Find the answer to your Linux question:
Results 1 to 3 of 3
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1

    Question NVidia screen problem

    HI ALL!
    I have a problem. I install Nvidia driver for linuux on Mandriva free 2006. It's works! BUT i have a little bug. My screen size resolution is 1024/768 And i have 15'' monitor. My screen is scrolled. It is not displayed wholly. Looks as if to place the picture of a 17'' monitor in 15''.
    It is the file of configuration of X-server:
    # nvidia-xconfig: X configuration file generated by nvidia-xconfig
    # nvidia-xconfig:  version 1.0  (buildmeister@builder3)  Wed Mar 29 14:43:26 PST 2006
    # File generated by XFdrake.
    # **********************************************************************
    # Refer to the XF86Config man page for details about the format of
    # this file.
    # **********************************************************************
    Section "ServerLayout"
        Identifier     "layout1"
        Screen         "screen1" 0 0
        InputDevice    "Keyboard1" "CoreKeyboard"
        InputDevice    "Mouse1" "CorePointer"
    Section "Files"
        # Multiple FontPath entries are allowed (they are concatenated together)
        # By default, Mandrake 6.0 and later now use a font server independent of
        # the X server to render fonts.
        FontPath        "unix/:-1"
    Section "Module"
        Load           "dbe" # Double-Buffering Extension
        Load           "v4l" # Video for Linux
        Load           "extmod"
        Load           "type1"
        Load           "freetype"
        Load           "glx" # 3D layer
    Section "ServerFlags"
        #DontZap # disable <Crtl><Alt><BS> (server abort)
     # allows the server to start up even if the mouse does not work
        #DontZoom # disable <Crtl><Alt><KP_+>/<KP_-> (resolution switching)
        Option         "allowmouseopenfail"
    Section "InputDevice"
        Identifier     "Keyboard1"
        Driver         "keyboard"
        Option         "XkbModel" "pc105"
        Option         "XkbLayout" "us,ru(winkeys)"
        Option         "XkbOptions" "grp:alt_shift_toggle,grp_led:scroll,compose:rwin"
    Section "InputDevice"
        Identifier     "Mouse1"
        Driver         "mouse"
        Option         "Protocol" "ExplorerPS/2"
        Option         "Device" "/dev/mouse"
        Option         "ZAxisMapping" "6 7"
    Section "Monitor"
        # TV fullscreen mode or DVD fullscreen output.
        # 768x576 @ 79 Hz, 50 kHz hsync
        Identifier     "monitor1"
        VendorName     "Plug'n Play"
        ModelName      ""
        HorizSync       30.0 - 70.0
        VertRefresh     50.0 - 150.0
        ModeLine       "1024x768" 50.0 768 832 846 1000 576 590 595 630
        ModeLine       "1024x768" 63.1 768 800 960 1024 576 578 590 616
    Section "Device"
        Identifier     "device1"
        Driver         "nvidia"
        VendorName     "nVidia"
        BoardName      "NVIDIA GeForce FX (generic)"
    Section "Screen"
        Identifier     "screen1"
        Device         "device1"
        Monitor        "monitor1"
        DefaultDepth    24
        Option         "DPMS"
        SubSection     "Display"
            Virtual     1024 768
            Depth       8
        SubSection     "Display"
            Virtual     1024 768
            Depth       15
        SubSection     "Display"
            Virtual     1024 768
            Depth       16
        SubSection     "Display"
            Virtual     1024 768
            Depth       24

  2. #2
    Open a console and login as root, then run xorgconfig to change the settings.

  3. #3
    Thx! It's help!

  4. $spacer_open

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts