Find the answer to your Linux question:
Results 1 to 4 of 4
High, I just installed Mandriva onto this ancient Dell Optiplex GX1 for basically a web browser. We are trying to run a network from Windows XP to share internet. For ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined! p0ptart's Avatar
    Join Date
    May 2006
    Location
    Tennessee
    Posts
    8

    Exclamation Total linux newbie


    High, I just installed Mandriva onto this ancient Dell Optiplex GX1 for basically
    a web browser. We are trying to run a network from Windows XP to share internet. For some reason it isnt connecting to the XP box. We have the IP and netmask and such setup, but yet we are still getting the "red x" on the network icon. We managed to get windows to recognize linux at one point but then it quickley disappeared. It keeps telling us that the Mandriva configuration isnt correct even though we have checked it a billion times. Samba is up and running, but we still dont have a network connection. Any ideas as to what the problem maybe?? I would love some help on this since i have been up for 24 hours now and im gettin extremely frustrated. Help please!!

  2. #2
    Linux Newbie
    Join Date
    Apr 2005
    Location
    CT --> PA
    Posts
    170
    each samba user will need an account on the system too, not only the samba share..

    meaning, make an account using the name of the XP box on the mandriva system, as well as an account by the same name on the samba share...make sure your samba system is broadcasting the same workgroup name that your XP box needs...

    those were two of the biggest obstacles that i ran in to setting up my dept's fileserver.


    oh, and a couple hours of sleep will help too.
    Chicks dig giant mechanized war machines

  3. #3
    Just Joined!
    Join Date
    May 2006
    Posts
    3
    Two other things you might want to check...

    If you're running shorewall, turn it off temporarily and see if the network will work then. If it does, you'll probably need to add two lines to your configuration file. This is an excellent howto given to me by someone on another forum when I was having issues with my network working while shorewall was turned on.

    As for Samba, sometimes you have to add your network ip's to the configuration file. I never had to do this in Mandriva, but I have had to do this in other distros. You can do this by logging in as root *open up the terminal, type "su", press enter, enter the root password, press enter again* and editing the /etc/samba/smb.conf file *type "kedit /etc/samba/smb.conf"*. If you're using KDE you can just open Konqueror and right click on the smb.conf file then go to actions>edit as root. Add your network ip's to the line that says "hosts allow =", and then save.

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined! p0ptart's Avatar
    Join Date
    May 2006
    Location
    Tennessee
    Posts
    8

    Thanks

    Well, we had Samba set up correctly and got some sleep, and it still didnt work. Turns out that the DNS wasent set up right.....it sucked...lol. But thanks for trying to help.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •