Find the answer to your Linux question:
Results 1 to 4 of 4
This is my first post here! Greetings! I am trying to install Mandriva Linux 3 CD Set on my second hard drive. When I get almost all the way through ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    May 2006
    Location
    Arizona
    Posts
    4

    Question Error Opening RPM Database


    This is my first post here! Greetings!

    I am trying to install Mandriva Linux 3 CD Set on my second hard drive.

    When I get almost all the way through the installation I get this:

    An error occurred
    Error opening RPM Database
    Packages database in /mnt/var/lib/rpm

    I understand this refers to the Red Hat Package Manager, and am learning more all the time.

    This is a new install on a new hard drive (40 GB)

    I did an automatical partition and it made 3 partitions for me.


    I tried doing a bare minimum installation and I got:

    An error occurred
    MKINITRD Failed:
    (MKINITRD -v -f /boot/initrd-2.6.12KDKSMP.IMG - -if needed
    2.6.12-12 MDKSMP)).


    Obviously I have no clue what to do next. I have searched this and other forums. I have used linux extensively at the University, but never installed it myself.

    I checked all the MD5's and they are fine.
    I will try burning another disk 1 and see if that changes anything.

    Thanks for any help!

    Just in case:

    Dell Dimension 8400 - Purchased Jan. 2005
    P4 3.4 GHz HT 1MB Cache
    DVD - Player, DVD - Recorder
    160GB Drive C
    40 GB Drive F
    512 MB Main Memory

  2. #2
    Linux Guru fingal's Avatar
    Join Date
    Jul 2003
    Location
    Birmingham - UK
    Posts
    1,539
    Looks nasty! I've never seen that error before ... which disturbs me a little because I've seen quite a few with Mandriva. I had a look into what mkinitrd is / does and I found a howto which says:
    mkinitrd creates an initial image used by the kernel for preloading the block device modules (such as IDE, SCSI or RAID) which are needed to access the root filesystem.
    So whatever's happening involves interaction with your kernel. I wonder if selecting an earlier kernel version would help? I think re-burning your disks is a good move. Let us know what happens.

    Btw - where are you downloading from? It might just be that you have an incomplete download ...
    I am always doing that which I can not do, in order that I may learn how to do it. - Pablo Picasso

  3. #3
    Just Joined!
    Join Date
    May 2006
    Location
    Arizona
    Posts
    4

    Unhappy Reburned CD

    Hey Thanks for the help and advice!

    I reburned CD #1 and for a lot further into the install.
    I get to the point of adding users and added just myself.
    I then selected for automatically logging me in and using the KDE GUI by default. At that point I then get this like before:

    An error occurred
    mkinitrd failed:
    (mkinitrd -v -f /boot/initrd-2.6.12-12mdksmp.img --if needed
    2.6.12-12mdksmp)).

    That 3rd line of the error looks like it is suggesting to me that I hit F1 for more options at the very first install screen and enter that command. Maybe I will try that.

    How could I find out exactly what mkinitrd does, so that I can see what specifically is failing and maybe how to fix it? (I will look for this answer myself as well). I saw your post but need to see why it's failing.

    I can't imagine what could be wrong. I have a new hard disk dedicated just for this Mandriva install (it is being assigned the drive letter 'F:' which I guess is OK). The only other thing I have is a C: drive with my Windows XP installation. They are supposed to be completely separate, and I should be able to pick any drive letter for Mandriva to be on.

    Question: Is there another version of linux I could try that should be easier to set up for a beginner, I don't care which version I use, I just need to be able to compile and run SimpleScalar for high performance computing research. www.simplescalar.com

    I hope this doesn't turn into months of trying to install Mandriva.

    Thanks for your help again!!

    - Richard

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined!
    Join Date
    May 2006
    Location
    Arizona
    Posts
    4

    Lightbulb Text mode installation

    I tried to install in text only mode and got more information!

    An error occurred
    rebuilding of rpm database failed

    rpmdb: program version 4.3 doesn't match environment version
    error: DB4 error(-30974) from dbenv-> open DB_VERSION_MISMATCH: database environment version mismatch
    error: cannot open packages index using db3 - (-30974)


    When I hit OK it says:

    An error occurred
    basesystem package not selected

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •