Find the answer to your Linux question:
Results 1 to 2 of 2
I am quite new to linux. I am running into a problem which is quite wierd. I had installed linux on primary slave by mistake and later wanted to use ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    May 2006
    Posts
    27

    Angry Grub have gone BRAINDEAD!!!


    I am quite new to linux. I am running into a problem which is quite wierd. I had installed linux on primary slave by mistake and later wanted to use in master boot. Following was the situation when I installed::
    Root /dev/hdb5
    Swap /dev/hdb6
    Home /dev/hdb7

    I read through the forum and found the thread for bootloader at length. I did exactly the way it is written there...

    Grub> find /boot/grub/stage1
    Grub> root(hd0,4)
    which gave me some info about file system that was ext something.
    Grub> kernel (hd0,4)/boot/vmlinuz ......
    Grub> initrd (hd0,4)/boot/init....
    then boot.

    System booted. It did work till the ""WELCOME TO MANDRAKELINUX 10.1. PRESS 'I' to enter interactive startup"" >>I did not do anything here<<

    The last screen that i can see says::

    Mounting root filesystem
    kjournald starting. Commit interval 5 seconds
    EXT3-fs: mounted filesystem with orderered data mode.
    Initrd finished
    Freeing unused kernel memory: 200k freed
    INIT: version 2.85 booring
    Mounting proc filesystem [OK]
    Mounting sysfs on /sys [OK]
    Unmounting initrd: [OK]
    Setting default font (lat0-16): [OK]

    Welcome to Mandrake Linux 10.1
    Press 'I' to enter interactive startup.
    COnfiguring kernel parameters: [ok]
    Setting clock (localtime): Wed May 24 01:37:47 KIST 2006 [ok]
    Loading default keymap [ok]
    Setting hostname localost: [ok]
    Initializing USB controller (uhci-hcd)[ok]
    Mount USB filesystem[ok]
    Loading USB printer[ok]
    Checking root filesystem
    fsck.ext3Possibly non-existent or swap device?
    :No such device or address while trying to open /dev/hdb5
    Failed to check filesystem. Do you want to repair the errors? (y/n)
    (beware,, you can lose data)



    Now I said yes and it asked root pass. I gave it and then it came up with


    Possibly non-existent or swap device?
    e2fsck 1.35 (28-feb-2004)
    fsck.ext3: No such device or address while trying to open /dev/hdb5 [FAILED]

    *** An error occurred during the file system check.
    *** Dropping you to a shell; the system will reboot
    *** when you leave the shell.
    Give root password for maintenance
    (or type Control-D for normal startup):

    Tried both and none is working now.

    This hdb5 was the thing that was seconday ide earlier now changed to (hd0,4)

    And to my surprise i can still load linux if i turn back things the way they were; ie. my hdd on Slave jumper settings without anything else.

    Please help...



  2. #2
    Just Joined!
    Join Date
    May 2006
    Posts
    27
    Another thing that I observed.
    For Grub::
    Since i am a bit familliar with GRUB. I tried looking in device.map which does not shows hd0 = dev/hda5 instead its hdb.
    For LILO:
    I can not change anything since when i do sbin/lilo it says error.

    Problem is I cant attach any new device or swap master and slave drives. Or for that matter USB. Now if i do i get filesystem errors. If i dont, run linux and then try fixing lilo.conf or grub menu I get errors compiling kernel. Since the device is not present... for instance...
    right now its like
    dev/hdb5 but it should be dev/hda5 in primary master. Now question is supposedly I put this as external USB drive that would be /dev/sda so in that case I ll again have to go through this cumbersome thing or can I save myself by adding entries like we do in NT loaders as follows:


    Linux Primary Master >>> when disk is master
    Linux Primary slave>>> when disk is slave
    Linux Primary USB Master >>> when disk is usb



    pls help.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •