Find the answer to your Linux question:
Page 1 of 3 1 2 3 LastLast
Results 1 to 10 of 25
Hi, I'm a Linux newbie, and I'm going insane! I'm trying to set up my speedtouch modem so I can connect to my Wanadoo internet account... It isn't going well. ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jun 2006
    Posts
    12

    Access denied?! HELP!


    Hi, I'm a Linux newbie, and I'm going insane!

    I'm trying to set up my speedtouch modem so I can connect to my Wanadoo internet account... It isn't going well.

    I followed various tutorials and discovered I needed to run something called "speedtouchconf.sh" with my old Windows 'alcaudsl.sys' in the directory. Well that's all fair and well... But when I ran it it said it could not delete 'speedtch' please delete it manually.

    I searched around and found the folder in sys/module, but found there was an 'access denied' message when I tried to delete it.

    I explored this forum for a while and discovered that even though I'm the only user on the machine, I'm not usually logged in as root.

    Following various guides, I used the Run command and entered "kdesu konqueror". It asked for my root password, which I entered, then it brought up a konqueror window, with that Welcome message. I navigated to the sys/module folder, and tried to delete speedtch... 'Access Denied'... But... I'm root?? Aren't I? :S

    Help me, if you can.

  2. #2
    Linux Guru fingal's Avatar
    Join Date
    Jul 2003
    Location
    Birmingham - UK
    Posts
    1,539
    Hi - Personally I wouldn't use a gui tool to delete a file in that directory. You are probably worried about using a command line (a 'CLI' we call it) ... actually it's easier to use in this case.

    Open up a terminal (looks like a TV screen) and become root. To do this type:
    su

    Then enter your password. To navigate to the correct directory type:
    cd /sys/module

    To delete the file type rm -f <name_of_file>

    Replace <name_of_file> with the file you want to delete. He he ... some people copy that word for word!!

    I nearly forgot to talk about the ls command (lists files in your current directory). Type ls -al and scroll around. Has your file gone?

    To leave root type 'exit' and 'exit' again to leave the CLI. Did that work? While in the terminal you might want to type man rm to bring up the manual for that command. They are very powerful and useful. GUIs also have their uses, but not in this case.
    I am always doing that which I can not do, in order that I may learn how to do it. - Pablo Picasso

  3. #3
    Just Joined!
    Join Date
    Jun 2006
    Posts
    12
    Right, I think this is working, but it says "cannot remove 'speedtch': Is a directory", I think your guide was meant for individual files, yes? What do I type for deleting an entire directory?

  4. $spacer_open
    $spacer_close
  5. #4
    Linux Guru fingal's Avatar
    Join Date
    Jul 2003
    Location
    Birmingham - UK
    Posts
    1,539
    Quote Originally Posted by DrLilo
    Right, I think this is working, but it says "cannot remove 'speedtch': Is a directory", I think your guide was meant for individual files, yes? What do I type for deleting an entire directory?
    The command is rmdir -fr /path_to_directory

    What that will do is recursively force the deletion of all files in that directory. Then you should also be able to delete the actual directory.
    I am always doing that which I can not do, in order that I may learn how to do it. - Pablo Picasso

  6. #5
    Just Joined!
    Join Date
    Jun 2006
    Posts
    12
    Thanks for your help, but it doesn't seem to have worked.

    I ran rm dir -fr /sys/module/speedtch and it began outputting the following:

    rm: cannot remove '/sys/module/speedtch/sections/.strtab': Operation not permitted
    rm: cannot remove '/sys/module/speedtch/sections/.symab': Operation not permitted
    rm: cannot remove '/sys/module/speedtch/sections/.bss': Operation not permitted
    etc. etc.

  7. #6
    Linux User Giles's Avatar
    Join Date
    May 2005
    Location
    Gloucestershire and Cambridge, UK
    Posts
    283
    Are you still root when you tried those commands? If you are the superuser, there shouldn't be any commands you're not permitted to run, nor any files/folders you're not permitted to change/delete*.

    Toodle-oo
    Giles
    *I'm sure someone'll correct me if this isn't entirely true, but certainly I've never met anything that wasn't allowed as root.
    "Our greatest fear is not that we are powerless. Our greatest fear is Microsoft"
    Registered linux user #391027

  8. #7
    Just Joined!
    Join Date
    Jun 2006
    Posts
    12
    That's really odd... I am definately still root, it still says '[root@localhost module]#' where I'm about to type.

  9. #8
    Linux Guru fingal's Avatar
    Join Date
    Jul 2003
    Location
    Birmingham - UK
    Posts
    1,539
    Quote Originally Posted by DrLilo
    Thanks for your help, but it doesn't seem to have worked.

    I ran rm dir -fr /sys/module/speedtch and it began outputting the following:

    rm: cannot remove '/sys/module/speedtch/sections/.strtab': Operation not permitted
    rm: cannot remove '/sys/module/speedtch/sections/.symab': Operation not permitted
    rm: cannot remove '/sys/module/speedtch/sections/.bss': Operation not permitted
    etc. etc.
    Hi - Did you type the command correctly? I notice you typed:
    rm dir -fr /sys/module/speedtch

    But you should type rmdir -fr /sys/module/speedtch

    Take out the space. Linux error messages aren't always very descriptive. What it's really saying is, 'I don't/can't understand that syntax.' Giles is right: when you're root you can do anything you want ... Be careful
    I am always doing that which I can not do, in order that I may learn how to do it. - Pablo Picasso

  10. #9
    Just Joined!
    Join Date
    Jun 2006
    Posts
    12
    [root@localhost module]# rmdir -fr /sys/module/speedtch
    rmdir: invalid option -- f
    Try 'rmdir --help' for more information.

    This isn't looking good is it?

  11. #10
    Linux Guru fingal's Avatar
    Join Date
    Jul 2003
    Location
    Birmingham - UK
    Posts
    1,539
    Hmmm ... it may be partly my fault (I'm not working from a Linux box today). The command doesn't like the -f switch. Don't Panic! I'm at fault because rmdir only removes empty directories!

    What a mess. Try rm -rf /sys/module/speedtch THEN try rmdir /sys/module/speedtch

    Btw I have a headache now. I think the extra switch might do it.
    I am always doing that which I can not do, in order that I may learn how to do it. - Pablo Picasso

Page 1 of 3 1 2 3 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •