Find the answer to your Linux question:
Results 1 to 5 of 5
Hi guys!!! I tried to upgrade 10.0 -> 2006 a couple of times... all went well. But when i rebooted i got hung up on the splash screen for a ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jun 2006
    Posts
    3

    Upgrade sleep problem


    Hi guys!!!

    I tried to upgrade 10.0 -> 2006 a couple of times... all went well.
    But when i rebooted i got hung up on the splash screen for a few minutes
    I deactivated the Xlogon, but i got the same problem, when i wanted to log in with normal users, i had to wait that he gave me the password prompt.

    i checked the process table, and there's a "sleep 1" hanging around... each time it dies another one comes around ( very frustrating to kill a renewable process that only lives for one second )

    So i tried do to a 10.0 -> 10.1... again all went well, but i got the same splash/logon problem...

    At the end of my stuburness, i turn to you, my brothers in arms...

    what to do?
    where can i find a doc about it? ( although a straight answer is way welcomed )


    Thank you for your attention.
    Nuno

    PS: using the urpmi upgrade technique

  2. #2
    Just Joined!
    Join Date
    Jun 2006
    Posts
    3
    up !!!

  3. #3
    Linux Guru fingal's Avatar
    Join Date
    Jul 2003
    Location
    Birmingham - UK
    Posts
    1,539
    Not easy to solve at all. Have you tried 'upgrading' (rather than a fresh install) your original OS? I think it might over-write whatever utility is causing the problem. If your data is in a separate /home partition it should be fairly safe.

    Thinking about it, sleep is a utility in its own right, and you can find it in /bin/sleep ... to prove this (assuming you could get to a terminal) type: whereis sleep . I would be tempted to remove it, or zip it up and remove the original binary.

    These are just ideas of course ... no guarantee they will work. Some process or other seems to be calling the sleep utility for one second only; so logically it would be a good idea to disable that option.

    To use sleep from the command line you would type sleep n, where n is the number of seconds you want a given process to pause for.
    I am always doing that which I can not do, in order that I may learn how to do it. - Pablo Picasso

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined!
    Join Date
    Jun 2006
    Posts
    3
    no no no

    i didn't do a fresh install i did an upgrade

    on this order:
    i installed 10.0
    reboot
    login root
    removed urpmi medias
    install urpmi 2006 medias ( vive easyurpmi )
    urpmi urpmi
    urpmi --auto-select
    reboot

    and on the login screen i got the sandwatch for minutes and minutes

    after the wait everything's normal... but each time i have this lag on the login when i boot.


    PS: thanks for your reply, man...

  6. #5
    Linux Guru fingal's Avatar
    Join Date
    Jul 2003
    Location
    Birmingham - UK
    Posts
    1,539
    You should type: dmesg in a terminal. Any clues in there? Also check your log files in /var/log and look for error messages.

    Normally 2006 boots very quickly ... Mandriva 2005 LE was the slow booting version. I wonder what went wrong?
    I am always doing that which I can not do, in order that I may learn how to do it. - Pablo Picasso

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •