Find the answer to your Linux question:
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 20
Hello every one, Well I booted up mandriva for the first time since I got my new computer hom. It doesn't boot into the GUI it just gives me a ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    May 2006
    Posts
    15

    Mandriva Stuck bash-3.00$ please help


    Hello every one,


    Well I booted up mandriva for the first time since I got my new computer hom. It doesn't boot into the GUI it just gives me a blue backround and a little black window with "bash-3.00$" and what looks like a prompt.

    The keyboard won't let me type anything though and the mouse doesn't move on the screen so where do I go from here?

    This is dual booting machine.
    Linux was put on by our local computer repair shop. They told me it was booting fine.

  2. #2
    Blackfooted Penguin daark.child's Avatar
    Join Date
    Apr 2006
    Location
    West Yorks
    Posts
    4,393
    Are you sure you can't enter anything using the keyboard? What type of keyboard are you using? If the keyboard was working you would need to enter a username and password (the password is not echoed back) then enter "startx" to run a gui. Usually the mouse won't work in text mode so don't worry about that for now.

  3. #3
    Just Joined!
    Join Date
    May 2006
    Posts
    15
    Well I tried typing and nothing came up on the screen. no new letters, nothing.

    how do I log in in text mode, I'll give it a try. It probably still has the default settings.

  4. #4
    Blackfooted Penguin daark.child's Avatar
    Join Date
    Apr 2006
    Location
    West Yorks
    Posts
    4,393
    Quote Originally Posted by mikev727
    Well I tried typing and nothing came up on the screen. no new letters, nothing.

    how do I log in in text mode, I'll give it a try. It probably still has the default settings.
    Logging in, in text mode is what I was describing above (ie. the gui is not running and you are in a text based interface). You didn't answer all the questions e.g. what type of keyboard? If the GUI is not running and you can't enter anything using your keyboard, then unfortunately you may have to reinstall.

  5. #5
    Just Joined!
    Join Date
    May 2006
    Posts
    15
    sorry I forgot that one.

    I just have a memorex keyboard. it has a few quick keys for email and web browser and such.

    I just realized I had a jump drive plugged in when I was trying to load it would that effect it?

    Also on another note it never asked me for a login of any type.

  6. #6
    Blackfooted Penguin daark.child's Avatar
    Join Date
    Apr 2006
    Location
    West Yorks
    Posts
    4,393
    I don't think having a jump drive plugged in would affect the keyboard (unless they are both USB). I would suggest that you reinstall if you keep having problems.

  7. #7
    Linux Enthusiast KenJackson's Avatar
    Join Date
    Jun 2006
    Location
    Maryland, USA
    Posts
    510

    Arrow Try CTRL-ALT-F1

    Press CTRL-ALT-F1 (i.e., hold down CTRL and ALT then press F1). Hopefully that will give you a text-mode login prompt.

    Login as root and look at /var/log/messages and /var/log/Xorg.0.log, especially lines in Xorg.0.log that start with "(EE)", which are error messages.

    You can try this command to restart the display manager: service dm restart

    You can switch back to graphics mode with CTRL-ALT-F7 (or maybe CTRL-ALT-F8 ).

  8. #8
    Just Joined!
    Join Date
    May 2006
    Posts
    15
    Ok here we go..

    I did the Alt+ctrl+F1 and got a console that worked

    this is what I got AFTER typing startkde

    xset: unable to open display ""
    xsetroot: unable to open display ' '
    xmodmap: unable to open display ' '
    xmodmap: unable to open display ' '
    Error "home/tony/tmp/kde-tony" is own by uid 0 instead of uid 500
    Error "home/tony/tmp/kde-tonyjrQp1P" is own by uid 0 instead of uid 500
    Error Can not create link from "/home/tony/.kde/cache-localhost" to "/var/tmp/kdecache-tony"
    Error Can Not creat link from "/home/tony/.kde/cache-localhost" to "/var/tmp/kdecache-tonyorQLAQ"
    startkde: starting up...

    (gnome-volume-manager: 4335);Gtk-WARNING **: cannot open display:
    ksplash:cannot connect to X server
    kdeinit: Aborting. $DISPLAY is not set.
    Warning connect() failed: :No Such file or directory
    ksmserver: cannot connect to X server
    ERROR: Couldn't attach to DCOP server!
    startkde: Shutting down...
    Warnning: connect() failed : : No such file or directory
    Error can't contact kdeinit!
    startkde: Running shutdown scripts...
    startkde: Done.


    Sooo what should I do now?

  9. #9
    Linux Enthusiast KenJackson's Avatar
    Join Date
    Jun 2006
    Location
    Maryland, USA
    Posts
    510

    service dm stop

    There are two ways to start X (KDE):
    • Use 'startkde' or 'startx' or similar as a normal user, as you did, or

    • Allow a display manager to start it and present a graphical login

    Most people prefer the second method, and that is normally the way Mandriva is installed. But it looks like you were logged in as user 'tony' instead of 'root' and used the first method.

    In either case, you apparently already have X running but in some odd or hung state. To stop the existing X, try one of these:
    • From the blue background GUI, press CTRL-ALT-BACKSPACE

    • From the command prompt as 'root', type "service dm stop".

    If it stops, then maybe you can use 'startkde' if you want.

    But it would be better to get the display manager working so you get the normal graphical login. To do that, you need to look in the logs in /var/log/ to see what the problem is.

  10. #10
    Blackfooted Penguin daark.child's Avatar
    Join Date
    Apr 2006
    Location
    West Yorks
    Posts
    4,393
    There is a problem with your permissions which maybe why X won't run properly for you. Try doing the following,
    Code:
    $su -
    #chown -R tony:tony /home/tony
    #init 3 (this will kill the currently running x server)
    #exit
    $startx (this will hopefully start KDE)
    If you keep having problems starting X, try doing
    Code:
    $su -
    #xfdrake (this automatically configures your display settings)
    Are you using the same hardware as that which was used when Mandriva was installed on your system?

Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •