Find the answer to your Linux question:
Results 1 to 10 of 10
I installed the nVidia driver from the NVIDIA-Linux-x86-1.0-8762-pkg1.run file. It modifies the xorg.conf file, but when i run the startx command the entire system locks up. After I press the ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Feb 2006
    Location
    Iowa
    Posts
    15

    nVidia Driver Crashes Linux on KDE Start


    I installed the nVidia driver from the NVIDIA-Linux-x86-1.0-8762-pkg1.run file. It modifies the xorg.conf file, but when i run the startx command the entire system locks up. After I press the reset button I change the driver back from "nvidia" back to "nv" and KDE starts, but none of the nVidia features such as GLX module work. Is there something else that is set wrong? Here is my config file:

    Section "ServerLayout"
    Identifier "layout1"
    Screen "screen1" 0 0
    InputDevice "Keyboard1" "CoreKeyboard"
    InputDevice "Mouse1" "CorePointer"
    EndSection

    Section "Files"

    # Multiple FontPath entries are allowed (they are concatenated together)
    # By default, Mandrake 6.0 and later now use a font server independent of
    # the X server to render fonts.
    FontPath "unix/:-1"
    EndSection

    Section "Module"
    Load "dbe" # Double-Buffering Extension
    Load "v4l" # Video for Linux
    Load "extmod"
    Load "type1"
    Load "freetype"
    Load "glx" # 3D layer
    EndSection

    Section "ServerFlags"

    #DontZap # disable <Crtl><Alt><BS> (server abort)
    #DontZoom # disable <Crtl><Alt><KP_+>/<KP_-> (resolution switching)
    # allows the server to start up even if the mouse does not work
    Option "allowmouseopenfail"
    EndSection

    Section "InputDevice"
    Identifier "Keyboard1"
    Driver "keyboard"
    Option "XkbModel" "microsoftmult"
    Option "XkbLayout" "en_US"
    Option "XkbOptions" "compose:rwin"
    EndSection

    Section "InputDevice"
    Identifier "Mouse1"
    Driver "mouse"
    Option "Protocol" "ExplorerPS/2"
    Option "Device" "/dev/mouse"
    Option "ZAxisMapping" "6 7"
    EndSection

    Section "Monitor"

    # TV fullscreen mode or DVD fullscreen output.
    # 768x576 @ 79 Hz, 50 kHz hsync
    Identifier "monitor1"
    VendorName "Plug'n Play"
    ModelName "MICRON 700Dx"
    HorizSync 30.0 - 70.0
    VertRefresh 50.0 - 160.0
    ModeLine "768x576" 50.0 768 832 846 1000 576 590 595 630
    ModeLine "768x576" 63.1 768 800 960 1024 576 578 590 616
    ModeLine "1152x864_120" 176.0 1152 1240 1368 1584 864 865 868 926 -hsync +vsync
    ModeLine "1152x864_100" 143.5 1152 1232 1360 1568 864 865 868 915 -hsync +vsync
    ModeLine "1152x864_85" 119.7 1152 1224 1352 1552 864 865 868 907 -hsync +vsync
    ModeLine "1152x864_75" 105.0 1152 1224 1352 1552 864 865 868 902 -hsync +vsync
    ModeLine "1152x864_60" 81.6 1152 1216 1336 1520 864 865 868 895 -hsync +vsync
    ModeLine "1152x864_50" 66.8 1152 1208 1328 1504 864 865 868 889 -hsync +vsync
    EndSection

    Section "Device"
    Identifier "device1"
    Driver "nvidia"
    VendorName "nVidia"
    BoardName "NVIDIA GeForce FX (generic)"
    EndSection

    Section "Screen"
    Identifier "screen1"
    Device "device1"
    Monitor "monitor1"
    DefaultDepth 24
    Option "DPMS"
    SubSection "Display"
    Virtual 1152 864
    Depth 8
    EndSubSection
    SubSection "Display"
    Virtual 1152 864
    Depth 15
    EndSubSection
    SubSection "Display"
    Virtual 1152 864
    Depth 16
    EndSubSection
    SubSection "Display"
    Virtual 1152 864
    Depth 24
    EndSubSection
    EndSection

  2. #2
    Linux Guru
    Join Date
    Nov 2004
    Posts
    6,110
    It all looks correct there at a glance. What card are you using? Have you tried any of the older drivers, sometimes there might be card specific bugs in the driver.

  3. #3
    Just Joined!
    Join Date
    Feb 2006
    Location
    Iowa
    Posts
    15
    I am using the nVidia GeForce 5200FX. I haven't tried any other drivers. I also tried changing the AGP speed from 8X to 4X and had no luck.

  4. #4
    Linux Guru
    Join Date
    Nov 2004
    Posts
    6,110
    I'm not sure on this one, unless someone else has any ideas. Maybe try an older driver release and see if it is any better.

  5. #5
    Linux Guru techieMoe's Avatar
    Join Date
    Aug 2004
    Location
    Texas
    Posts
    9,496
    Did you modprobe nvidia after you installed the drivers and before you typed startx?
    Registered Linux user #270181
    TechieMoe's Tech Rants

  6. #6
    Linux Engineer spencerf's Avatar
    Join Date
    Jan 2005
    Location
    Syracuse, NY
    Posts
    1,144
    Section "Screen"
    Identifier "screen1"
    Device "device1"
    Monitor "monitor1"
    DefaultDepth 24
    Option "DPMS"
    SubSection "Display"
    Virtual 1152 864
    Depth 8
    EndSubSection
    SubSection "Display"
    Virtual 1152 864
    Depth 15
    EndSubSection
    SubSection "Display"
    Virtual 1152 864
    Depth 16
    EndSubSection
    SubSection "Display"
    Virtual 1152 864
    Depth 24
    EndSubSection
    EndSection
    try changing this section a little because all you have setup up is virtual screens and nothing for depth 24. Try something sane like:

    Code:
    Section "Screen"
        Identifier  "screen1"
        Device      "device1"
        Monitor     "monitor1"
        DefaultDepth 24
    
        Subsection "Display"
            Depth       8
            Modes       "1280x1024" "1024x768" "800x600" "640x480"
            ViewPort    0 0
        EndSubsection
        Subsection "Display"
            Depth       16
            Modes       "1280x1024" "1024x768" "800x600" "640x480"
            ViewPort    0 0
         EndSubsection
         Subsection "Display"
             Depth       24
             Modes      "1280x1024" "1024x768" "800x600"
         EndSubsection
         EndSection
    also if you post the output of

    cat /var/log/Xorg.0.log | grep EE

    that could be helpful
    All right, brain. You don't like me and I don't like you, but let's just do this and I can get back to killing you with beer. All New Users Read This!!! If you have a grub problem please look at GRUB MANUAL

  7. #7
    Linux Engineer spencerf's Avatar
    Join Date
    Jan 2005
    Location
    Syracuse, NY
    Posts
    1,144
    Also the driver for keyboard has changed to kbd depending on what version of X your are running but I guess since just changing the driver to nv everything works this might not be your problem but worth a shot.


    Section "InputDevice"
    Identifier "Keyboard1"
    Driver "keyboard"
    Option "XkbModel" "microsoftmult"
    Option "XkbLayout" "en_US"
    Option "XkbOptions" "compose:rwin"
    EndSection
    change the Driver "keyboard" to

    Driver "kbd"
    All right, brain. You don't like me and I don't like you, but let's just do this and I can get back to killing you with beer. All New Users Read This!!! If you have a grub problem please look at GRUB MANUAL

  8. #8
    Just Joined!
    Join Date
    Feb 2006
    Location
    Iowa
    Posts
    15
    I changed everything suggested above in the xorg.conf file. Before rolling back to legacy drivers I typed "modprobe nvidia" and it returned a fatal error and said they weren't recognizeable or something like that. I then rolled back the drivers and changed the xorg.conf configuration to the way the readme said. I then typed "modprobe nvidia" again and it returned nothing. When I started X the machine still locked up. I had to go back to the "nv" driver to successfully start X.

    For what its worth, when the machine starts up it says it is loading "DKMS". The next line says that the nVidia 8762 Driver is already included in the kernel. I don't know if that would have anything to do with it or not though.

  9. #9
    Just Joined!
    Join Date
    Jun 2006
    Posts
    6

    me too

    I did this: i copy screen section from my old Xorg.conf and paste it on the new xorg.conf. it works.(delete screen section of the new xorg.conf)

  10. #10
    Just Joined!
    Join Date
    Feb 2006
    Location
    Iowa
    Posts
    15
    Using the screen config from the old xorg.conf file did not work. Here are the results from cat /var/log/Xorg.0.log | grep EE :

    (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
    (II) Loading extension MIT-SCREEN-SAVER
    (EE) /usr/X11R6/lib/modules/extensions/libglx.so is an unrecognized module type
    (EE) Failed to load module "glx" (unknown module type, 6)

    Earlier it was returning errors about module "nvidia" being an unkown module type, 6.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •