Find the answer to your Linux question:
Results 1 to 7 of 7
i have an external ntfs formated hd i want to access on my normal user acount as at the moment i can only access it from root which is not ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jun 2006
    Location
    Nelspruit, South Africa
    Posts
    7

    need advice to set permisions for usb external ntfs formated hd


    i have an external ntfs formated hd i want to access on my normal user acount as at the moment i can only access it from root which is not a good thing
    i do not want to write to the disk only access the data on it
    any help is welcome
    thnx

  2. #2
    Linux Engineer
    Join Date
    Oct 2004
    Location
    Vancouver
    Posts
    1,366
    If you want everyone to be able to read it then use 744, if you want read and execute access then 755. Plus you can always use sudo to write to it.
    Operating System: GNU Emacs

  3. #3
    Just Joined!
    Join Date
    Jun 2006
    Location
    Nelspruit, South Africa
    Posts
    7
    well i did try :
    cmod rwx 744 755 and 777 dimilion /mnt/external -R
    and i got the same result as when i previously tried an ls on that directory/hard drive :
    ls /mnt/external : permission denied

    nb. I am rather new to Linux so i'm not too familiar with some of the commands

    thanks for the help

  4. $spacer_open
    $spacer_close
  5. #4
    Linux Guru bigtomrodney's Avatar
    Join Date
    Nov 2004
    Location
    Ireland
    Posts
    6,133
    The filesystem is NTFS, it is very difficult and quite unreliable to write to NTFS. It is disabled by default. Have a look into FUSe or Captive-NTFS if you must, otherwise you may need to format in FAT32.
    Last edited by bigtomrodney; 06-28-2006 at 12:32 PM.

  6. #5
    Just Joined!
    Join Date
    Jun 2006
    Location
    Nelspruit, South Africa
    Posts
    7
    like i said i dont want to be able to write to the disk , all i want to do is access and execute the data that is on the disk so ....
    the poblem :
    /mnt/external(the usb external hd in question) is only accesible if i log in with root, when i log in with my user account created during installation whom at this stage i've added to all groups and gave as much rights as possible i get no access to the folder/drive i cant even view its contents .

    what i've tried to resolve probelm :
    ive done a chmod on the drive adding 744 755 and 777 to read write and execute, all with the same result: me still not being able to gain access to the drive when logged in with my normal user account, i've even tried adding rights in the kde gui all with no results .....

    so if anybody who stumbles upon this thread can assist me in any way to resolve this problem i will be very gratefull ..
    thanks for the replys thus far

  7. #6
    Just Joined!
    Join Date
    Jun 2004
    Location
    Portugal
    Posts
    47
    You can try the following (with the drive unmounted):

    Code:
    chmod 755 /mnt/external
    edit /etc/fstab and make sure the line refering to your external drive looks like this (especially the umask part):

    Code:
    /dev/sda1 /mnt/external ntfs user,umask=0022,nls=iso8859-1,ro 0 0
    Now mount the drive and use it as a regular user.

  8. #7
    Just Joined!
    Join Date
    Jun 2006
    Location
    Nelspruit, South Africa
    Posts
    7
    Thank you very much Hugo problem has been resolved

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •