Find the answer to your Linux question:
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 12
Hi, I am having a strange problem in my laptop( Dell latitude 620). I have installed mandriva linux. Even if i connect headphones in the jack provided, the audio can ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Aug 2006
    Posts
    6

    sound in both speaker and headphones


    Hi,

    I am having a strange problem in my laptop( Dell latitude 620). I have installed mandriva linux.

    Even if i connect headphones in the jack provided, the audio can be heared both in headphone and also through inbuilt speakers of the laptop.

    I am using AlsaMixer 1.0.11.


    please see the technical details below:



    [root@santhosh santhosh]# uname -a
    Linux santhosh 2.6.12-12mdksmp #1 SMP Fri Sep 9 17:43:23 CEST 2005 i686 Genuine Intel(R) CPU T2500 @ 2.00GHz unknown GNU/Linux



    [root@santhosh santhosh]# lsmod | grep snd
    snd_seq_dummy 3524 0
    snd_seq_oss 33024 0
    snd_seq_midi_event 6880 1 snd_seq_oss
    snd_seq 51504 5 snd_seq_dummy,snd_seq_oss,snd_seq_midi_event
    snd_seq_device 7884 3 snd_seq_dummy,snd_seq_oss,snd_seq
    snd_pcm_oss 50368 0
    snd_mixer_oss 17952 1 snd_pcm_oss
    snd_hda_intel 14752 1
    snd_hda_codec 83872 1 snd_hda_intel
    snd_pcm 83812 3 snd_pcm_oss,snd_hda_intel,snd_hda_codec
    snd_timer 22596 2 snd_seq,snd_pcm
    snd_page_alloc 9384 2 snd_hda_intel,snd_pcm
    snd 48644 11 snd_seq_oss,snd_seq,snd_seq_device,snd_pcm_oss,snd _mixer_oss,snd_hda_intel,snd_hda_codec,snd_pcm,snd _timer
    soundcore 8256 1 snd


    [root@santhosh santhosh]# lspci
    00:00.0 Host bridge: Intel Corporation Mobile Memory Controller Hub (rev 03)
    00:02.0 VGA compatible controller: Intel Corporation Mobile Integrated Graphics Controller (rev 03)
    00:02.1 Display controller: Intel Corporation Mobile Integrated Graphics Controller (rev 03)
    00:1b.0 Class 0403: Intel Corporation 82801G (ICH7 Family) High Definition Audio Controller (rev 01)
    00:1c.0 PCI bridge: Intel Corporation 82801G (ICH7 Family) PCI Express Port 1 (rev 01)
    00:1c.1 PCI bridge: Intel Corporation 82801G (ICH7 Family) PCI Express Port 2 (rev 01)
    00:1c.2 PCI bridge: Intel Corporation 82801G (ICH7 Family) PCI Express Port 3 (rev 01)
    00:1d.0 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI #1 (rev 01)
    00:1d.1 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI #2 (rev 01)
    00:1d.2 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI #3 (rev 01)
    00:1d.3 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI #4 (rev 01)
    00:1d.7 USB Controller: Intel Corporation 82801G (ICH7 Family) USB2 EHCI Controller (rev 01)
    00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev e1)
    00:1f.0 ISA bridge: Intel Corporation 82801GBM (ICH7-M) LPC Interface Bridge (rev 01)
    00:1f.2 IDE interface: Intel Corporation 82801GBM/GHM (ICH7 Family) Serial ATA Storage Controllers cc=IDE (rev 01)
    00:1f.3 SMBus: Intel Corporation 82801G (ICH7 Family) SMBus Controller (rev 01)
    03:01.0 CardBus bridge: O2 Micro, Inc. OZ601/6912/711E0 CardBus/SmartCardBus Controller (rev 40)
    09:00.0 Ethernet controller: Broadcom Corporation NetXtreme BCM5752 Gigabit Ethernet PCI Express (rev 02)
    0c:00.0 Network controller: Intel Corporation: Unknown device 4222 (rev 02)

  2. #2
    Just Joined!
    Join Date
    Jul 2006
    Location
    Raddolugama, Sri Lanka
    Posts
    27
    Cant u just turn off the speakers? Anyways try to configure the sound from the KDE control center. (Under System Menu). If it becomes desperate u can always disable the speaker hardware from the drakconf.

  3. #3
    Just Joined!
    Join Date
    Aug 2006
    Posts
    6
    Hi rooot,

    Thanks for your reply. Nice solution. But i dont know how to i disable the speaker hardware. I will be very thankful for you if you provide me the steps to disable the inbuilt speaker in my laptop.

  4. #4
    Linux Guru bigtomrodney's Avatar
    Join Date
    Nov 2004
    Location
    Ireland
    Posts
    6,132
    I would check your settings in Kmix and check that "External Amplifier" is set to on and that headphone auto-sensing is on too. Other than that I have had problems with Mandriva using the wrong driver for the soundcard in my Inspiron. do you find it doesn't always load on boot?

  5. #5
    Just Joined!
    Join Date
    Aug 2006
    Posts
    6
    Hi bigtomrodney,

    I checked all those stuffs in kmix. There is no separate option for headphone and inbuilt speaker.The options that i have in my Kmix are

    1) Master
    2) PCM
    3) Capture Mix

    Even i tried installing the latest driver from ALSA. But the problem appeared again.

    The better solution fot this will be disabling the inbuilt speaker.
    i dont know how to disable the inbuilt speaker. Is there any option available ?

  6. #6
    Just Joined!
    Join Date
    Aug 2006
    Posts
    6
    Is there a way to disable the laptop speaker ????
    I dont need the laptop speaker anymore.....

  7. #7
    Linux Guru fingal's Avatar
    Join Date
    Jul 2003
    Location
    Birmingham - UK
    Posts
    1,539
    Quote Originally Posted by san_irtt
    Is there a way to disable the laptop speaker ????
    I dont need the laptop speaker anymore.....
    Hi - I'm not good with laptops, but I think Kmixer has an 'external speaker' or just 'speaker'(?) option. Maybe if you just disabled it there it would be easiest.

    If it was a desktop PC I would suggest taking the case off and disconnecting the external speaker cable from the motherboard.

    There may be an option in your BIOS settings to disable the speaker. You would need to explore, but be cautious about what you alter.
    I am always doing that which I can not do, in order that I may learn how to do it. - Pablo Picasso

  8. #8
    Just Joined!
    Join Date
    Aug 2006
    Posts
    6
    Dear fingal,

    Thanks for your reply.
    Those options are not listed. Thats why i posted in this forum.

  9. #9
    Linux Guru fingal's Avatar
    Join Date
    Jul 2003
    Location
    Birmingham - UK
    Posts
    1,539
    Quote Originally Posted by san_irtt
    Dear fingal,

    Thanks for your reply.
    Those options are not listed. Thats why i posted in this forum.
    I see Well, I have one further idea. I see that you're using ALSA. If you open a terminal and type amixer this should give you ALSA's sound mixer. If you scroll around using the <--- and ---> arrows on your keyboard you might find an external speaker channel which you can turn down. Once done, you then press the Esc. key to exit this.

    Just an idea.
    I am always doing that which I can not do, in order that I may learn how to do it. - Pablo Picasso

  10. #10
    Just Joined!
    Join Date
    Jan 2007
    Posts
    2

    Alsa 1.0.13

    I had a similar problem for the longest time, now being able to get headphones to work. I found looking around online that there was a change in alsa1.0.13 which allowed the volume for the headphones to be set along with the main speakers. Although not automatic, perhaps if you upgrade to alsa1.0.13 you will be able to turn the speaker volume to 0, then turn the headphone volume up. This has worked for me.

Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •