Find the answer to your Linux question:
Results 1 to 3 of 3
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1

    Gaim GTK help required

    i have recently installed mandriva 2006
    while installing Gaim 1.5 on it, it gave the following error
    checking for GLIB - version >= 2.0.0... yes (version 2.8.1)
    checking for pkg-config... (cached) /usr/bin/pkg-config
    checking for GTK+ - version >= 2.0.0... no
    *** Could not run GTK+ test program, checking why...
    *** The test program failed to compile or link. See the file config.log for the
    *** exact error that occurred. This usually means GTK+ is incorrectly installed.
    configure: error:
    *** GTK+ 2.0 is required to build Gaim; please make sure you have the GTK+
    *** development headers installed. The latest version of GTK+ is
    *** always available at

    but gtk is surely installed, i checked it in mandriva control center (add/remove programs)
    gtk 2.8.3 is installed

    what shud i do?
    i thought installing gtk-devel may help and tried to install that, but it is not installing ... due to pango etc.


  2. #2
    Blackfooted Penguin daark.child's Avatar
    Join Date
    Apr 2006
    West Yorks
    You need to install gtk2-devel in order to build applications that rely on gtk2. If you are having problems installing packages, then go to easyurpmi and setup the main, contrib, plf and updates repos for your version of Mandriva. After that install gtk2-devel and then build your app. If you have already setup the software repositories I mentioned above, then run "urpmi.update -a" and then install gtk2-devel.

  3. #3
    thnx ... it worked

  4. $spacer_open

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts