Find the answer to your Linux question:
Results 1 to 6 of 6
I am an absolute linux n00b, and I need some help. I did a search on this and didn't find much on Google or on this forum about this problem ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Oct 2006
    Posts
    4

    Install problems


    I am an absolute linux n00b, and I need some help.

    I did a search on this and didn't find much on Google or on this forum about this problem i am having.

    I have a machine at home that I am trying to install, Mandriva Free, on. It goes to the boot option screen and when I choose any of the install options it boots into a black screen with hot key items on the bottom and an error that says "No CD" or something like it, and gives me other options to install from. I am at a loss. I can't even get the ubuntu live cd or the mandriva one to boot from the CD.

    I tried taking the cd's to work and got the live cd's to boot up on a Dell optiplex GX620. I can get mandriva free to install on the optiplex but when I boot it the first time it hangs, so I boot again in linux-nonfb it hangs at "Setting hostname ****" and goes no further.

    System stats for home:

    Pentium D 3.4 (enginering sample)
    1Gb Ram
    WD 80 Gb HDD
    Seagate 160Gb HDD
    Intel 965G board
    onboard Video
    onboard sound
    1 lite-on CD/RW
    1 unknown DVD player

    Work system
    Dell optiplex GX620
    P4 HT 3.0
    1Gb RAM
    intel 945 chipset
    unknown DVD writer
    onboard video
    onboard sound
    Small form factor machine.

    Thanks for the help.

  2. #2
    Just Joined!
    Join Date
    Oct 2006
    Posts
    4

    a couple of errors

    I tried Mandriva Free when i got home today again. I booted the first cd and kept getting the black screen that says "No CD". So one of the options at the bottom is Alt-F3 which takes you to some sort of log. toward the bottom it gives me this:

    needs ide-cd
    error: file exists
    warning, insmod failed (ide-cd (null)) (-1)


    Ok I am hopeing this gives a bit more information on the subject.

    I am wondering if my drives are not supported or something. They work fine to boot from. At least for windows or most other apps. the CD-RW drive is a Lite-on LTR-522465. the DVD drive I don't know make and model off the top of my head.

    Any help or pointing in the right direction would be great thanks.

  3. #3
    Linux Enthusiast KenJackson's Avatar
    Join Date
    Jun 2006
    Location
    Maryland, USA
    Posts
    510
    I would first make sure that the CDs are good copies. If you have a working Linux system, you should be able to get an MD5 sum of a CD with this command. Change 'hdc' if that's not the CD drive. The MD5 sum is a 32-digit hex number. Compare it with the number published for the CD from wherever you downloaded it.
    Code:
    md5sum /dev/hdc
    If you don't have a Linux machine, hopefully the Windows software has a similar function.

    If you're confident the CD is a good copy, was it made on some other machine? Consider the possibility of dusty optics in the CD drives where you are reading it. You can buy a can of Dust Free or similar aerosol can for dusting electronics that you can clean out your CD reader with.

  4. #4
    Linux Enthusiast KenJackson's Avatar
    Join Date
    Jun 2006
    Location
    Maryland, USA
    Posts
    510
    We posted at about the same time. That happens.

    Another thing you can check is how the CD is connected internally. Ideally, the hard drive is connected via one cable to the primary interface (the first connector on the motherboard), and the CD drive is connected via it's own cable to the secondary interface. If this is true, the jumper on the back of the CD should be in the MASTER position (not slave, csel or missing).

    When it's setup that way, the hard drive is /dev/hda and the CD is /dev/hdc. If it's different, consider changing it.

    In any case, you can check that the connectors are tight by pressing on them.

  5. #5
    Just Joined!
    Join Date
    Oct 2006
    Posts
    4
    Thanks for the reply KenJackson

    I had been wondering how to check the MD5 of the cd, I will do that. The ISO's checked out when I downloaded them, but I didn't have any idea how to check the cd burn (don't know if Windows can do that). That could be the problem.

    As far as the internal optics I don't know if that is it, I was also having trouble at work with these CD's (the 4 mandriva free disks). I tried a CD drive from another system, it still didn't work. The thing is I know the CD and DVD drives "work" they boot from the CD's just fine. I also have no problems with them in Windows. It is only when I ask the computer to install the OS to the HDD's that it balks at me.

    As far as the HDD's go, they are both SATA (don't think I mentioned that sorry) the CD and DVD drive are attached via the only IDE port that I have on the motherboard. They both use the same cable. I know that CD drives and HDD's can have problems when on the same cable but never heard of too many problems with two optical drives attached. I have tried varrious different configurations of the drives, but switching slave and master jumpers or leaving only one drive connected just gives me the same error/problem. I think I might try installing from the ISO's in a directory.

    With the bad CD thing, I can get a copy of Mandriva One and Ubuntu to boot into the live CD mode and install to the disk on a computer at work.... but those same disks don't work here on my home computer... they give me simmilar problems mentioned earlier, even when using the varrious boot options.

    I will check the MD5 hash for the CD's in question, on an Ubuntu install I have at work and let you know what I find.

    Thanks for pointing me in the right direction, a little moral support goes a long way

  6. #6
    Just Joined!
    Join Date
    Oct 2006
    Posts
    4

    I think I found out the problem

    I think the problem that I had with my Linux installations was the motherboard I was using. It seems, after sleuthing around the web, that the Intel 965 chipsets have some problems with some linux distros (I wasn't the only one with problems regarding 965). It ended up that my new motherboard was having intermittent problems with the BIOS also, and at the end decided it wouldn't boot up anymore. I exchanged it for an ASUS Nvidia 570 motherboard, and now Knoppix STD, and Mandriva run and install properly. I have a small problem with the Knoppix CD in that it doesn't recognize my USB mouse and keyboard. So for now I have a set of USB and a set of PS2 keyboards and mice plugged in.

    If anyone can shed some light on Intel 965 chipsets and Linux it would be nice , so others with this chipset could benefit.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •