Hi *

I'trying to install the ATI drivers in automatic mode (8.29.6) for linux (using free mandriva 2007).

Fisrt of all, this is my video card (lspci):
ATI RV370 5B64 [FireGL V3100 (PCIE) (rev 80)]

This is the log of the installation (/usr/share/fglrx/fglrx-install.log):
[Message] Kernel Module : Trying to install a precompiled kernel module.
[Message] Kernel Module : Precompiled kernel module version mismatched.
[Message] Kernel Module : Found kernel module build environment, generating kernel module now.
ATI module generator V 2.0
==========================
initializing...
cleaning...
patching 'highmem.h'...
assuming new VMA API since we do have kernel 2.6.x...
Assuming default VMAP API
doing Makefile based build for kernel 2.6.x and higher
make -C /lib/modules/2.6.17-5mdv/build SUBDIRS=/lib/modules/fglrx/build_mod/2.6.x modules
make[1]: Entering directory `/usr/src/linux-2.6.17-5mdv'

WARNING: Symbol version dump /usr/src/linux-2.6.17-5mdv/Module.symvers
is missing; modules will have no dependencies and modversions.

CC [M] /lib/modules/fglrx/build_mod/2.6.x/firegl_public.o
/lib/modules/fglrx/build_mod/2.6.x/firegl_public.c:456: warning: initialization from incompatible pointer type
/lib/modules/fglrx/build_mod/2.6.x/firegl_public.c: In function ‘firegl_stub_open’:
/lib/modules/fglrx/build_mod/2.6.x/firegl_public.c:579: warning: assignment discards qualifiers from pointer target type
LD [M] /lib/modules/fglrx/build_mod/2.6.x/fglrx.o
Building modules, stage 2.
MODPOST
CC /lib/modules/fglrx/build_mod/2.6.x/fglrx.mod.o
LD [M] /lib/modules/fglrx/build_mod/2.6.x/fglrx.ko
make[1]: Leaving directory `/usr/src/linux-2.6.17-5mdv'
build succeeded with return value 0
duplicating results into driver repository...
done.
==============================
- recreating module dependency list
- trying a sample load of the kernel modules
failed.
[Error] Kernel Module : Failed to install compiled kernel module - please consult readme.

Though it seems there's some problems, X-server runs pretty well (init 5).
The reason I'm installing the proprietary drivers from ATI, is that I work a program (VMD) that relies heavily on good video card drivers. Before installing the ATI driver, the program couldn't start in graphical mode. After having installed the ATI driver (8.29.6), it gives me the following error: Xlib: extension "XFree86-DRI" missing on display ":0.0".
And, the 3D visualization in this program (VMD) is really slow.
As an example, glxgears is about : 980 frames in 5.4 seconds = 180.791 FPS

Can anybody point me how to solve this. I'm pretty a newby on installing video drivers.
Best,
Nuno