Find the answer to your Linux question:
Page 1 of 3 1 2 3 LastLast
Results 1 to 10 of 21
[root@localhost Desktop]# urpmi BitTorrent-5.0.1-1-Python2.4.noarch.rpm Some requested packages cannot be installed: BitTorrent-5.0.1-1.noarch (due to unsatisfied python-psyco) I tried finding the python-psyco package which i managed to find in : http://psyco.sourceforge.net/ then ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Nov 2006
    Posts
    10

    cannot install latest bittorent on mandriva 2007


    [root@localhost Desktop]# urpmi BitTorrent-5.0.1-1-Python2.4.noarch.rpm
    Some requested packages cannot be installed:
    BitTorrent-5.0.1-1.noarch (due to unsatisfied python-psyco)


    I tried finding the python-psyco package which i managed to find in :
    http://psyco.sourceforge.net/

    then when trying to install python-psyco it tells me :
    invalid Python installation: unable to open /usr/lib/python2.4/config/Makefile (No such file or directory)

    Any help will be appreciated

  2. #2
    Just Joined!
    Join Date
    Nov 2006
    Posts
    41
    i dunno if i will be much help, but when i was installing my packages (from configure your computer) i saw alot of python packages there, so maybe go to where all your packages are and see if there is some python packages that still need to be installed :S

    meh sorri if i wsant mcuh help

  3. #3
    Just Joined!
    Join Date
    Nov 2006
    Posts
    10
    i already did this but i didn't find any package that could actually help. most were security updates . Thanks for trying to help anyway . Anyone else please ?

  4. #4
    Linux Guru antidrugue's Avatar
    Join Date
    Oct 2005
    Location
    Montreal, Canada
    Posts
    3,211
    "python-psyco" is available in the Mandriva repository.

    You should be able to install it like that :
    Code:
    urpmi python-psyco
    If not, check your /etc/urpmi/urpmi.conf configuration file. You might want to reconfigure it using those instructions :
    http://easyurpmi.zarb.org/

    "python-psyco" is in the main section of the official repository. If you can't fix "urpmi" then you can download the file directly from any of the mirrors. This one for example :
    http://gulus.usherbrooke.ca/pub/dist...-1mdk.i586.rpm
    "To express yourself in freedom, you must die to everything of yesterday. From the 'old', you derive security; from the 'new', you gain the flow."

    -Bruce Lee

  5. #5
    Just Joined!
    Join Date
    Nov 2006
    Posts
    9
    I am in the same boat ..even worse its my first install of linux [lovely] but i don't know how to get Bittorrent to work. I downloaded version 5.0.1.e but it will not run.It wants an application to do so and presents a list. I doubt i have the app required how do you get bittorent to work.
    I installed http://gulus.usherbrooke.ca/pub/dist...-1mdk.i586.rpm as instructed but nothing.
    I think when i installed mandriva 2007 i did not install the file sharing package..not sure though..Help please and a big thanks all..my 1st post

  6. #6
    Just Joined!
    Join Date
    Nov 2006
    Posts
    10
    my problem was solved... Just go to the urpmi webpage that antidrugue posted and update your urpmi configuration. Then just do urpmi bittorrent and it will download/install the latest installable version which was 4.20 for me . It just doesn't install the latest version

    btw thanks for the help antidrugue

    latest version says unsatisfied python-crypto [>=2.0] ... And yes i have pycrypto installed so i shouldn't get this error !

  7. #7
    Just Joined!
    Join Date
    Nov 2006
    Posts
    9
    What is urpmi.. how do you update configuration etc..well basically can you take me through it.A little brief explanation please..Thanks
    I don't want to install wrong thing

  8. #8
    Just Joined!
    Join Date
    Nov 2006
    Posts
    10
    i am no expert myself (actually linux newbie ) but from what i understood urpmi is something similar to rpm , a package installer . But it will look on the net for the package you specify ,download it and install it for you. First you need to update the configuration . The way i did it was complete all the boxes on easyurpmi webpage and at the end i copy-pasted the output it made in the console. keep in my mind that it will take some time till completely updating it .

    then do urpmi bittorrent and write yes when it asks you to get the dependencies too.

  9. #9
    Just Joined!
    Join Date
    Nov 2006
    Posts
    9
    Well i tried ..but struggling is the console actually "Konsole" which mirror site did you use and which version of mandriva do you have [mine is the free mandriva 2007 edition].

    All i could find was
    System>Terminals>Konsole

    I worked through the boxes as follows:

    easy uprimi>2007 official Architecture i586 package uprimi

    Mandrikversion 7>source main Australia..etc

    Then step 3 i cut and pasted into konsole

    I ended up with error

    To be honest i need to find exactly what version i have.its easyin windows xp but how do you find the version in linux.

  10. #10
    Just Joined!
    Join Date
    Nov 2006
    Posts
    10
    well i have mandriva powerpack 2007 .. dunno about the error...

Page 1 of 3 1 2 3 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •