Find the answer to your Linux question:
Results 1 to 2 of 2
I have a Probleme it is my first time on linux and when i tried to install GTK the make got errors and I dont know wath to to /bin/sh ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Dec 2006
    Posts
    2

    Unhappy Mandravia free 2007


    I have a Probleme it is my first time on linux and when i tried to install GTK the make got errors and I dont know wath to to

    /bin/sh ../../libtool --mode=link gcc -g -O2 -Wall -o im-viqr.la -rpath /usr/lib/gtk-2.0/2.4.0/immodules -rpath /usr/lib/gtk-2.0/2.4.0/immodules -avoid-version -module imviqr.lo ../../gdk-pixbuf/libgdk_pixbuf-2.0.la ../../gdk/libgdk-x11-2.0.la ../../gtk/libgtk-x11-2.0.la -lX11 -lpangoxft-1.0 -lpangoft2-1.0 -lpangox-1.0 -lpango-1.0 -latk-1.0 -lgobject-2.0 -lgmodule-2.0 -ldl -lglib-2.0 -lm
    libtool: link: warning: `/usr/lib/gcc/i586-mandriva-linux-gnu/4.1.1/../../..//libgmodule-2.0.la' seems to be moved
    libtool: link: warning: `/usr/lib/gcc/i586-mandriva-linux-gnu/4.1.1/../../..//libgobject-2.0.la' seems to be moved
    libtool: link: warning: `/usr/lib/gcc/i586-mandriva-linux-gnu/4.1.1/../../..//libglib-2.0.la' seems to be moved
    libtool: link: warning: `/usr/lib/gcc/i586-mandriva-linux-gnu/4.1.1/../../..//libXrandr.la' seems to be moved
    libtool: link: warning: `/usr/lib/gcc/i586-mandriva-linux-gnu/4.1.1/../../..//libXinerama.la' seems to be moved
    libtool: link: warning: `/usr/lib/gcc/i586-mandriva-linux-gnu/4.1.1/../../..//libXext.la' seems to be moved
    libtool: link: warning: `/usr/lib/gcc/i586-mandriva-linux-gnu/4.1.1/../../..//libXft.la' seems to be moved
    libtool: link: warning: `/usr/lib/gcc/i586-mandriva-linux-gnu/4.1.1/../../..//libXrender.la' seems to be moved
    libtool: link: warning: `/usr/lib/gcc/i586-mandriva-linux-gnu/4.1.1/../../..//libfontconfig.la' seems to be moved
    libtool: link: warning: `/usr/lib/gcc/i586-mandriva-linux-gnu/4.1.1/../../..//libfreetype.la' seems to be moved
    libtool: link: warning: `/usr/lib/gcc/i586-mandriva-linux-gnu/4.1.1/../../..//libX11.la' seems to be moved
    libtool: link: warning: `/usr/lib/gcc/i586-mandriva-linux-gnu/4.1.1/../../..//libXfixes.la' seems to be moved
    libtool: link: warning: `/usr/lib/gcc/i586-mandriva-linux-gnu/4.1.1/../../..//libXcursor.la' seems to be moved
    libtool: link: warning: `/usr/lib/gcc/i586-mandriva-linux-gnu/4.1.1/../../..//libpangoxft-1.0.la' seems to be moved
    libtool: link: warning: `/usr/lib/gcc/i586-mandriva-linux-gnu/4.1.1/../../..//libpangoft2-1.0.la' seems to be moved
    libtool: link: warning: `/usr/lib/gcc/i586-mandriva-linux-gnu/4.1.1/../../..//libpangox-1.0.la' seems to be moved
    libtool: link: warning: `/usr/lib/gcc/i586-mandriva-linux-gnu/4.1.1/../../..//libpango-1.0.la' seems to be moved
    libtool: link: warning: `/usr/lib/gcc/i586-mandriva-linux-gnu/4.1.1/../../..//libgmodule-2.0.la' seems to be moved
    libtool: link: warning: `/usr/lib/gcc/i586-mandriva-linux-gnu/4.1.1/../../..//libgobject-2.0.la' seems to be moved
    libtool: link: warning: `/usr/lib/gcc/i586-mandriva-linux-gnu/4.1.1/../../..//libglib-2.0.la' seems to be moved
    libtool: link: warning: `/usr/lib/gcc/i586-mandriva-linux-gnu/4.1.1/../../..//libXrandr.la' seems to be moved
    libtool: link: warning: `/usr/lib/gcc/i586-mandriva-linux-gnu/4.1.1/../../..//libXinerama.la' seems to be moved
    libtool: link: warning: `/usr/lib/gcc/i586-mandriva-linux-gnu/4.1.1/../../..//libXext.la' seems to be moved
    libtool: link: warning: `/usr/lib/gcc/i586-mandriva-linux-gnu/4.1.1/../../..//libXft.la' seems to be moved
    libtool: link: warning: `/usr/lib/gcc/i586-mandriva-linux-gnu/4.1.1/../../..//libXrender.la' seems to be moved
    libtool: link: warning: `/usr/lib/gcc/i586-mandriva-linux-gnu/4.1.1/../../..//libfontconfig.la' seems to be moved
    libtool: link: warning: `/usr/lib/gcc/i586-mandriva-linux-gnu/4.1.1/../../..//libfreetype.la' seems to be moved
    libtool: link: warning: `/usr/lib/gcc/i586-mandriva-linux-gnu/4.1.1/../../..//libXfixes.la' seems to be moved
    libtool: link: warning: `/usr/lib/gcc/i586-mandriva-linux-gnu/4.1.1/../../..//libXcursor.la' seems to be moved
    libtool: link: warning: `/usr/lib/gcc/i586-mandriva-linux-gnu/4.1.1/../../..//libX11.la' seems to be moved
    libtool: link: warning: `/usr/lib/gcc/i586-mandriva-linux-gnu/4.1.1/../../..//libpangoxft-1.0.la' seems to be moved
    libtool: link: warning: `/usr/lib/gcc/i586-mandriva-linux-gnu/4.1.1/../../..//libpangoft2-1.0.la' seems to be moved
    libtool: link: warning: `/usr/lib/gcc/i586-mandriva-linux-gnu/4.1.1/../../..//libpangox-1.0.la' seems to be moved
    libtool: link: warning: `/usr/lib/gcc/i586-mandriva-linux-gnu/4.1.1/../../..//libpango-1.0.la' seems to be moved
    libtool: link: warning: `/usr/lib/gcc/i586-mandriva-linux-gnu/4.1.1/../../..//libatk-1.0.la' seems to be moved
    libtool: link: warning: `/usr/lib/gcc/i586-mandriva-linux-gnu/4.1.1/../../..//libgobject-2.0.la' seems to be moved
    libtool: link: warning: `/usr/lib/gcc/i586-mandriva-linux-gnu/4.1.1/../../..//libgmodule-2.0.la' seems to be moved
    libtool: link: warning: `/usr/lib/gcc/i586-mandriva-linux-gnu/4.1.1/../../..//libglib-2.0.la' seems to be moved
    rm -fr .libs/im-viqr.la .libs/im-viqr.lai .libs/im-viqr.so .libs/im-viqr.soT
    gcc -shared .libs/imviqr.o -Wl,--rpath -Wl,/home/nyrcal/gtk+-2.6.10/gdk-pixbuf/.libs -Wl,--rpath -Wl,/home/nyrcal/gtk+-2.6.10/gdk/.libs -Wl,--rpath -Wl,/home/nyrcal/gtk+-2.6.10/gtk/.libs -Wl,--rpath -Wl,/usr/local/lib -Wl,--rpath -Wl,/usr/local/lib ../../gdk-pixbuf/.libs/libgdk_pixbuf-2.0.so -L/usr/lib/gcc/i586-mandriva-linux-gnu/4.1.1/../../../ -L/usr/lib ../../gdk/.libs/libgdk-x11-2.0.so -L/home/nyrcal/gtk+-2.6.10/gdk-pixbuf/.libs ../../gtk/.libs/libgtk-x11-2.0.so -L/home/nyrcal/gtk+-2.6.10/gdk/.libs /usr/lib/libX11.so /usr/lib/libpangoxft-1.0.so /usr/lib/libpangoft2-1.0.so /usr/lib/libpangox-1.0.so /usr/lib/libpango-1.0.so /usr/local/lib/libatk-1.0.so /usr/lib/libgobject-2.0.so /usr/lib/libgmodule-2.0.so -ldl /usr/lib/libglib-2.0.so -lm -Wl,-soname -Wl,im-viqr.so -o .libs/im-viqr.so
    creating im-viqr.la
    (cd .libs && rm -f im-viqr.la && ln -s ../im-viqr.la im-viqr.la)
    ../../gtk/gtk-query-immodules-2.0 im-xim.la im-am-et.la im-cedilla.la im-cyrillic-translit.la im-inuktitut.la im-ipa.la im-thai-broken.la im-ti-er.la im-ti-et.la im-viqr.la > gtk.immodules
    make[3]: quittant le répertoire « /home/nyrcal/gtk+-2.6.10/modules/input »
    Making all in engines
    make[3]: entrant dans le répertoire « /home/nyrcal/gtk+-2.6.10/modules/engines »
    Making all in pixbuf
    make[4]: entrant dans le répertoire « /home/nyrcal/gtk+-2.6.10/modules/engines/pixbuf »
    if /bin/sh ../../../libtool --mode=compile gcc -DHAVE_CONFIG_H -I. -I. -I../../.. -I../../.. -I../../../gdk -I../../../gdk -DG_DISABLE_DEPRECATED -DGDK_PIXBUF_DISABLE_DEPRECATED -DGDK_DISABLE_DEPRECATED -pthread -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include -I/usr/include/pango-1.0 -I/usr/include/freetype2 -I/usr/include/atk-1.0 -g -O2 -Wall -MT pixbuf-draw.lo -MD -MP -MF ".deps/pixbuf-draw.Tpo" \
    -c -o pixbuf-draw.lo `test -f 'pixbuf-draw.c' || echo './'`pixbuf-draw.c; \
    then mv -f ".deps/pixbuf-draw.Tpo" ".deps/pixbuf-draw.Plo"; \
    else rm -f ".deps/pixbuf-draw.Tpo"; exit 1; \
    fi
    gcc -DHAVE_CONFIG_H -I. -I. -I../../.. -I../../.. -I../../../gdk -I../../../gdk -DG_DISABLE_DEPRECATED -DGDK_PIXBUF_DISABLE_DEPRECATED -DGDK_DISABLE_DEPRECATED -pthread -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include -I/usr/include/pango-1.0 -I/usr/include/freetype2 -I/usr/include/atk-1.0 -g -O2 -Wall -MT pixbuf-draw.lo -MD -MP -MF .deps/pixbuf-draw.Tpo -c pixbuf-draw.c -fPIC -DPIC -o .libs/pixbuf-draw.o
    In file included from ../../../gtk/gtk.h:60,
    from pixbuf.h:23,
    from pixbuf-draw.c:28:
    ../../../gtk/gtkclist.h:155: error: expected specifier-qualifier-list before ‘GMemChunk’
    In file included from ../../../gtk/gtk.h:152,
    from pixbuf.h:23,
    from pixbuf-draw.c:28:
    ../../../gtk/gtkstatusbar.h:68: error: expected specifier-qualifier-list before ‘GMemChunk’
    make[4]: *** [pixbuf-draw.lo] Erreur 1
    make[4]: quittant le répertoire « /home/nyrcal/gtk+-2.6.10/modules/engines/pixbuf »
    make[3]: *** [all-recursive] Erreur 1
    make[3]: quittant le répertoire « /home/nyrcal/gtk+-2.6.10/modules/engines »
    make[2]: *** [all-recursive] Erreur 1
    make[2]: quittant le répertoire « /home/nyrcal/gtk+-2.6.10/modules »
    make[1]: *** [all-recursive] Erreur 1
    make[1]: quittant le répertoire « /home/nyrcal/gtk+-2.6.10 »
    make: *** [all] Erreur 2


    is the (seems to be moved) normal and what is my probleme

  2. #2
    Just Joined!
    Join Date
    Dec 2006
    Posts
    2

    Exclamation Gtk+

    what is wrong

    CPPFLAGS="-I/***" LDFLAGS="-L/****" PKG_CONFIG_PATH="/****" export CPPFLAGS LDFLAGS PKG_CONFIG_PATH

    LD_LIBRARY_PATH="/***" PATH="/****:$PATH" export LD_LIBRARY_PATH PATH

    ./configure --prefix=/***

    up to here everytings fine


    Make

    gcc -DHAVE_CONFIG_H -I. -I. -I../../.. -I../../.. -I../../../gdk -I../../../gdk -DG_DISABLE_DEPRECATED -DGDK_PIXBUF_DISABLE_DEPRECATED -DGDK_DISABLE_DEPRECATED -pthread -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include -I/usr/include/pango-1.0 -I/usr/include/freetype2 -I/usr/include/atk-1.0 -I/usr/include -g -O2 -Wall -MT pixbuf-draw.lo -MD -MP -MF .deps/pixbuf-draw.Tpo -c pixbuf-draw.c -fPIC -DPIC -o .libs/pixbuf-draw.o
    In file included from ../../../gtk/gtk.h:60,
    from pixbuf.h:23,
    from pixbuf-draw.c:28:
    ../../../gtk/gtkclist.h:155: erreur: expected specifier-qualifier-list before ‘GMemChunk’
    In file included from ../../../gtk/gtk.h:152,
    from pixbuf.h:23,
    from pixbuf-draw.c:28:
    ../../../gtk/gtkstatusbar.h:68: erreur: expected specifier-qualifier-list before ‘GMemChunk’
    make[4]: *** [pixbuf-draw.lo] Erreur 1
    make[4]: quittant le répertoire « /home/nyrcal/gtk+-2.6.10/modules/engines/pixbuf »
    make[3]: *** [all-recursive] Erreur 1
    make[3]: quittant le répertoire « /home/nyrcal/gtk+-2.6.10/modules/engines »
    make[2]: *** [all-recursive] Erreur 1
    make[2]: quittant le répertoire « /home/nyrcal/gtk+-2.6.10/modules »
    make[1]: *** [all-recursive] Erreur 1
    make[1]: quittant le répertoire « /home/nyrcal/gtk+-2.6.10 »
    make: *** [all] Erreur 2

    can you help me plz

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •