Find the answer to your Linux question:
Results 1 to 4 of 4
Ok so was testing out a little 2d game on wine just to see how wine worked...and the system locked up badly. I couldn't even change to a command line ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jan 2007
    Posts
    13

    Kernel Panic...


    Ok so was testing out a little 2d game on wine just to see how wine worked...and the system locked up badly. I couldn't even change to a command line mode to issue a rebot command and so I hard restarted. As soon as I restart I get "Kernel panic - not syncing: attempted to kill init!". Alright...never faced a linux boot problem before so I have a lot o learning to do.

    As I understand it that error message is a generic message telling you it's dead...and the real problem lies in the lines before it. Most of it makes sense to me and is god except the last line, but I'll parse at a bunch.

    Loading jdb.ko module
    Loading ext3.ko mdule
    Mounting /proc filesystem
    Mounting sysfs
    Creating device files
    Mounting tmpfs on devfsck on a mounted partition
    Creating root device
    Trying to resume from /dev/hda2
    No suspend signature on swap, not resuming.
    echo: cannot open /proc/suspend2/do_resume for write: 2
    Mounting root filesystem /dev/root
    kjournald starting. COmmit interval 5 seconds
    EXT3-fs: mounted filesystem with ordered data mode.
    Switching to new root
    unmounting old /proc
    unmounting old /sys
    /bin/sh: root=/dev/hda3: No such file or directory
    Kernel panic - not syncing: Attempted to kill init!

    So from what I gather the problem occurs when attempting to load my /root. I figured a god first step would be to drop the Mandriva rescue CD in and take a look. Unfortunatly this seemed to go nowhere, as nearly every command I know would result in a "command not found" error...I couldn't even do dir to figure anything out. So I resort to booting Knoppix. I tried fsck on hda3 and found nothign wrong (though I'm not 100% sure how to use it since I'm very new to linux). I ran it as fsck.ext3 /dev/hda3 and it returned "clean".

    I'm figuring that a cat /etc/fstab might help understand my system so from within knoppix:

    /dev /hda3 / ext3 defaults 1 1
    /dev/hdc3 /boot ext3 defaults 1 2
    /dev/hdc1 /home ext3 defaults 1 2
    /dev/hbdb /mnt/cdrom auto unmaks=0022, users,iocharset=utf8,noauto,ro,exec 0 0
    none /mnt/floppy supermount dev=/dev/fd0,fs=ext2:vfat,--,umask=0022,exec 0 0
    /dev/hda1 /mnt/win_c ntfs umask=0022, nls=utf8,ro 0 0
    /dev/hdc2 /mnt/win_c2 ntfs umask=0022, nls=utf8, ro 0 0
    none /proc proc defaults 0 0
    /dev/hda2 swap swap defaults 0 0

    I would provide more in depth diagnosics...but I don't know where to begin. Any help would be appreciated

  2. #2
    Linux User glennzo's Avatar
    Join Date
    Sep 2004
    Location
    Salem, Mass
    Posts
    463
    I'm a Fedora user. If I have a serious boot problem in insert my install DVD and type 'linux rescue' at the boot prompt. This usually allows me to restore my bootloader, which is GRUB. Is there an option like that for Mandriva users? The line I've quoted below is where your problem is, and the reason you're getting a kernel panic. The bootloader cannot find your boot partition. What do you use to boot, GRUB or LILO?
    Quote Originally Posted by Jaidan
    /bin/sh: root=/dev/hda3: No such file or directory
    Glenn
    Powered by Fedora

  3. #3
    Just Joined!
    Join Date
    Jan 2007
    Posts
    13
    I do have that option also which I'll give a try. I hadn't thought to do that since the actual loader seemed to be functional (I was getting the GRUB prompt to select my OS). The problem is pretty much for sure that line I only quoted the rest to be sure since I'm very new to linux but the rest looks like things I'd expect. However that line references the partition /dev/hda3 which is my root partition, rather than /dev/hdc3 which is my /boot.

  4. #4
    Linux User tech_man's Avatar
    Join Date
    Jan 2007
    Location
    USA
    Posts
    385
    Can you go into a live environment and post what "fdisk -l" prints out? Also verify that /dev/hda3 is intact.
    'Tis better to be silent and be thought a fool, than to speak and remove all doubt.'
    --Abraham Lincoln

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •