Find the answer to your Linux question:
Results 1 to 3 of 3
Hello all, I have just picked up a dell m1210 laptop and tried to install Mandriva 2007 on it. It all goes pretty well except that on first try it ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jan 2007
    Location
    Sydney, Australia
    Posts
    86

    ACPI problem on dell m1210 laptop


    Hello all,
    I have just picked up a dell m1210 laptop and tried to install Mandriva 2007 on it. It all goes pretty well except that on first try it makes Gnome (and KDE I discovered later) run _very_ slow, but not using allot of cpu.
    I then reinstalled using --disable-acpi and now everything is lighthing fast, BUT I only get one cpu, and battery monitor is not working, and I have to manually power off the system. Hardly surprising as it is all controlled by the acpi (from what I understand).

    I have read on various articles that apparently openSUSE runs without a problem, even with acpi enabled. This leads me to think that maybe a custom compiled kernel would fix this problem.

    I am very new to this whole kernerl compiling business, so I would like some advice on this. First and most important, is is probable that a custom compiled kernel would help (I realize there is only one way to find out, but if it seems improbable I have better things to do with my time).
    Second any advice, or pointers to websites for compiling kernels for Mandriva?
    thanks in advance

  2. #2
    Just Joined!
    Join Date
    Jan 2007
    Location
    Sydney, Australia
    Posts
    86
    I thought I'd give the whole compile a kernel a go, and while my kernel compiled I found this blog entry
    http://toufeeq.blogspot.com/2006/07/...xps-m1210.html
    It mentioned behavours similar to what I was experiencing. The advice from one of the posters were to append "notsc" to the commandline options for the kernel. Easy enough, so I gave it a go and it worked!
    Step by step instructions to complete this:
    1. become root
    2. open /etc/lilo.conf in your favourite editor
    3. on the line that says "append" there is a list of commands, one of them is "noresume" BEFORE this line add "notsc" so the whole line now says
    append="notsc resume=/"(and the rest of your original line here)
    4. save your file and leave your editor
    5. run lilo from the commandpromt.
    6. reboot

    Closing the lid of the laptop freezes the computer, have not found a workaround yet, but I will continue to look and try to solve it.

  3. #3
    Just Joined!
    Join Date
    Jan 2007
    Location
    Sydney, Australia
    Posts
    86
    Found a solution to the lid problem as well.
    What needs to be done (don't have the exact solution here but google should be able to help you out) is to blacklist the video driver. Use google to find instructions on how to do that.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •