Find the answer to your Linux question:
Results 1 to 3 of 3
OK so I installed the realplayer codecs like the above guide said, but mplayer still cannot decode the video. This is the output when I run mplayer in a terminal ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Dec 2006
    Posts
    73

    Whoops, real player codec!


    OK so I installed the realplayer codecs like the above guide said, but mplayer still cannot decode the video. This is the output when I run mplayer in a terminal
    Code:
    [root@localhost Desktop]soundwrapper gmplayer %U
    CPU: Genuine Intel(R) CPU           T2250  @ 1.73GHz (Family: 6, Model: 14, Stepping: 8)
    CPUflags:  MMX: 1 MMX2: 1 3DNow: 0 3DNow2: 0 SSE: 1 SSE2: 1
    Compiled with runtime CPU detection.
    98 audio & 216 video codecs
    mplayer: could not connect to socket
    mplayer: No such file or directory
    Failed to open LIRC support. You will not be able to use your remote control.
    
    Playing /home/zakaqere/%U.
    File not found: '/home/zakaqere/%U'
    Failed to open /home/zakaqere/%U.
    
    
    Playing /home/zakaqere/Desktop/Hakusho/cdrom/yu yu hakusho ep 99.rm.
    REAL file format detected.
    Stream description: Audio Stream
    Stream mimetype: audio/x-pn-realaudio
    Stream description: Video Stream
    Stream mimetype: video/x-pn-realvideo
    Stream mimetype: logical-fileinfo
    VIDEO:  [RV30]  352x240  24bpp  29.000 fps    0.0 kbps ( 0.0 kbyte/s)
    Clip info:
     name: Yu Yu Ep 99
     author: www.aftermathanime.net
     copyright: AftermathAnime
    ==========================================================================
    Opening video decoder: [realvid] RealVideo decoder
    Error: /usr/lib/RealPlayer10GOLD/codecs/drvc.so: cannot open shared object file: No such file or directory
    Win32 LoadLibrary failed to load: drvc.so, /usr/lib/win32/drvc.so, /usr/local/lib/win32/drvc.so
    Error loading dll
    ERROR: Could not open required DirectShow codec drvc.so.
    Read the RealVideo section of the DOCS!
    VDecoder init failed :(
    Opening video decoder: [realvid] RealVideo decoder
    Error: /usr/lib/RealPlayer10GOLD/codecs/drv3.so.6.0: cannot open shared object file: No such file or directory
    Win32 LoadLibrary failed to load: drv3.so.6.0, /usr/lib/win32/drv3.so.6.0, /usr/local/lib/win32/drv3.so.6.0
    Error loading dll
    ERROR: Could not open required DirectShow codec drv3.so.6.0.
    Read the RealVideo section of the DOCS!
    VDecoder init failed :(
    Opening video decoder: [realvid] RealVideo decoder
    Win32 LoadLibrary failed to load: drv33260.dll, /usr/lib/win32/drv33260.dll, /usr/local/lib/win32/drv33260.dll
    Error loading dll
    ERROR: Could not open required DirectShow codec drv33260.dll.
    Read the RealVideo section of the DOCS!
    VDecoder init failed :(
    Opening video decoder: [realvid] RealVideo decoder
    Error: /usr/lib/RealPlayer10GOLD/codecs/drvc.bundle/Contents/MacOS/drvc: cannot open shared object file: No such file or directory
    Win32 LoadLibrary failed to load: drvc.bundle/Contents/MacOS/drvc, /usr/lib/win32/drvc.bundle/Contents/MacOS/drvc, /usr/local/lib/win32/drvc.bundle/Contents/MacOS/drvc
    Error loading dll
    ERROR: Could not open required DirectShow codec drvc.bundle/Contents/MacOS/drvc.
    Read the RealVideo section of the DOCS!
    VDecoder init failed :(
    Cannot find codec matching selected -vo and video format 0x30335652.
    Read DOCS/HTML/en/codecs.html!
    ==========================================================================
    ==========================================================================
    Trying to force audio codec driver family libmad...
    Opening audio decoder: [ffmpeg] FFmpeg/libavcodec audio decoders
    AUDIO: 22050 Hz, 1 ch, s16le, 32.1 kbit/9.10% (ratio: 4014->44100)
    Selected audio codec: [ffcook] afm: ffmpeg (FFmpeg COOK audio decoder)
    ==========================================================================
    AO: [oss] 22050Hz 1ch s16le (2 bytes per sample)
    Video: no video
    Starting playback...
    A:   7.7 (07.6) of 1155.0 (19:15.0)  0.5%
    
    Exiting... (Exit)
    Eep. where is docs?
    And why is it referencing MacOS?

  2. #2
    Linux Guru fingal's Avatar
    Join Date
    Jul 2003
    Location
    Birmingham - UK
    Posts
    1,539
    Hi - you could try using Realplayer for Linux. Find it here.
    I am always doing that which I can not do, in order that I may learn how to do it. - Pablo Picasso

  3. #3
    Just Joined!
    Join Date
    Dec 2006
    Posts
    73
    Yeah, I have that but the libraries still weren't installed and the RealPlayer gives me lots of chopZy video. I just installed all of the RPM's. For both all of the players from real. It's wasteful of HDD space but it worked.>_<

  4. $spacer_open
    $spacer_close

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •