Hi there!

I installed my old Laserjet 4P using CUPS on my Mandriva 2007 system, and printed a testpage, but was, at first, unable to print from OpenOffice, but it worked in the end! Here are the hurdles I went through:

Configuring it in CUPS:
It's not a network printer, just connected directly to the parallel
port.
I tried using different settings in CUPS (http://localhost:631/),
setting Device URI (in Modify Printer -> Administration) to

socket://laserjet4mp:9100

since I understand I'm using Hewlett Packard JetDirect w/o IPP

but got the message:
"/usr/lib/cups/backend/socket failed"

Then I tried this: Downloaded HP Linux Imaging and Printing's 1.7.1
release to my desktop from
http://sourceforge.net/project/showf...ease_id=481157
(I don't know if this was actually necessary for the final success, actually!)

I went to System-> Configuration->KDE->Peripherals->Printer, which
started
Configure - KDE Control Module. I pressed add -> printer and in the
Add Printer Wizard I did this (somewhere in between I had to give a
username, which a gave as "root" -not my actual username!, and root
password) :
Chose Local Printer, selected Parallel LPT#1, selected model, and got
a test page printed via CUPS.

However, I couldn't print from Open Office, so I was advised by a 'mr. b' to
go to File and Printer settings in Open Office. But I happened to have misnamed the printer (Laserjet MP instead of just P, which showed itself on the
test page printed) in the Configuration Wizard, so I went back there and
changed the name. Then I had to close and restart Open Office (not the
system) for the right name to display in File, Printer settings of Open
Office. And it worked! )

Alexbn