Hi there,

I solved the problem of page size in Open Office by going to Font, Page... and setting it to A4. That's why it kept jumping back to letter after setting it to A4 in File, Printer settings, and in the Print dialog box!

"If there's a will there's a way!"

Alexbn


LATEST PROBLEM SOLVED:

I was trying to configure Open Office (Printer settings... to A4, Print dialog box to A4),
and all (yes, all) the different configuration possibilities in KDE Control Module for printer, setting paper size to A4, and I've restarted Open Office several times (not the system though, because I got it to work perfectly yesterday, recognizing A4 size, but on startup today, nothing worked - no printing at all).

When I press print, with all the different settings set to A4 size, about 10 seconds pass, and then the printer suddenly asks to add *Letter* size paper! It's as if it just "changes its mind" after a few moments, jumping back to Letter!


ORIGINAL PROBLEM:

Hi guys,

Yesterday it worked fine, having gone through all the routines below, but today it just won't print at all. Maybe the cable snapped overnight, I don't know.

When I press Print, in both Open Office and in Konqueror (for PDF) it seems to respond normally, but it doesn't print.
Under Jobs (in Configure - KDE Control Module) it says Processing... (under State) and KDE Print System under Name.

Alexbn



Hi there!

I installed my old Laserjet 4P using CUPS on my Mandriva 2007 system, and printed a testpage, but was, at first, unable to print from OpenOffice, but it worked in the end! Here are the hurdles I went through:

Configuring it in CUPS:
It's not a network printer, just connected directly to the parallel
port.
I tried using different settings in CUPS (http://localhost:631/),
setting Device URI (in Modify Printer -> Administration) to

socket://laserjet4mp:9100

since I understand I'm using Hewlett Packard JetDirect w/o IPP

but got the message:
"/usr/lib/cups/backend/socket failed"

Then I tried this: Downloaded HP Linux Imaging and Printing's 1.7.1
release to my desktop from
http://sourceforge.net/project/showf...ease_id=481157
(I don't know if this was actually necessary for the final success, actually!)

I went to System-> Configuration->KDE->Peripherals->Printer, which
started
Configure - KDE Control Module. I pressed add -> printer and in the
Add Printer Wizard I did this (somewhere in between I had to give a
username, which a gave as "root" -not my actual username!, and root
password) :
Chose Local Printer, selected Parallel LPT#1, selected model, and got
a test page printed via CUPS.

However, I couldn't print from Open Office, so I was advised by a 'mr. b' to
go to File and Printer settings in Open Office. But I happened to have misnamed the printer (Laserjet MP instead of just P, which showed itself on the
test page printed) in the Configuration Wizard, so I went back there and
changed the name. Then I had to close and restart Open Office (not the
system) for the right name to display in File, Printer settings of Open
Office. And it worked! )

Alexbn