Find the answer to your Linux question:
Results 1 to 5 of 5
Hi, I'm trying to get my wireless usb dongle working in Mandriva Linux 2007. The version of the kernel i'm using is: 2.6.17-5mdv I'm using a "how to" guide that ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Feb 2007
    Posts
    7

    Installing Wireless Network Adapter


    Hi,

    I'm trying to get my wireless usb dongle working in Mandriva Linux 2007. The version of the kernel i'm using is:

    2.6.17-5mdv

    I'm using a "how to" guide that explains how to set up ndiswrapper so that you can use the windows drivers in linux to enable the wireless adapter.
    The problem arises when I try the following command:

    urpmi kernel-source-2.6-2.6.17-5mdv
    I get the message "no package named urpmi kernel-source-2.6-2.6.17-5mdv"

    When I try to "make" the ndiswrapper program, I get the following:

    [root@localhost ndiswrapper-1.37]# make
    make -c driver
    make [1]: Entering directory /home/james/Documents/nidiswrapper-1.37.tar/ndiswrapper-1.37/driver
    Can't find kernel build files in /lib/module/2.6.17-5mdv/build;
    give the path to kernel build directory with
    KBUILD=<path> argument to make
    make[1]: *** [prereq_check] Error 1
    make[1]: Leaving directory /home/james/Documents/ndiswrapper-1.37.tar/ndiswrapper-1.37/driver
    make: *** [all] Error 2

    I think that this is because I don't have the kernel source files on my system. Please could someone give
    me a walkthrough of what I need to do to fix this - an idiot's guide would be good as i'm new to linux.

    When I run ls /lib/modules/2.6.17-5mdv there is no "build" directory present.

    Many thanks
    James

  2. #2
    Just Joined!
    Join Date
    Feb 2007
    Posts
    7
    Hi,

    Many thanks for the reply.

    I tried:

    urpmi kernel-source-2.6.17.5mdv

    But I get:

    no package named urpmi kernel-source-2.6.17.5mdv

  3. #3
    Linux Guru antidrugue's Avatar
    Join Date
    Oct 2005
    Location
    Montreal, Canada
    Posts
    3,211
    You should almost never bother to compile anything yourself. Just use prebuild binary packages.

    There is precompiled kernel module available for Mandriva 2007 here.

    Once you have the RPM, just install like like that :
    Code:
    urpmi ndiswrapper-1.21-1mdv2007.0.i586.rpm
    "To express yourself in freedom, you must die to everything of yesterday. From the 'old', you derive security; from the 'new', you gain the flow."

    -Bruce Lee

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined!
    Join Date
    Feb 2007
    Posts
    7
    Hi,

    Thanks for the help so far. I managed to install ndiswrapper (i think).
    I used urpme to remove (it said package already installed), and then urpmi to install.

    However, if I am not the superuser it does not recognise the command ndiswrapper. I find this strange - as I understand why it wouldn't work if you weren't the root, but not sure why it won't find it.

    Anyway - logged in as superuser I ran

    ndiswrapper -i /mnt/cdrom/Driver/rt73.inf
    (typing this from memory so may not be exact).
    It seemed to install and I checked with:
    ndiswrapper -l
    and it said that the inf was installed and that the hardware was present.

    It didn't seem to do much though - when I right click on network icon, choose configure network, wireless, use windows driver (with ndiswrapper) I get the following error:

    An unexpected error has happened:
    Can't locate network/ndiswrapper.pm in @INC (@INC
    contains: /usr/lib/libDrakX /usr/lib/perl5.8.8/x86_64-linux /
    usr/lib/perl5/5.8.8 /usr/lib/perl5/site_perl/5.8.8/x86_64-linux /
    usr/lib/perl5/site_perl/5.8.8 /usr/lib/perl5/site_perl /usr/lib/perl5/
    vendor_perl/5.8.8/x86/x86_64-linux /usr/lib/perl5
    vendor_perl/5.8.8/usr/lib/perl5/vendor_perl/5.8.7 /usr/lib/
    perl5/vendor_perl/5.8.7/x86_64-linux /usr/lib/perl5/
    vendor_perl/5.8.6 /usr/lib/perl5/vendor_perl .) at /usr/lib/
    libDrakX/network/connection/wireless.pm line 175.

    Something's amiss - any ideas?
    Thanks
    James

  6. #5
    Just Joined!
    Join Date
    Feb 2007
    Posts
    7
    Update:

    Code:
    modprobe ndiswrapper

    gives:
    FATAL: Could Not Open '/lib/modules/2.6.17-5mdv/kernel/3rdparty/ndiswrapper/ndiswrapper.ko.gz

    Not sure how to fix this.
    Cheers

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •