Find the answer to your Linux question:
Results 1 to 8 of 8
Hello, I seem to be having a problem on mandriva trying to write files to the usr/local folder. It just won't let me put stuff there. Any help would be ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Feb 2007
    Posts
    23

    Question How to get file privleges


    Hello, I seem to be having a problem on mandriva trying to write files to the usr/local folder. It just won't let me put stuff there. Any help would be great!

  2. #2
    Just Joined!
    Join Date
    Dec 2006
    Posts
    62
    What account are you attempting this from, root or a user account? What application are you using to attempt this with?

    Are you trying to edit or copy a set of files?

    If you execute an "ls -las" on the folder you will see that it is owned by root.

  3. #3
    Just Joined!
    Join Date
    Feb 2007
    Posts
    23

    Question

    I am using a user but how do I login to root?
    I want to run an .sh file that wants to write files into the usr/local folder but gets the msg that it doesn't have permision. is there an easy way to get permision? or did I do something wrong in the instal?

  4. #4
    Just Joined!
    Join Date
    Dec 2006
    Posts
    62
    Sounds like you are trying to install a program. Most new users would use the Mandriva software install application. It would prompt you for your root password, the one you were prompted to create during the install process.

    If this application install is using a shell script ".sh", then yes you do have to be root to do so.

    Before the script name type "sudo" for super user (root) do and you will be prompted for root's password.

    This must be a test/learning box right? Be prepared to be frustrated installing programs using anything other than the installer application mentioned above, at least until you learn some Unix.

  5. #5
    Blackfooted Penguin daark.child's Avatar
    Join Date
    Apr 2006
    Location
    West Yorks
    Posts
    4,393
    You use the "su" command in the CLI to switch from a normal user to root. If you want to use all of roots environment, then you have to use "su -" intead of "su".

  6. #6
    Just Joined!
    Join Date
    Feb 2007
    Posts
    23
    Tryed that command but got this msg
    sudo ./rockboxdev.sh
    nathan is not in the sudoers file. This incident will be reported.

    Is there no way to just login as root? now I look at how to mount iso images and the same problem exists, I need to be the root user.

    Just saw that new post THANKYOU VERY MUCH!
    now it works!
    THX

  7. #7
    Blackfooted Penguin daark.child's Avatar
    Join Date
    Apr 2006
    Location
    West Yorks
    Posts
    4,393
    Did you take a look at my post above?

  8. #8
    Just Joined!
    Join Date
    Feb 2007
    Posts
    23
    YEs it solved my problems THX

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •