library qt-mt or have you installed qt with thread support.

i get this type of error about 75% of the time whenever i try to compile stuff, i have got qt installed with thread support i dunno but its supposed to be installed by default.

i have gooled for the answer to this but i either didn't understand or i'm not far enough down the linux track to get it to work, anyone no a step by step way to fix this