So I installed Mandriva 2007 power pack using the "upgrade option" all goes well, (or so I think) So then all of my custom compiled kernel modules stop functioning vmmon, truecrypt ,etc,etc. I find out that the stupid thing deleted my initrd-2.6.17-11mdv.img, didn't remove the package, nope! just the vmlinuz. So I spend 15 minutes re symlinking the files to the new kernel ass they were all pointing to the 2.6.17-9mdv files and finally discover there is no image for the new kernel I had. The CD had deleted it even though the kernel on the CD was older! So then I removed the kernel package and then reinstalled it and it worked, or so i thought. The boot sequence was all text now. . I thought "okay I can live with that" so then I updated all of my packages only to find out that the CD also removed my urpmi media except for itself, and of course rpmdrake could not find the files -.- . THen after I reinstalled ALL of my media updated and rebooted. I noticed tow WRONG things first of all my network connection was down on eth2(wifi) when i did ifconfig eth2 didn't even exist! When I ran the interface configurator from drakconf ifconfig showed it's existence. Right after it said "Please wait, running device configuration commands". Then I dent to the drak3d and I noticed something drastically different, before I had the choice of beryl or compiz, now I have metisse and "3D workspace" top revealed that it was compiz and NOT beryl. How am I supposed to enable beryl now? I ended up fising beryl by creating a symlink in my kde autostart folder to beryl-manager but then Kwin loads first. And this is getting annoying.


This isn't the first time "updates" have caused the computer to act up. When I updated the lilo package it totally lost the ability to display graphics. Outta nowhere. When the Kcontrol center package was updated all the sudden the lilo manager module is gone! So I use urpmi to try and reinstall it. Coflict!. Um... >.>.

Up until now none of the things have actually impacted the preformance of the system. Now every time I halt my system the netwok interface eth2 ceases to exist. So now I have to run drakconf and make the "running device configuration commands" dialog pop up. I don't even have to configure it. So I KNOW the information is there but where's the 802.11?

Has Anyone else experienced this?
The other little bug I am having is that the menu renders improperly( no logout button) after a few minutes