Find the answer to your Linux question:
Results 1 to 5 of 5
this is the problem i have: Code: X Window System Version 7.1.1 Release Date: 12 May 2006 X Protocol Version 11, Revision 0, Release 7.1.1 Build Operating System: Linux 2.6.17-4mdv ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Dec 2006
    Posts
    4

    Can't init graphical mode


    this is the problem i have:

    Code:
    X Window System Version 7.1.1
    Release Date: 12 May 2006
    X Protocol Version 11, Revision 0, Release 7.1.1
    Build Operating System: Linux 2.6.17-4mdv i686 
    Current Operating System: Linux localhost 2.6.17-5mdv #1 SMP Wed Sep 13 14:32:31 EDT 2006 i686
    Build Date: 17 September 2006
    	Before reporting problems, check http://wiki.x.org
    	to make sure that you have the latest version.
    Module Loader present
    Markers: (--) probed, (**) from config file, (==) default setting,
    	(++) from command line, (!!) notice, (II) informational,
    	(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
    (==) Log file: "/var/log/Xorg.0.log", Time: Wed Mar 21 13:09:12 2007
    (==) Using config file: "//xorg.conf"
    Data incomplete in file //xorg.conf
    	At least one Device section is required.
    (EE) Problem parsing the config file
    (EE) Error parsing the config file
    
    Fatal server error:
    no screens found
    (WW) xf86CloseConsole: KDSETMODE failed: Bad file descriptor
    (WW) xf86CloseConsole: VT_GETMODE failed: Bad file descriptor
    Code:
    # File generated by XFdrake (rev 57713)
    
    # **********************************************************************
    # Refer to the xorg.conf man page for details about the format of
    # this file.
    # **********************************************************************
    
    Section "Files"
        # font server independent of the X server to render fonts.
        FontPath "unix/:-1"
        
        # minimal fonts to allow X to run without xfs
        FontPath "/usr/share/fonts/misc:unscaled"
    EndSection
    
    Section "Extensions"
        Option "Composite"
    EndSection
    
    Section "ServerFlags"
        #DontZap # disable <Crtl><Alt><BS> (server abort)
        #DontZoom # disable <Crtl><Alt><KP_+>/<KP_-> (resolution switching)
        AllowMouseOpenFail # allows the server to start up even if the mouse does not work
    EndSection
    
    Section "Module"
        Load "dbe" # Double-Buffering Extension
        Load "v4l" # Video for Linux
        Load "extmod"
        Load "type1"
        Load "freetype"
        Load "glx" # 3D layer
    EndSection
    
    Section "InputDevice"
        Identifier "Keyboard1"
        Driver "kbd"
        Option "XkbModel" "pc105"
        Option "XkbLayout" "es"
        Option "XkbOptions" "compose:rwin"
    EndSection
    
    Section "InputDevice"
        Identifier "Mouse1"
        Driver "mouse"
        Option "Protocol" "ExplorerPS/2"
        Option "Device" "/dev/mouse"
    EndSection
    
    Section "Monitor"
        Identifier "monitor1"
        VendorName "Plug'n Play"
        ModelName "E771-4"
        HorizSync 30-70
        VertRefresh 50-120
        
        # TV fullscreen mode or DVD fullscreen output.
        # 768x576 @ 79 Hz, 50 kHz hsync
        ModeLine "768x576"     50.00  768  832  846 1000   576  590  595  630
        
        # 768x576 @ 100 Hz, 61.6 kHz hsync
        ModeLine "768x576"     63.07  768  800  960 1024   576  578  590  616
    EndSection
    
    Section "Device"
        Identifier "device1"
        VendorName "nVidia Corp."
        BoardName "NVIDIA GeForce 6800 (generic)"
        Driver "nv"
        Option "DPMS"
    EndSection
    
    Section "Screen"
        Identifier "screen1"
        Device "device1"
        Monitor "monitor1"
        DefaultColorDepth 24
        
        Subsection "Display"
            Depth 8
            Modes "1024x768" "832x624" "800x600" "640x480" "480x360" "320x240"
        EndSubsection
        
        Subsection "Display"
            Depth 15
            Modes "1024x768" "832x624" "800x600" "640x480" "480x360" "320x240"
        EndSubsection
        
        Subsection "Display"
            Depth 16
            Modes "1024x768" "832x624" "800x600" "640x480" "480x360" "320x240"
        EndSubsection
        
        Subsection "Display"
            Depth 24
            Modes "1024x768" "832x624" "800x600" "640x480" "480x360" "320x240"
        EndSubsection
    EndSection
    
    Section "ServerLayout"
        Identifier "layout1"
        InputDevice "Keyboard1" "CoreKeyboard"
        InputDevice "Mouse1" "CorePointer"
        Screen "screen1"
    EndSection
    i don't know where the problem is....
    thanks for your help...

  2. #2
    Linux Guru fingal's Avatar
    Join Date
    Jul 2003
    Location
    Birmingham - UK
    Posts
    1,539
    Can you give us some context for this problem? Which version of Mandriva are you using? At what point did this error occur (while booting)? What are your hardware specs? Are you dual booting with Windows? Etc...
    I keep six honest serving men
    (They taught me all I knew);
    Their names are What and Why and When
    And How and Where and Who.

    Rudyard Kipling
    Last edited by fingal; 03-21-2007 at 08:58 PM. Reason: Just a whim
    I am always doing that which I can not do, in order that I may learn how to do it. - Pablo Picasso

  3. #3
    Just Joined!
    Join Date
    Dec 2006
    Posts
    4
    Oh yes... sorry... it hapens when i'm about to turn to the graphical mode. I have installed mandriva 2007 free. I have also tried many different other distributions like ubuntu 6.1, knoppix and SuSE (don't rember they distributions exactly) and always happens the same error... I thought that was my monitor but i've tried with others monitors and there is always the same problem. There's no way i could init the graphical mode.

    I have a PIV 2.4 Ghz with 768mb of ram anda i have a nvidia gforce 6200 256mb agp. The monitor is a samsung SyncMaster 795mb. I have also problems with the keyboard... sometimes it doesn't work properly( genius ergomedia 700) but this problem doesn't bother me i just connect another kyb... i just want to enter X

    Yes i'm also booting with windows xp uE... How can i change my grub menu and enter automatically to windows...because linux doesn't work yet i been trying going to /boot/grub/menu.lst but when i'm going to edit (with vi) it doesn´t appear nothing at all. there is also a file /boot/grub/menu.lst.example that has info, here i change the default to 3... but i don't know how i can save changes ... later i will post the quote of what this files said. Because there are another other two files zipped but i don't remeber they names... but i think they have memories directiones.

    (Sorry for my engish )

    Thanks in advance!

  4. #4
    Linux Guru fingal's Avatar
    Join Date
    Jul 2003
    Location
    Birmingham - UK
    Posts
    1,539
    GRUB is large and complex at first. This might help.

    Not exactly sure what's wrong there ... You video card should be fine for example (NVidia is well supported).

    Which desktop environment are you trying to start? KDE, Gnome ...?
    I am always doing that which I can not do, in order that I may learn how to do it. - Pablo Picasso

  5. #5
    Just Joined!
    Join Date
    Dec 2006
    Posts
    4
    I'm trying to start Gnome...
    I fix the problem of booting windows with the comand mcc...Thanks a lot fingal !! for the information you passed me I hope i can fix the problem of the graphical mode. If there is no solution i think that i'm going to change my computer because i want to try another OS specially this one...

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •