Find the answer to your Linux question:
Results 1 to 3 of 3
Hi I am a very new user of Linux (Mandrake 10 - upgraded to Official) and bought the printer mentioned above on the weekend. One of the reasons I bought ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    May 2004
    Posts
    3

    Printer - Lexmark E321 Laser


    Hi

    I am a very new user of Linux (Mandrake 10 - upgraded to Official) and bought the printer mentioned above on the weekend. One of the reasons I bought it was it had the Penguin on the outside, so was supposedly Linux compatible. It turns out that they only have drivers for RedHat and Suse.

    Have I wasted my cash or is there a way I can get one of the other drivers set up under Mandrake? By the way, Ive tried the Lexmark website and there doesn appear to be any Mandrake driver there either.

    Also, Ive had a bit of a look through the Printer HOWTO and the best advice I could find there (Im new to this remember, so I dont really know what Im looking for) was to try using a compatible driver, so I tried CUPS with other Lexmark drivers but all that prints is heiroglyphics.

    Its funny - I swapped to Linux for the more generic support, and the first perirpheral I buy slams into the same OS-specific compatibility wall. If you can believe it, the Lexmark Linux doco (which they stick only on the CD, while giving full Windows instructions in the printed material I might add) actually says you will have to have one of those Linux distros to install.

  2. #2
    Linux Guru
    Join Date
    Mar 2003
    Location
    Wisconsin
    Posts
    1,907
    You should be able to install the driver onto any distro, it's just that they only offer support for redhat and suse. If it's an rpm, you can simple install it. If it's a .tar.gz, then you can make it.

    Good Luck!
    Jeremy
    Registered Linux user #346571
    "All The Dude ever wanted was his rug back" - The Dude

  3. #3
    Just Joined!
    Join Date
    May 2004
    Posts
    3
    Thanks

    I try to install the driver using RPM: rpm -U drivers-linux-MVprint.rpm
    but it fails:

    error: Failed dependencies: libncurses.so.4 is needed by drivers-MVprint-4.7.1-1
    When I download a package and try to install it:
    # rpm -U ncurses-4.2-25.LS1.i386.rpm

    it returns:

    package ncurses-5.3-1.20040125.4mdk (which is newer than ncurses-4.2-25.LS1) is already installed
    Does anyone know how I proceed from here? Please remember, this is actually my first week of operation with Linux.

  4. $spacer_open
    $spacer_close

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •