Find the answer to your Linux question:
Results 1 to 6 of 6
Last week I have installed my first Linux on my laptop. After realizing some of my hardware were not working properly, I have decided to download the latest kernel and ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jun 2004
    Location
    UK
    Posts
    6

    Problems with Kernel 2.6.6 and Mandrake 10.0 Official


    Last week I have installed my first Linux on my laptop. After realizing some of my hardware were not working properly, I have decided to download the latest kernel and patch it after reading some articles related to my laptop model (HP Compaq NX9005) and Linux and possible solutions. I am a total newbie so please try not to laugh hard.

    Anyway, here are my questions/problems I have encountered after patching and building kernel 2.6.6:

    (1) This is the most annoying problem. When my laptop is on AC power, it is becoming so hot, I can't touch underneath of it. CPU is always on max frequency and the fan is always on max speed. When I was using WindowsXP, this was never a problem. The fan and CPU were running like mad only when I was playing a 3D game or so. Otherwise (browsing the internet, writing text docs, etc.) the laptop was always cool and quiet (sometimes the fan doesn't even work). I did not have the chance to check the cpu behaviour with a full battery test. But when I simply unplug the AC power and run x86info, the cpu still seems to be running in full power (1.66 GHz). Is there a way to build the kernel so that the cpu uses a task intensive frequency scaling (not sure whether this is the correct term or not)?

    (2) This is only a minor problem actually but annoying enough. When I turn my laptop off, it doesn't power itself off. I have to manually press the on/off button after seeing "power down" on the screen. I can live without it of course but can't I make it work anyway? I have already patched the kernel with latest ACPI patch and ACPI seems to be on in the configuration.

    (3) Since I have installed my new kernel, I have problems with my internet. Everytime I boot my Linux, on the verbose screen, the system hangs for a minute or two "bringing up interface eth0" and then fails and the same thing happens with the eth1 as well. Actually Eth0 seems to be the "ATI | CPU to PCI bridge" while eth1 is the ethernet card. Everytime I boot my laptop, I have to create a new connection using eth1 in order to be able to activate the internet connection. It was not like this with the old kernel but I can't really understand what I had done wrong when compiling the new kernel.

    Well, I think this many questions is enough for now. Thanks a lot for your helps guys...

  2. #2
    Linux Guru
    Join Date
    Mar 2003
    Location
    Wisconsin
    Posts
    1,907
    I'm not too sure about 3, but from the sounds of 1 & 2 you don't have acpi built into your kernel. Are you sure you enabled it when you recompiled? Did you modify /etc/lilo.conf to make sure acpi is turned on?

    Jeremy
    Registered Linux user #346571
    "All The Dude ever wanted was his rug back" - The Dude

  3. #3
    Just Joined!
    Join Date
    Jun 2004
    Location
    UK
    Posts
    6
    I dunno how but I have fixed (1) and (3) somehow. I have recompiled the kernel and installed it and they are both fine now. Although one point is very interesting. When bringing up ethernet devices the devices fail immediately without waiting. But my network connection works without a problem when I log in. I don't need create a new connection any more.

    ACPI is turned on and CPU freq scaling seems to be working. At least the laptop is much cooler and the fan is not working like mad. But still the computer doesn't turn itself off. I have to still wait for "power down" to be able to turn it of.

  4. #4
    Linux Guru
    Join Date
    Mar 2003
    Location
    Wisconsin
    Posts
    1,907
    Try changing acpi=on to acpi=force in lilo.conf.

    That's what I had to do. I'm not sure how that will affect the rest of your power control functions, but it should fix the power down problem.

    Jeremy
    Registered Linux user #346571
    "All The Dude ever wanted was his rug back" - The Dude

  5. #5
    Just Joined!
    Join Date
    Jun 2004
    Location
    UK
    Posts
    6
    I am using Grub and can't find the conf file for it Can anyone help??

  6. #6
    Linux Guru
    Join Date
    Mar 2003
    Location
    Wisconsin
    Posts
    1,907
    I am using Grub and can't find the conf file for it
    I believe that it's at:

    Code:
    /boot/grub/grub.conf
    Jeremy
    Registered Linux user #346571
    "All The Dude ever wanted was his rug back" - The Dude

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •