Find the answer to your Linux question:
Results 1 to 6 of 6
After upgrading everything seems to be crashing constantly. Firefox will crash after about 20 minutes of use after which it will usually not open again until i reboot. Amarok will ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Mar 2007
    Posts
    5

    Angry Upgraded to Mandriva 2007 spring now everything crashes


    After upgrading everything seems to be crashing constantly. Firefox will crash after about 20 minutes of use after which it will usually not open again until i reboot. Amarok will crash after about ONE ot two songs if im lucky, must reboot in order to open it again. Rythmbox will play a few more before it does, must reboot to open it again also. Epiphany has been crashing frequently too.
    Basically i can't listen to music OR surf the web since upgrading. Whats the problem?

  2. #2
    Linux Guru fingal's Avatar
    Join Date
    Jul 2003
    Location
    Birmingham - UK
    Posts
    1,539
    Hi - which version of Mandriva did you upgrade from?
    I am always doing that which I can not do, in order that I may learn how to do it. - Pablo Picasso

  3. #3
    Just Joined!
    Join Date
    Mar 2007
    Posts
    5
    ..................... 2006

  4. #4
    Linux Guru fingal's Avatar
    Join Date
    Jul 2003
    Location
    Birmingham - UK
    Posts
    1,539
    I'm honestly not sure what's causing that. Have you tried starting one of those programmes from a terminal? Then when it crashes it should give you more information about what went wrong.

    It's also worth checking your log files for errors. It might just be one buggy process causing your problems. Have a look in /var/log as root, and to avoid having to scroll down too much try - for example:

    tail -50 messages

    This is at least a starting point for you.
    I am always doing that which I can not do, in order that I may learn how to do it. - Pablo Picasso

  5. #5
    Just Joined!
    Join Date
    Mar 2007
    Posts
    5
    :???: Might it have anything to do with this::???:

    "th: "pixmap",

    (npviewer.bin:18573): Gtk-WARNING **: Unable to locate theme engine in module_path: "pixmap",

    (npviewer.bin:18573): Gtk-WARNING **: Unable to locate theme engine in module_path: "pixmap",

    (npviewer.bin:18573): Gtk-WARNING **: Unable to locate theme engine in module_path: "pixmap",
    ERROR: ld.so: object '/usr/$LIB/libaoss.so.0' from LD_PRELOAD cannot be preloaded: ignored.
    ERROR: ld.so: object '/usr/$LIB/libaoss.so.0' from LD_PRELOAD cannot be preloaded: ignored.
    Flash Player: Warning: environment variable G_FILENAME_ENCODING is set and is not UTF-8

    (npviewer.bin:18609): Gtk-WARNING **: Unable to locate theme engine in module_path: "pixmap",

    (npviewer.bin:18609): Gtk-WARNING **: Unable to locate theme engine in module_path: "pixmap",

    (npviewer.bin:18609): Gtk-WARNING **: Unable to locate theme engine in module_path: "pixmap",

    (npviewer.bin:18609): Gtk-WARNING **: Unable to locate theme engine in module_path: "pixmap",

    (npviewer.bin:18609): Gtk-WARNING **: Unable to locate theme engine in module_path: "pixmap",

    (npviewer.bin:18609): Gtk-WARNING **: Unable to locate theme engine in module_path: "pixmap",

    (npviewer.bin:18609): Gtk-WARNING **: Unable to locate theme engine in module_path: "pixmap",

    (npviewer.bin:18609): Gtk-WARNING **: Unable to locate theme engine in module_path: "pixmap",

    (npviewer.bin:18609): Gtk-WARNING **: Unable to locate theme engine in module_path: "pixmap",

    (npviewer.bin:18609): Gtk-WARNING **: Unable to locate theme engine in module_path: "pixmap",

    (npviewer.bin:18609): Gtk-WARNING **: Unable to locate theme engine in module_path: "pixmap",

    (npviewer.bin:18609): Gtk-WARNING **: Unable to locate theme engine in module_path: "pixmap",

    (npviewer.bin:18609): Gtk-WARNING **: Unable to locate theme engine in module_path: "pixmap",

    (npviewer.bin:18609): Gtk-WARNING **: Unable to locate theme engine in module_path: "pixmap",

    (npviewer.bin:18609): Gtk-WARNING **: Unable to locate theme engine in module_path: "pixmap",

    (npviewer.bin:18609): Gtk-WARNING **: Unable to locate theme engine in module_path: "pixmap",
    ERROR: ld.so: object '/usr/$LIB/libaoss.so.0' from LD_PRELOAD cannot be preloaded: ignored.
    ERROR: ld.so: object '/usr/$LIB/libaoss.so.0' from LD_PRELOAD cannot be preloaded: ignored.
    Flash Player: Warning: environment variable G_FILENAME_ENCODING is set and is not UTF-8

    (npviewer.bin:18844): Gtk-WARNING **: Unable to locate theme engine in module_path: "pixmap",

    (npviewer.bin:18844): Gtk-WARNING **: Unable to locate theme engine in module_path: "pixmap",

    (npviewer.bin:18844): Gtk-WARNING **: Unable to locate theme engine in module_path: "pixmap",

    (npviewer.bin:18844): Gtk-WARNING **: Unable to locate theme engine in module_path: "pixmap",

    (npviewer.bin:18844): Gtk-WARNING **: Unable to locate theme engine in module_path: "pixmap",

    (npviewer.bin:18844): Gtk-WARNING **: Unable to locate theme engine in module_path: "pixmap",

    (npviewer.bin:18844): Gtk-WARNING **: Unable to locate theme engine in module_path: "pixmap",

    (npviewer.bin:18844): Gtk-WARNING **: Unable to locate theme engine in module_path: "pixmap",

    (npviewer.bin:18844): Gtk-WARNING **: Unable to locate theme engine in module_path: "pixmap",

    (npviewer.bin:18844): Gtk-WARNING **: Unable to locate theme engine in module_path: "pixmap",

    (npviewer.bin:18844): Gtk-WARNING **: Unable to locate theme engine in module_path: "pixmap",

    (npviewer.bin:18844): Gtk-WARNING **: Unable to locate theme engine in module_path: "pixmap",

    (npviewer.bin:18844): Gtk-WARNING **: Unable to locate theme engine in module_path: "pixmap",

    (npviewer.bin:18844): Gtk-WARNING **: Unable to locate theme engine in module_path: "pixmap",

    (npviewer.bin:18844): Gtk-WARNING **: Unable to locate theme engine in module_path: "pixmap",

    (npviewer.bin:18844): Gtk-WARNING **: Unable to locate theme engine in module_path: "pixmap",
    ERROR: ld.so: object '/usr/$LIB/libaoss.so.0' from LD_PRELOAD cannot be preloaded: ignored.
    ERROR: ld.so: object '/usr/$LIB/libaoss.so.0' from LD_PRELOAD cannot be preloaded: ignored.
    Flash Player: Warning: environment variable G_FILENAME_ENCODING is set and is not UTF-8

    (npviewer.bin:18980): Gtk-WARNING **: Unable to locate theme engine in module_path: "pixmap",

    (npviewer.bin:18980): Gtk-WARNING **: Unable to locate theme engine in module_path: "pixmap",

    (npviewer.bin:18980): Gtk-WARNING **: Unable to locate theme engine in module_path: "pixmap",

    (npviewer.bin:18980): Gtk-WARNING **: Unable to locate theme engine in module_path: "pixmap",

    (npviewer.bin:18980): Gtk-WARNING **: Unable to locate theme engine in module_path: "pixmap",

    (npviewer.bin:18980): Gtk-WARNING **: Unable to locate theme engine in module_path: "pixmap",

    (npviewer.bin:18980): Gtk-WARNING **: Unable to locate theme engine in module_path: "pixmap",

    (npviewer.bin:18980): Gtk-WARNING **: Unable to locate theme engine in module_path: "pixmap",

    (npviewer.bin:18980): Gtk-WARNING **: Unable to locate theme engine in module_path: "pixmap",

    (npviewer.bin:18980): Gtk-WARNING **: Unable to locate theme engine in module_path: "pixmap",

    (npviewer.bin:18980): Gtk-WARNING **: Unable to locate theme engine in module_path: "pixmap",

    (npviewer.bin:18980): Gtk-WARNING **: Unable to locate theme engine in module_path: "pixmap",

    (npviewer.bin:18980): Gtk-WARNING **: Unable to locate theme engine in module_path: "pixmap",

    (npviewer.bin:18980): Gtk-WARNING **: Unable to locate theme engine in module_path: "pixmap",

    (npviewer.bin:18980): Gtk-WARNING **: Unable to locate theme engine in module_path: "pixmap",

    (npviewer.bin:18980): Gtk-WARNING **: Unable to locate theme engine in module_path: "pixmap",
    ERROR: ld.so: object '/usr/$LIB/libaoss.so.0' from LD_PRELOAD cannot be preloaded: ignored.
    ERROR: ld.so: object '/usr/$LIB/libaoss.so.0' from LD_PRELOAD cannot be preloaded: ignored.
    Flash Player: Warning: environment variable G_FILENAME_ENCODING is set and is not UTF-8

    (npviewer.bin:19071): Gtk-WARNING **: Unable to locate theme engine in module_path: "pixmap",

    (npviewer.bin:19071): Gtk-WARNING **: Unable to locate theme engine in module_path: "pixmap",

    (npviewer.bin:19071): Gtk-WARNING **: Unable to locate theme engine in module_path: "pixmap",

    (npviewer.bin:19071): Gtk-WARNING **: Unable to locate theme engine in module_path: "pixmap",

    (npviewer.bin:19071): Gtk-WARNING **: Unable to locate theme engine in module_path: "pixmap",

    (npviewer.bin:19071): Gtk-WARNING **: Unable to locate theme engine in module_path: "pixmap",

    (npviewer.bin:19071): Gtk-WARNING **: Unable to locate theme engine in module_path: "pixmap",

    (npviewer.bin:19071): Gtk-WARNING **: Unable to locate theme engine in module_path: "pixmap",

    (npviewer.bin:19071): Gtk-WARNING **: Unable to locate theme engine in module_path: "pixmap",

    (npviewer.bin:19071): Gtk-WARNING **: Unable to locate theme engine in module_path: "pixmap",

    (npviewer.bin:19071): Gtk-WARNING **: Unable to locate theme engine in module_path: "pixmap",

    (npviewer.bin:19071): Gtk-WARNING **: Unable to locate theme engine in module_path: "pixmap",

    (npviewer.bin:19071): Gtk-WARNING **: Unable to locate theme engine in module_path: "pixmap",

    (npviewer.bin:19071): Gtk-WARNING **: Unable to locate theme engine in module_path: "pixmap",

    (npviewer.bin:19071): Gtk-WARNING **: Unable to locate theme engine in module_path: "pixmap",

    (npviewer.bin:19071): Gtk-WARNING **: Unable to locate theme engine in module_path: "pixmap",
    ERROR: ld.so: object '/usr/$LIB/libaoss.so.0' from LD_PRELOAD cannot be preloaded: ignored.
    ERROR: ld.so: object '/usr/$LIB/libaoss.so.0' from LD_PRELOAD cannot be preloaded: ignored.
    Flash Player: Warning: environment variable G_FILENAME_ENCODING is set and is not UTF-8

    (npviewer.bin:19378): Gtk-WARNING **: Unable to locate theme engine in module_path: "pixmap",

    (npviewer.bin:19378): Gtk-WARNING **: Unable to locate theme engine in module_path: "pixmap",

    (npviewer.bin:19378): Gtk-WARNING **: Unable to locate theme engine in module_path: "pixmap",

    (npviewer.bin:19378): Gtk-WARNING **: Unable to locate theme engine in module_path: "pixmap",

    (npviewer.bin:19378): Gtk-WARNING **: Unable to locate theme engine in module_path: "pixmap",

    (npviewer.bin:19378): Gtk-WARNING **: Unable to locate theme engine in module_path: "pixmap",

    (npviewer.bin:19378): Gtk-WARNING **: Unable to locate theme engine in module_path: "pixmap",

    (npviewer.bin:19378): Gtk-WARNING **: Unable to locate theme engine in module_path: "pixmap",

    (npviewer.bin:19378): Gtk-WARNING **: Unable to locate theme engine in module_path: "pixmap",

    (npviewer.bin:19378): Gtk-WARNING **: Unable to locate theme engine in module_path: "pixmap",

    (npviewer.bin:19378): Gtk-WARNING **: Unable to locate theme engine in module_path: "pixmap",

    (npviewer.bin:19378): Gtk-WARNING **: Unable to locate theme engine in module_path: "pixmap",

    (npviewer.bin:19378): Gtk-WARNING **: Unable to locate theme engine in module_path: "pixmap",

    (npviewer.bin:19378): Gtk-WARNING **: Unable to locate theme engine in module_path: "pixmap",

    (npviewer.bin:19378): Gtk-WARNING **: Unable to locate theme engine in module_path: "pixmap",

    (npviewer.bin:19378): Gtk-WARNING **: Unable to locate theme engine in module_path: "pixmap",
    ERROR: ld.so: object '/usr/$LIB/libaoss.so.0' from LD_PRELOAD cannot be preloaded: ignored.
    ERROR: ld.so: object '/usr/$LIB/libaoss.so.0' from LD_PRELOAD cannot be preloaded: ignored.
    Flash Player: Warning: environment variable G_FILENAME_ENCODING is set and is not UTF-8

    (npviewer.bin:19422): Gtk-WARNING **: Unable to locate theme engine in module_path: "pixmap",

    (npviewer.bin:19422): Gtk-WARNING **: Unable to locate theme engine in module_path: "pixmap",

    (npviewer.bin:19422): Gtk-WARNING **: Unable to locate theme engine in module_path: "pixmap",

    (npviewer.bin:19422): Gtk-WARNING **: Unable to locate theme engine in module_path: "pixmap",

    (npviewer.bin:19422): Gtk-WARNING **: Unable to locate theme engine in module_path: "pixmap",

    (npviewer.bin:19422): Gtk-WARNING **: Unable to locate theme engine in module_path: "pixmap",

    (npviewer.bin:19422): Gtk-WARNING **: Unable to locate theme engine in module_path: "pixmap",

    (npviewer.bin:19422): Gtk-WARNING **: Unable to locate theme engine in module_path: "pixmap",

    (npviewer.bin:19422): Gtk-WARNING **: Unable to locate theme engine in module_path: "pixmap",

    (npviewer.bin:19422): Gtk-WARNING **: Unable to locate theme engine in module_path: "pixmap",

    (npviewer.bin:19422): Gtk-WARNING **: Unable to locate theme engine in module_path: "pixmap",

    (npviewer.bin:19422): Gtk-WARNING **: Unable to locate theme engine in module_path: "pixmap",

    (npviewer.bin:19422): Gtk-WARNING **: Unable to locate theme engine in module_path: "pixmap",

    (npviewer.bin:19422): Gtk-WARNING **: Unable to locate theme engine in module_path: "pixmap",

    (npviewer.bin:19422): Gtk-WARNING **: Unable to locate theme engine in module_path: "pixmap",

    (npviewer.bin:19422): Gtk-WARNING **: Unable to locate theme engine in module_path: "pixmap",
    ERROR: ld.so: object '/usr/$LIB/libaoss.so.0' from LD_PRELOAD cannot be preloaded: ignored.
    ERROR: ld.so: object '/usr/$LIB/libaoss.so.0' from LD_PRELOAD cannot be preloaded: ignored.
    Flash Player: Warning: environment variable G_FILENAME_ENCODING is set and is not UTF-8

    (npviewer.bin:19465): Gtk-WARNING **: Unable to locate theme engine in module_path: "pixmap",

    (npviewer.bin:19465): Gtk-WARNING **: Unable to locate theme engine in module_path: "pixmap",

    (npviewer.bin:19465): Gtk-WARNING **: Unable to locate theme engine in module_path: "pixmap",

    (npviewer.bin:19465): Gtk-WARNING **: Unable to locate theme engine in module_path: "pixmap",

    (npviewer.bin:19465): Gtk-WARNING **: Unable to locate theme engine in module_path: "pixmap",

    (npviewer.bin:19465): Gtk-WARNING **: Unable to locate theme engine in module_path: "pixmap",

    (npviewer.bin:19465): Gtk-WARNING **: Unable to locate theme engine in module_path: "pixmap",

    (npviewer.bin:19465): Gtk-WARNING **: Unable to locate theme engine in module_path: "pixmap",

    (npviewer.bin:19465): Gtk-WARNING **: Unable to locate theme engine in module_path: "pixmap",

    (npviewer.bin:19465): Gtk-WARNING **: Unable to locate theme engine in module_path: "pixmap",

    (npviewer.bin:19465): Gtk-WARNING **: Unable to locate theme engine in module_path: "pixmap",

    (npviewer.bin:19465): Gtk-WARNING **: Unable to locate theme engine in module_path: "pixmap",

    (npviewer.bin:19465): Gtk-WARNING **: Unable to locate theme engine in module_path: "pixmap",

    (npviewer.bin:19465): Gtk-WARNING **: Unable to locate theme engine in module_path: "pixmap",

    (npviewer.bin:19465): Gtk-WARNING **: Unable to locate theme engine in module_path: "pixmap",

    (npviewer.bin:19465): Gtk-WARNING **: Unable to locate theme engine in module_path: "pixmap",
    ERROR: ld.so: object '/usr/$LIB/libaoss.so.0' from LD_PRELOAD cannot be preloaded: ignored.
    ERROR: ld.so: object '/usr/$LIB/libaoss.so.0' from LD_PRELOAD cannot be preloaded: ignored.
    Flash Player: Warning: environment variable G_FILENAME_ENCODING is set and is not UTF-8

    (npviewer.bin:20961): Gtk-WARNING **: Unable to locate theme engine in module_path: "pixmap",

    (npviewer.bin:20961): Gtk-WARNING **: Unable to locate theme engine in module_path: "pixmap",

    (npviewer.bin:20961): Gtk-WARNING **: Unable to locate theme engine in module_path: "pixmap",

    (npviewer.bin:20961): Gtk-WARNING **: Unable to locate theme engine in module_path: "pixmap",

    (npviewer.bin:20961): Gtk-WARNING **: Unable to locate theme engine in module_path: "pixmap",

    (npviewer.bin:20961): Gtk-WARNING **: Unable to locate theme engine in module_path: "pixmap",

    (npviewer.bin:20961): Gtk-WARNING **: Unable to locate theme engine in module_path: "pixmap",

    (npviewer.bin:20961): Gtk-WARNING **: Unable to locate theme engine in module_path: "pixmap",

    (npviewer.bin:20961): Gtk-WARNING **: Unable to locate theme engine in module_path: "pixmap",

    (npviewer.bin:20961): Gtk-WARNING **: Unable to locate theme engine in module_path: "pixmap",

    (npviewer.bin:20961): Gtk-WARNING **: Unable to locate theme engine in module_path: "pixmap",

    (npviewer.bin:20961): Gtk-WARNING **: Unable to locate theme engine in module_path: "pixmap",

    (npviewer.bin:20961): Gtk-WARNING **: Unable to locate theme engine in module_path: "pixmap",

    (npviewer.bin:20961): Gtk-WARNING **: Unable to locate theme engine in module_path: "pixmap",

    (npviewer.bin:20961): Gtk-WARNING **: Unable to locate theme engine in module_path: "pixmap",

    (npviewer.bin:20961): Gtk-WARNING **: Unable to locate theme engine in module_path: "pixmap",
    ERROR: ld.so: object '/usr/$LIB/libaoss.so.0' from LD_PRELOAD cannot be preloaded: ignored.
    ERROR: ld.so: object '/usr/$LIB/libaoss.so.0' from LD_PRELOAD cannot be preloaded: ignored.
    Flash Player: Warning: environment variable G_FILENAME_ENCODING is set and is not UTF-8

    (npviewer.bin:20996): Gtk-WARNING **: Unable to locate theme engine in module_path: "pixmap",

    (npviewer.bin:20996): Gtk-WARNING **: Unable to locate theme engine in module_path: "pixmap",

    (npviewer.bin:20996): Gtk-WARNING **: Unable to locate theme engine in module_path: "pixmap",

    (npviewer.bin:20996): Gtk-WARNING **: Unable to locate theme engine in module_path: "pixmap",

    (npviewer.bin:20996): Gtk-WARNING **: Unable to locate theme engine in module_path: "pixmap",

    (npviewer.bin:20996): Gtk-WARNING **: Unable to locate theme engine in module_path: "pixmap",

    (npviewer.bin:20996): Gtk-WARNING **: Unable to locate theme engine in module_path: "pixmap",

    (npviewer.bin:20996): Gtk-WARNING **: Unable to locate theme engine in module_path: "pixmap",

    (npviewer.bin:20996): Gtk-WARNING **: Unable to locate theme engine in module_path: "pixmap",

    (npviewer.bin:20996): Gtk-WARNING **: Unable to locate theme engine in module_path: "pixmap",

    (npviewer.bin:20996): Gtk-WARNING **: Unable to locate theme engine in module_path: "pixmap",

    (npviewer.bin:20996): Gtk-WARNING **: Unable to locate theme engine in module_path: "pixmap",

    (npviewer.bin:20996): Gtk-WARNING **: Unable to locate theme engine in module_path: "pixmap",

    (npviewer.bin:20996): Gtk-WARNING **: Unable to locate theme engine in module_path: "pixmap",

    (npviewer.bin:20996): Gtk-WARNING **: Unable to locate theme engine in module_path: "pixmap",

    (npviewer.bin:20996): Gtk-WARNING **: Unable to locate theme engine in module_path: "pixmap",
    *** NSPlugin Wrapper *** ERROR: NPP_Destroy() wait for reply: Message timeout
    *** NSPlugin Wrapper *** ERROR: NPClass::Invalidate() invoke: Message timeout
    *** NSPlugin Wrapper *** ERROR: NP_Shutdown() invoke: Message timeout
    "

    ?

  6. #6
    Linux Guru fingal's Avatar
    Join Date
    Jul 2003
    Location
    Birmingham - UK
    Posts
    1,539
    That might be it. Perhaps all those packages depend on GTK modules which you don't have installed? "GTK engines" is a package which might be missing from your distro.

    You might try to install it using urpmi on a command line, or (probably better at this stage) log into your package manager (it's called 'install software') and browse for gtk-engines. It's installed on my distro ... Seems a bit strange though: it should be there already.
    I am always doing that which I can not do, in order that I may learn how to do it. - Pablo Picasso

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •