Find the answer to your Linux question:
Results 1 to 4 of 4
Ok guys, I think I got a good one this time. Recently had to do a reinstall, because I couldn't get HP printer to work. (Mandriva 2007). Since then, I ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Nov 2006
    Posts
    14

    P2P progs will not install


    Ok guys,

    I think I got a good one this time.

    Recently had to do a reinstall, because I couldn't get HP printer to work. (Mandriva 2007).

    Since then, I have had trouble with 2 Issues that are probably related. It seems that JRE is the problem. First, I can't get Firefox to recognize the freshly installed Java. I know it's there, and is working properly because it works in Opera. I have removed and replaced the symbolic links, but still no go.
    my Java is located here:

    /usr/lib/jre1.6.0_01/plugin/i386/ns7/libjavaplugin_oji.so
    My Firefox is located here:
    usr/lib/mozilla-firefox-1.5.0.7/ns7/plugins (where I created the symbolic link with:

    ln -s /usr/lib/jre1.6.0_01/plugin/i386/ns7/libjavaplugin_oji.so

    I cant get Limewire to install, It tells me that It needs JRE......

    Frostwire will install but will not run.

    I Installed Amule, but it will not run either.

    I have set up easyURPMI for the updated packages. and have updated several times.

    One question is: DO I have to Uninstall limewire (or frostwire) that may have been there before? If so perhaps someone can explain that process to me.

    The other question is:

    How can I get Firefox to jecognize the Java installed. Do I have to re-install Java (possibly in a different location)

    BTW I have tried installing from the Terminal and the KDE software installer.

    I am still liking the Mandriva, and I am sure that this is just something that I am doing wrong.

    Help me out here guys..... You have been a big help with all the other problems, Maybe this one is more of a challenge.....

    Thanks,

    Michael

  2. #2
    Linux Guru fingal's Avatar
    Join Date
    Jul 2003
    Location
    Birmingham - UK
    Posts
    1,539
    Hello - yes, getting Firefox to see Java can be a pain. I struggled with this, but it's a question of using the correct paths when issuing the ln command (as I think you've guessed).

    I would read this to start with and see if it helps. Another little trick is (after you've tried to get Firefox to recognise Java) to type about : plugins (without the space) in Firefox's address bar. If it can 'see' Java this should be apparent.

    Also read this guide. For some reason this is hard to find using Google, but note that the ln -s command takes the form:
    Code:
    ln -s /usr/java/jre1.5.0_09/plugin/i386/ns7/libjavaplugin_oji.so ./libjavaplugin_oji.so
    It's not exactly intuitive is it? I seem to remember that's what fixed it for me in the end.
    I am always doing that which I can not do, in order that I may learn how to do it. - Pablo Picasso

  3. #3
    Just Joined!
    Join Date
    Nov 2006
    Posts
    14

    3 weeks and still no Java

    Well still having this same problem. No Java after 3 weeks. I have tried everything I could possibly think of....

    No one has any Ideas?

    Seems strange, but on the first install it worked out of the box first time out. No problems, unfortunately, cant remember how I did it.

    Someone told me that I needed to add Java to my path but couldn't explain how to do it.

    Is this true? If so perhaps someone can explain it for me.

    Thanks for the help.

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined!
    Join Date
    Dec 2006
    Posts
    11
    I dont know if this will be a help, but after FF kept closing everytime I tried to do a search I removed it and replaced it Opera, which I actually found better.
    Anyhoo, once I disabled the built in Bitttorrent, and installed JRE 6 myself I installed Limewire and Azureus. One of them insisted on installing an oldr JRE but both work fine and I dont even have to use the terminal.
    I am finding the fact both JRE's are there but not having problems.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •