Find the answer to your Linux question:
Results 1 to 2 of 2
I'm a total linux noob and so far i am loving it. Mandriva is my first linux install and all went in fine. My only problem is that the wireless ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    May 2007
    Posts
    1

    3945ABG wireless card woes


    I'm a total linux noob and so far i am loving it. Mandriva is my first linux install and all went in fine.
    My only problem is that the wireless card on my sony viao "VGN-C1S" laptop seems to have a busted driver.

    When i go to set up the connection in the control center. I am able to select the wireless card. However, when i click next. A prompt is displayed saying "Unable to find network interface for selected device (using ipw3945 driver)".

    The "Linux Tools Logs" says

    Code:
    21:47:39 drakconnect[14510]: running: /bin/rpm -q --qf %{name} wireless-tools 
    21:47:49 drakconnect[14510]: running: dmidecode 
    21:47:49 drakconnect[14510]: Found settings for driver "ipw3945" in category "network::connection::wireless" 
    21:47:49 drakconnect[14510]: No kernel_module package for module "ipw3945" is required, skipping 
    21:47:49 drakconnect[14510]: Required tools package for module "ipw3945" is already installed, skipping 
    21:47:49 drakconnect[14510]: Required firmware package for module "ipw3945" is already installed, skipping 
    21:47:49 drakconnect[14510]: Settings for driver "ipw3945" applied 
    21:47:49 drakconnect[14510]: Reloading module ipw3945 
    21:47:49 drakconnect[14510]: running: rmmod ipw3945 
    21:47:49 drakconnect[14510]: running: /sbin/modprobe ipw3945 
    21:48:00 drakconnect[14510]: running: /sbin/modprobe -n ipw3945 
    21:48:00 drakconnect[14510]: running: /sbin/modprobe ipw3945 
    21:48:10 drakconnect[14510]: running: /sbin/modprobe -n ipw3945 
    21:53:25 drakconnect[14510]: Found settings for driver "ipw3945" in category "network::connection::wireless" 
    21:53:25 drakconnect[14510]: No kernel_module package for module "ipw3945" is required, skipping 
    21:53:25 drakconnect[14510]: Required tools package for module "ipw3945" is already installed, skipping 
    21:53:25 drakconnect[14510]: Required firmware package for module "ipw3945" is already installed, skipping 
    21:53:25 drakconnect[14510]: Settings for driver "ipw3945" applied 
    21:53:25 drakconnect[14510]: Reloading module ipw3945 
    21:53:25 drakconnect[14510]: running: rmmod ipw3945 
    21:53:25 drakconnect[14510]: running: /sbin/modprobe ipw3945 
    21:53:35 drakconnect[14510]: running: /sbin/modprobe -n ipw3945 
    21:53:35 drakconnect[14510]: running: /sbin/modprobe ipw3945 
    21:53:46 drakconnect[14510]: running: /sbin/modprobe -n ipw3945
    and the other thing i found was
    Code:
    [root@localhost Elachys]# /sbin/modprobe ipw3945
    WARNING: Error inserting ieee80211 (/lib/modules/2.6.17-13mdv/net/ieee80211/ieee80211.ko): Unknown symbol in module, or unknown parameter (see dmesg)
    WARNING: Error inserting ieee80211 (/lib/modules/2.6.17-13mdv/net/ieee80211/ieee80211.ko): Unknown symbol in module, or unknown parameter (see dmesg)
    FATAL: Error inserting ipw3945 (/lib/modules/2.6.17-13mdv/kernel/3rdparty/ipw3945/ipw3945.ko.gz): Unknown symbol in module, or unknown parameter (see dmesg)
    FATAL: Error running install command for ipw3945
    Does this mean the drivers are just messed up?

    All replies are very much appreciated.

  2. #2
    Linux Engineer aliov's Avatar
    Join Date
    Dec 2006
    Location
    Geneva,Beirut
    Posts
    1,078
    the ipw3945 is fully supported under linux ,but your problem is very strange,
    try to download the firmware from Intel® PRO/Wireless 3945ABG Driver for Linux (the recent version)
    extract it and out all the file inside the /lib/firmware/
    Linux is not only an operating system, it's a philosophy.
    Archost.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •