Find the answer to your Linux question:
Results 1 to 4 of 4
Yes, I installed Mandriva Spring and it looks pretty, but will it work? Apparently not, at least with regard to trying to connect to the Internet with my Best Data ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jun 2007
    Posts
    3

    Thumbs down Dial-up modem under Mandriva Spring 2007


    Yes, I installed Mandriva Spring and it looks pretty, but will it work? Apparently not, at least with regard to trying to connect to the Internet with my Best Data Smart One 56K, which incidently I am currently using, under (gasp!) Windows 98 SE, to post this message. The same modem served me well under Mandrake 8.0 (or 8.2) and RH 9, but due to data incompatibilities between Windows and Linux, I stopped using Linux a few years ago.

    I must have lost my marbles because having a surplus 40 Gig hard drive, I purchased "barebone" DVDs of both Madriva Linux 2007.1 (Spring) and Fedora Core 7. I installed both, sequentially, on my Ibex 1.80 Gig. Pentium 4, with 512 Meg RAM, 100 Mhz. Bus Clock, ECS P4S5A/DX+ 1.0 motherboard, American Megatrends BIOS 07.00T (4/2/01), on a 40 Gig. second WD harddrive, as part of a dual OS system, with Windows 98 SE on the primary WD 40 Gig. hard drive.

    Both version of Linux installed without a problem, but neither could recognize the modem, although I meticulously followed the directions provided by Konquerer (Ha, what a misnomer!), Gnome and Fedora. This is in spite of the fact that the very same modem worked under RH 9 on this very same computer a few years ago, and still does. I tried the same procedure with both new distros, but substituting a US Robotics V.92 modem and the same thing happened, NOTHING, not even using "kppp", which I had used under both RH and Mandrake. I have tried to get help from Mandriva, but I am not going to pay for it, and so I am here, hoping someone can help, before I write off both these versions of Linux, and perhaps Linux itself, as totally worthless and a waste of the money I paid for them.

    I remain pessimistically optimistic ...

    Yavo Lem

    P.S. - I had nothing to do with the underline ad links, but I suppose this site has to be supported somehow. I guess there really isn't any free lunch anymore.

  2. #2
    Linux Engineer aliov's Avatar
    Join Date
    Dec 2006
    Location
    Geneva,Beirut
    Posts
    1,078
    have a look to this link linmodems.org
    Linux is not only an operating system, it's a philosophy.
    Archost.

  3. #3
    Just Joined!
    Join Date
    Jun 2007
    Posts
    3
    Thank you for replying Aliov.

    Not to be insulting, but I’ve been there and done that. According to the site, Linmodem = Winmodem + software, which is not what I am having a problem with. My other computer, a Gateway, does, indeed, have a U.S. Robotics Winmodem and Linux has never worked on that system. Rather, my problem is on the Ibex, as described, using a Best Data 56X Smart One EXTERNAL modem, which has a FN6USA-31385-M5-E chipset, is “OK” for Linux under EXT formatting. (This information comes from the very bottom link to Rob Clark’s listing, but the information is quite dated). Please note that the very same modem which I am using under Windows 98 SE to transmit this message, has worked under Mandrake (8.0 ro 8.2) and Red Hat v. 9, ON THIS VERY SAME IBEX COMPUTER, with no alterations, a few years ago.

    Under Windows, the modem is installed on COM-2 IRQ-3, and both Mandriva Spring and FC-7 install without a problem, but neither of them will allow me to access the Internet. I can install the modem via kppp under Mandriva, which reports “modem busy” on COM-2, OR ‘looking for modem” on either /dev/modem, or /dev/ttyS0, or /dev/ttyS1. Under FC-7, using the Hardware Installation tool, the modem shows up by highlighting as being on COM-2, but after going through the whole process, which included the modem lights flashing on and off, and trying to connect to the Internet, it reported that the “computer is not connected to the Internet”, which is quite obvious without the note. The same thing happens when I try putting the modem on the other ports described above, except the lights do not blink on and off. But the final message is the same.

    So, all things being as described, and with the modem having worked under Mandrake and Red Hat, I have to conclude that there is something that has changed with Mandriva kppp and FC-7, with regard to the way they identify and initialize modems like the one I use. Oh yes, I did also include the modem initialization string under kppp, to no avail. One final note, in an emergency, Best Data says the modem can be identified as a “Hayes compatible”, but that in any case, it carries its driver on board, along with whatever is necessary to get it going, as is sufficiently demonstrated by the fact that it is working now under Windows 98, and has been since I bought it in 1997.

    Please note that the same recognition problems occur with the U.S. Robotics V. 92 EXTERNAL modem that came with the Ibex system I am currently using, a system that was specifically designed for Linux, but can work with Windows as well. So, given that all my data and applications work fine under Windows 98 SE, and since the data and applications are incompatible with Linux, and since Linux applications offer me no obvious advantage over what I am currently using, I have made the decision to stay with what works, as I need it for various translation projects I am working on.

    However, I still have an empty 40 Gig WD hard drive, and am willing to use it to experiment with either Linux “distro”, but I do need to access the Internet and I do not intent to go out and buy another modem just to do so. Therefore, if either you, or someone else, can come up with something that REALLY works, please communicate that to me.

    Until then, thanks again for responding.

    Yavo Lem

  4. #4
    Just Joined!
    Join Date
    Jun 2005
    Location
    San Francisco, CA
    Posts
    54
    Yavo, my philosophy with computers, and especially with Linux, is "do what works."

    If you have tried a distro and it doesn't work, try another one, particularly one that has a reputation of working well on most systems. So try Ubuntu or Mepis. Ubuntu has the rep, and Mepis worked for me when even Ubuntu didn't. I'm sure there are many other good choices as well, but I'd start with those two.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •