Find the answer to your Linux question:
Results 1 to 8 of 8
Hi, I've used Mandriva in the past and never had an issue like this. * I changed my box to boot up in run level 3 * I allow root ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jul 2007
    Posts
    7

    root login on KDE kills my other users home directory


    Hi,

    I've used Mandriva in the past and never had an issue like this.

    * I changed my box to boot up in run level 3
    * I allow root access in the kde config files

    When I startx as root from the prompt (either directly as root or by using su on the prompt) my other users home directories are deleted! What is more when I delete the users and add them again they still can't login into X and I have to chown and chgrp their home directories from 501 to their username so their profile works under bash.

    Brand new users seem to able to login with out any problem if they are created after I login as root.

    Everything appears to work fine if I don't login to X as root. I know I shouldn't be doing this anyways but the distribution shouldn't behave in this way.

    I googled this problem and couldn't find any one else experiencing this issue. Has any one experienced anything similar?

    I might try Mandriva Spring to see if this issue is resolved.

    regards,

    Gerard

  2. #2
    Linux Guru budman7's Avatar
    Join Date
    Oct 2004
    Location
    Knee deep in Grand Rapids, Michigan
    Posts
    3,242
    Which file did you edit, and what did you change it to?
    I have found that using startx as root just works with no configuration necessary.
    With kdm and gdm, you have to edit a file.
    Maybe mandriva is different though.
    How to know if you are a geek.
    when you respond to "get a life!" with "what's the URL?"
    - Birger

    New users read The FAQ

  3. #3
    Just Joined!
    Join Date
    Jul 2007
    Posts
    7

    Thanks Budman7

    Hi Budman7

    Thanks very much for replying to my post.

    The only two files I edited were /etc/inittab (to change run level to 3)

    Apon logging in to X as root all hell broke loose. (I have been able to replicate this to establish this as the cause of my problems)

    Later I changed /etc/kde3/kdm/kdmrc to say

    allowrootaccess=true

    So that I could login to KDE as root at runlevel 5 to see if the same thing occured. Which it did.

    I have only ever had this issue with this version of Mandriva which is 2007.0. Which is a pity as EVERYTHING else worked out of the box beautifully - I didn't even need to compile the nvidia drivers. 3D desktop just worked!

    I think ill try Mandriva 2007.1, Fedora, SUSE or Debian and see how I go. I tried Ubuntu and didn't like that.

    Do you have any recommendations for a distro that can boot to run level 3 and also has support for a slick 3D desktop, good package management with user friendly Samba support?

    I definitely don't have the technical mind for FreeBSD, Gentoo or Slackware.

    Thanks once again for your post.

    regards,

    Gerard

  4. #4
    Linux User IsaacKuo's Avatar
    Join Date
    Feb 2005
    Location
    Baton Rouge, LA, USA
    Posts
    406
    That is truly bizarre behavior. I would suspect some sort of KDE bug, in which case it might affect other Linux distributions as well (as well as *BSD etc). KDE is god-awfully complex and it wouldn't surprise me if the KDE developers don't test the effects of logging in as root, since you're never supposed to do it.

    As a practical matter, the way root's home directory is handled varies from Linux distribution to Linux distribution, as well as with other *nix OS's. This may make it impractical to test KDE when logging in as root, in any case.
    Isaac Kuo, ICQ 29055726 or Yahoo mechdan

  5. #5
    Just Joined!
    Join Date
    Jul 2007
    Posts
    7

    THink ill just upgrade

    Thanks Isaac

    Yeah - I think ill try the latest version of Mandriva. The older version I used didn't suffer from this problem. Hopefully the bug has been resolved. Strange that no one else has had this problem (atleast I couldn't find any example when I googled it).

    I would have thought that if it occured in every Mandriva 2007 installation the bug would be well documented.

  6. #6
    Linux Guru budman7's Avatar
    Join Date
    Oct 2004
    Location
    Knee deep in Grand Rapids, Michigan
    Posts
    3,242
    Very few people login X as root, so if there are bugs the kde team is not likely to know about it.
    There just aren't enough people logging into X as root, which IMO is a good thing.
    Logging into X as root, for the most part is unnecessary.
    If you need to move files, just File Manager-Super user mode.
    Most anything that needs root access is easily done in the terminal.
    Just ask and we will be more than glad to help you.
    How to know if you are a geek.
    when you respond to "get a life!" with "what's the URL?"
    - Birger

    New users read The FAQ

  7. #7
    Just Joined!
    Join Date
    Jul 2007
    Posts
    7
    I agree one shouldn't login as root to KDE. Bad idea.

    But I can't live with this. If I have a heap of documents saved in the home directory and am root in runlevel 3 one day and I accidently type in 'startx' there goes my documents.

    Its on thing to accidently type rm -f -R /home/user as root but to loose documents and user profiles by using a startx command in the wrong circumstances is too risky.

    I've just downloaded Mandriva 2007.1 free edition. So Ill do a fresh install and let you guys know how I go.

    regards,

    Gerard

  8. #8
    Just Joined!
    Join Date
    Jul 2007
    Posts
    7

    Problem solved

    Downloaded mandriva free 2007.1 Spring.

    Did a clean install - everything working beautifully. Logged in as root into KDE to cause the same issue and it didn't happen.

    3D compiz desktop working, package management everything is wonderful! I don't like solving problems by giving up and upgrading but given that this was a really weird one felt I had too.

    I love Mandriva Linux. Now im going to set it up as a SSH, VNC, and Samba Server. Wish me luck! Thanks for every ones help.

    regards,

    Gerard

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •