Find the answer to your Linux question:
Results 1 to 9 of 9
Hey everyone, I used to use Linux all the time, but switched back to Windows to try 7. Now that I'm done with experimenting, I want to try Linux Mint. ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Feb 2009
    Posts
    5

    Linux Mint + Ubuntu black screen


    Hey everyone,

    I used to use Linux all the time, but switched back to Windows to try 7. Now that I'm done with experimenting, I want to try Linux Mint. (I used to use Ubuntu.)

    Since my last Ubuntu install, I've upgraded my video card from a Geforce 8600 GTS to a Radeon HD 4670. When I try to install the 64 bit version of Mint 6, it loads fine until after the progress bar. Then, my two monitors pretty much shut off, one saying "VGA MODE NOT SUPPORTED." I can also hear my video card fan go 100% speed. However, I can go into console by using CTRL + ALT + F1.

    I'm kinda unsure of what to do next. I'm a bit lost with all the xorg configuration...

    Also, the exact same thing happens when I try to install Ubuntu 8.10 64 bit. However, when I go into Graphics Safe mode, it works fine. I'd much rather use Linux Mint though...

    Any help is appreciated.

  2. #2
    Linux Guru
    Join Date
    Jul 2004
    Posts
    4,593
    The ATI driver, found HERE, does not list the Radeon HD 46xx line as supported.

    There is the RadeonHD driver, but their list of supported cards, found HERE, doesn't list your card either.

    There is also the Radeon driver. There list of supported chips, found HERE says this:
    R600/R700 class chips (Radeon HD 2300 Radeon HD 4870) initial support, 2D support with EXA, Xv etc. 3D support coming Q1/2009
    That would mean that the RadeonHD driver may also work. You need to find the chip that your card is using. Maybe the output of this command will help.
    Code:
    lspci
    These drivers are usually installed after Linux is installed. Since it seems to be hanging up during the installation, you would have to go about it differently. Maybe installing it in text mode, and then installing the video driver. You would either need to download the driver before hand, or download it from the terminal, using the wget command.

    Is it also possible that the installation completes, but without a proper video driver the video output shuts down. Since you can you bring up a terminal window using the Ctrl+Alt+Fx key combination, you should edit your Xorg.conf file. In the terminal window, enter this command.
    Code:
    sudo vi /etc/X11/xorg.conf
    Use the up/down left/right arrows to navigate. You need to find the video driver section and change it vesa. To delete the existing, put the curser under the character to be deleted, and hit the x key. To enter the new driver, first hit the i key, and enter the driver name. Hit the Esc key to exit the insert mode, then use Shift+ZZ to save and exit.

    It is possible that you may not even have an xorg.conf file. I am not sure of what to do if this is the case. Maybe just install one of the Radeon drivers using the terminal.
    Last edited by waterhead; 02-16-2009 at 09:02 AM.
    Please do not send Private Messages to me with requests for help. I will not reply.

  3. #3
    Just Joined!
    Join Date
    Feb 2009
    Posts
    5
    My radeon card is using an "RV730XT" chip. Doesn't the RadeonHD driver support this card? It says it does here.

    In both Linux Mint and Ubuntu, I have an xorg.conf file, and the video driver is set to vesa. However, the screen still doesn't show up. I've tried restarting the gdm, I've tried killing X then starting it, I've tried reconfiguring the Xserver, but nothing works. What I'm most likely going to try now is installing the radeon driver from terminal.

    What I'm doing is starting the live CD of Linux Mint or Ubuntu, and it loads and says everything is fine, then the screen shuts off right when I hear the log in sound. So, I didn't even start to install it.

    Thanks.

  4. #4
    Linux Guru Jonathan183's Avatar
    Join Date
    Oct 2007
    Posts
    3,043
    Sometimes bootsplash causes a problem ... try removing quiet and splash from the boot options and see if it works.

  5. #5
    Just Joined!
    Join Date
    Feb 2009
    Posts
    5
    I've tried that, didn't work.

  6. #6
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,729
    Press Alt+Ctrl+F1 and open xorg.conf file.
    Code:
    sudo nano /etc/X11/xorg.conf
    Set "vesa" driver in Video Card section.
    Code:
    Section "Device"
    	Identifier	"Configured Video Device"
    	Driver		"vesa"
    EndSection
    Press Ctrl+X, Y and hit Enter key to save file. Restart X Server ( Alt+Ctrl+Backspace). You can install ATI proprietary driver later on.
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

  7. #7
    Just Joined!
    Join Date
    Feb 2009
    Posts
    5
    I tried that as well, it didn't work. I gave up on trying to usethat video card, so I put in my old 8600 GTS. Linux booted up perfectly, and I installed it and everything. What should I do know to get the correct ATI driver?

  8. #8
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,729
    Have you tried to install driver through Hardware Drivers option in Menu?
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

  9. #9
    Just Joined!
    Join Date
    Feb 2009
    Posts
    5
    If I do that, the drivers for my nvidia card will only show up, because that's the card that's in the sytem. I'd I take it out and put the radeon card in, the same problem happens and the screen doesn't show.

    I'm just going to try to uninstall my nvidia drivers then install the ATI drivers, put my radeon card in and reboot.

    Thanks for your help, I'll post back how it goes.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •