Find the answer to your Linux question:
Results 1 to 6 of 6
Hello all, I just bought a new HP 14in laptop yesterday and the first thing I did was install MInt 9 on it. Everything is going well except no sound ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Sep 2009
    Posts
    72

    Mint 9 No sound in new HP Laptop


    Hello all,

    I just bought a new HP 14in laptop yesterday and the first thing I did was install MInt 9 on it. Everything is going well except no sound at all. Not even the 'start up chime' of any music/videos. I have the volume buttons working on the laptop and I have checked sound preferences and nothing is muted.

    I did not dig much further as I have learned with mint and ubuntu that can create problems. This is a fresh install and no sound from the get go.

    How should I proceed to trouble shoot?

    Thank you

    COMPUTER
    Processor 2x AMD Athlon(tm) II P320 Dual-Core Processor
    Memory 3609MB (578MB used)
    Operating System Linux Mint 9 Isadora
    User Name yanek (Yanek)
    Date/Time Tue 21 Sep 2010 10:04:01 AM EDT
    Display
    Resolution 1366x768 pixels
    OpenGL Renderer ATI Mobility Radeon HD 4200 Series
    X11 Vendor The X.Org Foundation
    Multimedia
    Audio Adapter HDA-Intel - HDA ATI SB
    Audio Adapter HDA-Intel - HDA ATI HDMI
    Input Devices
    Power Button
    Lid Switch
    Power Button
    Macintosh mouse button emulation
    AT Translated Set 2 keyboard
    Video Bus
    HP Webcam-101
    SynPS/2 Synaptics TouchPad
    Printers (CUPS)
    Print_to_PDF
    SCSI Disks
    ATA ST9500420AS
    hp CDDVDW TS-L633N
    Generic- Multi-Card
    StoreJet Transcend
    Operating System
    Version
    Kernel Linux 2.6.32-24-generic (i686)
    Compiled #43-Ubuntu SMP Thu Sep 16 14:17:33 UTC 2010
    C Library GNU C Library version 2.11.1 (stable)
    Default C Compiler GNU C Compiler version 4.4.3 (Ubuntu 4.4.3-4ubuntu5)
    Distribution Linux Mint 9 Isadora
    Current Session
    Computer Name yanek-laptop
    User Name yanek (Yanek)
    Home Directory /home/yanek
    Desktop Environment GNOME 2.30.2
    Misc
    Uptime 15 minutes
    Load Average 0.57, 0.69, 0.46
    Kernel Modules
    Loaded Modules
    binfmt_misc
    ppdev
    joydev Joystick device interfaces
    dm_crypt device-mapper target for transparent encryption / decryption
    snd_hda_codec_atihdmi ATI HDMI HD-audio codec
    snd_hda_codec_realtek Realtek HD-audio codec
    snd_hda_intel Intel HDA driver
    snd_hda_codec HDA codec core
    snd_hwdep Hardware dependent layer
    snd_pcm_oss PCM OSS emulation for ALSA.
    snd_mixer_oss Mixer OSS emulation for ALSA.
    snd_seq_dummy ALSA sequencer MIDI-through client
    snd_pcm Midlevel PCM code for ALSA.
    snd_seq_oss OSS-compatible sequencer module
    snd_seq_midi Advanced Linux Sound Architecture sequencer MIDI synth.
    snd_rawmidi Midlevel RawMidi code for ALSA.
    snd_seq_midi_event MIDI byte <-> sequencer event coder
    snd_seq Advanced Linux Sound Architecture sequencer.
    lib80211_crypt_tkip lib80211 crypt: TKIP
    snd_timer ALSA timer interface
    snd_seq_device ALSA sequencer device management
    fglrx ATI Fire GL
    uvcvideo USB Video Class driver
    videodev Device registrar for Video4Linux drivers v2
    v4l1_compat v4l(1) compatibility layer for v4l2 drivers.
    snd Advanced Linux Sound Architecture driver for soundcards.
    agpgart AGP GART driver
    wl
    lib80211 common routines for IEEE802.11 drivers
    psmouse PS/2 mouse driver
    serio_raw Raw serio driver
    soundcore Core sound module
    snd_page_alloc Memory allocator for ALSA system.
    shpchp Standard Hot Plug PCI Controller Driver
    i2c_piix4 PIIX4 SMBus driver
    lp
    parport
    dm_raid45 device-mapper raid4/5 target
    xor
    fbcon
    tileblit Tile Blitting Operation
    font Console Fonts
    bitblit Bit Blitting Operation
    softcursor Generic software cursor
    vga16fb Legacy VGA framebuffer device driver
    usb_storage USB Mass Storage driver for Linux
    video ACPI Video Driver
    output Display Output Switcher Lowlevel Control Abstraction
    vgastate VGA State Save/Restore
    r8169 RealTek RTL-8169 Gigabit Ethernet driver
    mii MII hardware support library
    ahci AHCI SATA low-level driver

  2. #2
    Just Joined!
    Join Date
    Sep 2009
    Posts
    72
    help still trying to get sound, I don't want to revert to windows but at least I can use my speakers.

    Please help

    Code:
    lspci
    00:00.0 Host bridge: Advanced Micro Devices [AMD] RS780 Host Bridge Alternate
    00:01.0 PCI bridge: Advanced Micro Devices [AMD] RS780 PCI to PCI bridge (int gfx)
    00:05.0 PCI bridge: Advanced Micro Devices [AMD] RS780 PCI to PCI bridge (PCIE port 1)
    00:06.0 PCI bridge: Advanced Micro Devices [AMD] RS780 PCI to PCI bridge (PCIE port 2)
    00:11.0 SATA controller: ATI Technologies Inc SB700/SB800 SATA Controller [AHCI mode]
    00:12.0 USB Controller: ATI Technologies Inc SB700/SB800 USB OHCI0 Controller
    00:12.2 USB Controller: ATI Technologies Inc SB700/SB800 USB EHCI Controller
    00:13.0 USB Controller: ATI Technologies Inc SB700/SB800 USB OHCI0 Controller
    00:13.2 USB Controller: ATI Technologies Inc SB700/SB800 USB EHCI Controller
    00:14.0 SMBus: ATI Technologies Inc SBx00 SMBus Controller (rev 41)
    00:14.2 Audio device: ATI Technologies Inc SBx00 Azalia (Intel HDA) (rev 40)
    00:14.3 ISA bridge: ATI Technologies Inc SB700/SB800 LPC host controller (rev 40)
    00:14.4 PCI bridge: ATI Technologies Inc SBx00 PCI to PCI Bridge (rev 40)
    00:14.5 USB Controller: ATI Technologies Inc SB700/SB800 USB OHCI2 Controller
    00:16.0 USB Controller: ATI Technologies Inc SB700/SB800 USB OHCI0 Controller
    00:16.2 USB Controller: ATI Technologies Inc SB700/SB800 USB EHCI Controller
    00:18.0 Host bridge: Advanced Micro Devices [AMD] K10 [Opteron, Athlon64, Sempron] HyperTransport Configuration
    00:18.1 Host bridge: Advanced Micro Devices [AMD] K10 [Opteron, Athlon64, Sempron] Address Map
    00:18.2 Host bridge: Advanced Micro Devices [AMD] K10 [Opteron, Athlon64, Sempron] DRAM Controller
    00:18.3 Host bridge: Advanced Micro Devices [AMD] K10 [Opteron, Athlon64, Sempron] Miscellaneous Control
    00:18.4 Host bridge: Advanced Micro Devices [AMD] K10 [Opteron, Athlon64, Sempron] Link Control
    01:05.0 VGA compatible controller: ATI Technologies Inc M880G [Mobility Radeon HD 4200]
    01:05.1 Audio device: ATI Technologies Inc RS880 Audio Device [Radeon HD 4200]
    02:00.0 Network controller: Broadcom Corporation Device 4727 (rev 01)
    03:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8101E/RTL8102E PCI Express Fast Ethernet controller (rev 02)

  3. #3
    Linux Guru rokytnji's Avatar
    Join Date
    Jul 2008
    Location
    Desert
    Posts
    3,993
    Read a bug report associated with your sound chip. (Bug report is for no sound in headphones only though)

    Audio device: ATI Technologies Inc SBx00 Azalia (Intel HDA) (rev 40) [from lspci]
    Ubuntu 10.10 Beta1 AMD64 live cd.
    https://bugs.launchpad.net/ubuntu/+s...er/+bug/637040

    Reply was

    You have hardware not in the Conexant model register. Please try updating your alsa drivers, as outlined here:
    https://wiki.ubuntu.com/Audio/Instal...aDriverModules. Please report back as to whether this solves your issue.
    https://wiki.ubuntu.com/Audio/Instal...aDriverModules

    More advise from bug report.

    Make sure the latest drivers are installed according to the above, then edit the file /etc/modprobe.d/alsa-base.conf
    and add the following line:
    options snd-hda-intel model=dell-laptop
    Reboot and test. Other models to test are:
    thinkpad
    ideapad
    hp_laptop
    dell-vostro
    olpc-xo-1_5
    Linux Registered User # 475019
    Lead,Follow, or get the heck out of the way. I Have a Masters in Raising Hell
    Tech Books
    Free Linux Books
    Newbie Guide
    Courses at Home

  4. #4
    Just Joined!
    Join Date
    Sep 2009
    Posts
    72
    Hey Sorry for th elate reply, been on the road lately.

    I found that updating the alsa drivers solved the sound issues. Hope this helps others

  5. #5
    Linux Guru rokytnji's Avatar
    Join Date
    Jul 2008
    Location
    Desert
    Posts
    3,993
    Quote Originally Posted by HaNgoc View Post
    Hey Sorry for th elate reply, been on the road lately.

    I found that updating the alsa drivers solved the sound issues. Hope this helps others
    Glad you got it sorted. Please post back on exact steps you took to update alsa drivers so other Linux Mint users with Hewlitt Packards can use your thread to resolve their issues.

    Then you can use thread tools (tab on top of first post) to mark thread as solved and also close thread.

    Happy Trails, Rok
    Linux Registered User # 475019
    Lead,Follow, or get the heck out of the way. I Have a Masters in Raising Hell
    Tech Books
    Free Linux Books
    Newbie Guide
    Courses at Home

  6. #6
    Just Joined!
    Join Date
    Sep 2009
    Posts
    72
    Here is the terminal commands I used'

    Code:
    CODE: SELECT ALL
    sudo add-apt-repository ppa:ubuntu-audio-dev/ppa
    sudo apt-get update
    sudo apt-get install linux-alsa-driver-modules-$(uname -r)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •