Find the answer to your Linux question:
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 11
Hi everyone. I used Linux back in the days of Red Hat 5, but found that it was terrible for gaming and I just had no use for it that ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Sep 2010
    Posts
    12

    Have Mandriva, want Mint, but can't mount/write DVD


    Hi everyone. I used Linux back in the days of Red Hat 5, but found that it was terrible for gaming and I just had no use for it that it was good at so I gave it up. Now Linux has clearly come a long way and I want to install Mint because my step-bro knows Ubuntu distros better than anything and will be able to best assist me in learning on that platform. Plus Mint looks nice and easy to use.

    The problem is, I downloaded the Live DVD ISO after a huge amount of problems, and installed K3B after a huge amount of problems only to find that it can't find the DVD drive. The system seems to know it's there, but K3B says I need to make sure the HAL Daemon is running. I can't find any reference to a "hal daemon" anywhere on this system. Everyone on Google talks like it's just a given that it's here. I can't find it in the console, can't find it in the file system, and seem to have no way to just mount this disk and get it burned. I'm really not happy with Mandriva and just want to get rid of it. Nothing against it or anything, but it's just not for me at this point.

    Could someone patient please help me with this issue? I'm virtually unable to do anything on Linux yet, but if I can just get Mint set up, my step-bro will be much more able to assist me(though he lives in another state and I have no telephone, so I need to at least get internet working on it by myself.

    If you need any more info, please let me know! Thanks.

  2. #2
    Linux Guru rokytnji's Avatar
    Join Date
    Jul 2008
    Location
    Desert
    Posts
    4,110
    While I don't run Mandriva any more. Did you install K3B using below page for a reference

    Writing CD and DVD images - Mandriva Community Wiki

    Because

    installed K3B after a huge amount of problems only to find that it can't find the DVD drive.
    Makes it sound like installing K3B would be no big problem.

    You might try the console method of burning a image using Wodim also. It is in the link above also. I don't use K3B anymore. Use Gnome-Baker or Braserio anymore. Maybe someone running K3B will point you in the right direction though error message sounds ominous.
    Linux Registered User # 475019
    Lead,Follow, or get the heck out of the way. I Have a Masters in Raising Hell
    Tech Books
    Free Linux Books
    Newbie Guide
    Courses at Home

  3. #3
    Just Joined!
    Join Date
    Sep 2010
    Posts
    12
    I just noticed that the DVD drive's info says it's scsi, not IDE, but I can't figure out how to change this. Wodim gave me an error after saying it was initializing scsi, and I was confused so I looked into it. Hopefully I can resolve this, I wish Mandriva did their interface a bit differently though.

  4. #4
    Just Joined!
    Join Date
    Sep 2010
    Posts
    12
    Oh and thanks for the reply!

  5. #5
    Linux Guru reed9's Avatar
    Join Date
    Feb 2009
    Location
    Boston, MA
    Posts
    4,651
    Which version of Mandriva are you running? HAL should be installed and running by default. (It is being deprecated, though, but some things still depend on it and it should still be around.)

    The SCSI drive shouldn't be a problem, that's common.

    Try from the command line
    Code:
    wodim -v dev=/dev/sr0 speed=4 mint.iso
    Change mint.iso to whatever the actually name of the mint iso file is. Your device is mostly likely called /dev/sr0, that's pretty standard for SCSI optical drives. But it's possible it is not. The Mandriva hardware control center should be able to tell you somewhere what the device node is if that's wrong.

  6. #6
    Just Joined!
    Join Date
    Sep 2010
    Posts
    12
    I'm running 2010.1 Spring, just installed it 2 or 3 days ago.

    When I run Wodim, I get this error:

    Code:
    @localhost Downloads]$ wodim -v dev=/dev/sr0 speed=4 linuxmint-9-gnome-dvd-i386.iso
    wodim: No write mode specified.
    wodim: Assuming -tao mode.
    wodim: Future versions of wodim may have different drive dependent defaults.
    TOC Type: 1 = CD-ROM
    wodim: Operation not permitted. Warning: Cannot raise RLIMIT_MEMLOCK limits.
    scsidev: '/dev/sr0'
    devname: '/dev/sr0'
    scsibus: -2 target: -2 lun: -2
    Linux sg driver version: 3.5.27
    Wodim version: 1.1.10
    SCSI buffer size: 64512
    wodim: Cannot do inquiry for CD/DVD-Recorder.
    Errno: 5 (Input/output error), test unit ready scsi sendcmd: fatal error
    CDB:  00 00 00 00 00 00
    cmd finished after 0.000s timeout 40s
    The Control Center sees the device, says it's working, but unlike Windows, there's no tab or button anywhere to change the drivers. I know such features are fairly dumbed-down, but when it comes to Linux I'm still fairly dumbed-down

    Here's what the control center says about the device:

    Code:
    Identification
    Vendor: ‎SONY
    
    Description: ‎DVD RW DW-G120A
    
    Disk identifier: ‎SONY DVD RW DW-G120A
    
    Media class: ‎cdrom
    
    Bus identification
    Target id number: ‎0
    
    Connection
    Bus: ‎SCSI
    
    Channel: ‎0
    
    Logical unit number: ‎0
    
    Target id number: ‎0
    
    Device
    Old device file: ‎/dev/sr0
    
    Misc
    Drive capacity: ‎burner DVD 
    
    Disk controller: ‎1
    
    Module: ‎pata_amd

  7. #7
    Just Joined!
    Join Date
    Sep 2010
    Posts
    12
    Here's another thing I ran. I'm posting them as I figure them out:

    Code:
    Downloads]$ cdrecord -scanbus
    scsibus1:
            1,0,0   100) *
            1,1,0   101) *
            1,2,0   102) *
            1,3,0   103) *
            1,4,0   104) *
            1,5,0   105) *
            1,6,0   106) *
            1,7,0   107) *
    So it can't seem to find any drives, but the Mandriva control panel sees both drives. I can't see any GUI method to activate them and I'm not good with the console. I'm going to keep trying to Google this though.

    Here is what the control panel says:
    Code:
    Mount point: /media/sr0
    Device: sr0
    Name: SONY DVD RW DW-G120A
    Type: auto
    Options: umask=0,user,iocharset=utf8,unhide,suid,exec
    Last edited by Amish_Fighter_Pilot; 10-01-2010 at 12:48 AM.

  8. #8
    Just Joined!
    Join Date
    Sep 2010
    Posts
    12
    I went into my bios and disabled SATA, even though there's nothing running on the SATA bus. Now it detects both writers as scd0, and scd1. The disk burned fine. I had to completely power-off the system though and do a static discharge to get it to post again(basically you flip the power switch on the PSU and hold down the power button on the front for a couple minutes. Mostly needed on laptops, but my desktop was acting funny so I tried it and it worked).

    Hopefully in a few here I should have Linux Mint 9!

  9. #9
    Administrator MikeTbob's Avatar
    Join Date
    Apr 2006
    Location
    Texas
    Posts
    7,864
    Nice work!
    Do let us know how it goes and post back if you run into any problems.
    I do not respond to private messages asking for Linux help, Please keep it on the forums only.
    All new users please read this.** Forum FAQS. ** Adopt an unanswered post.

    I'd rather be lost at the lake than found at home.

  10. #10
    Just Joined!
    Join Date
    Sep 2010
    Posts
    12
    haha I am not the luckiest fellow. I am running off the Mint live DVD, but I tried to do a full install. It asked me if I wanted to install Mandriva and Mint side by side, or wipe the drive and just install Mint. Install started, and I got a few steps in and it went to rewrite the drive and could not write ext4, but the error happened and went back a step so fast that it was impossible to read. I will google this though, and see what I can find.

Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •