Find the answer to your Linux question:
Results 1 to 2 of 2
I was trying to update a few things and Synaptic Package Manager is totally frozen. I have tried Google to figure out what the process is called so I can ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Sep 2010
    Posts
    12

    Synaptic Package Manager frozen


    I was trying to update a few things and Synaptic Package Manager is totally frozen. I have tried Google to figure out what the process is called so I can kill it in system monitor, but I can't find anything. Why the heck is there no force-kill option in the right click menu? I never remember having this many problems with Linux years ago. This is so disappointing...

  2. #2
    Just Joined!
    Join Date
    Sep 2010
    Posts
    12
    While it isn't my exact problem I found a good site(but I don't have enough posts to tell you what it is.....)

    For some reason after running the following commands it finally let me hit the x on the package manager window:

    Code:
    ps -aux | grep synaptic
    
    sudo kill -9 (tried several process IDs here)
    
    sudo cat /var/lib/dpkg/lock > lock.lst
    
    sudo gedit /var/lib/dpkg/lock > lock.lst
    Though I did not find or modify anything in lock.lst, it was not until I tried to open that with gedit that it let me close the package manager window. The package manager gave me some sort of error message about lock.lst, but it went away so fast I don't know what it said. I have absolutely no idea how this managed to do the job. I'm worried about this happening again.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •