Find the answer to your Linux question:
Results 1 to 7 of 7
Hi! I'm trying to install my Canon MP640 Printer in Linux Mint Julia, but when I open the setupfile I get this message: The file '/media/CANON_IJ/win/MSETUP4.EXE' is not marked as ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Dec 2010
    Posts
    4

    How to run executable files in Linux?


    Hi!
    I'm trying to install my Canon MP640 Printer in Linux Mint Julia, but when I open the setupfile I get this message:

    The file '/media/CANON_IJ/win/MSETUP4.EXE' is not marked as executable. If this was downloaded or copied from an untrusted source, it may be dangerous to run. For more details, read about the executable bit.

    I followed the required steps (right-click on the file, select properties, select permissions and activate the button saying "Allow executing file as program"). I even tried to follow these steps after copying the setupfile to the front screen.

    I have installed Wine, but I keep getting the message "Path not found" when I try to run the setupfile.

    Can anyone instruct me on how to install executable files like this in Linux, without making it to complicated? I noticed there are many people at other forums having the same problem as me, and I tried to follow the given instructions at those forums, but they were too difficult for a newbie like me.

    I am greatful to anyone who can help me with my problem!

  2. #2
    Linux User Manko10's Avatar
    Join Date
    Sep 2010
    Posts
    250
    Don't use the Windows driver on Linux. Instead you should use the cups driver. See here: Install Canon MP640 on Ubuntu GartenEden
    Refining Linux Advent calendar: “24 Outstanding ZSH Gems”

  3. #3
    Just Joined!
    Join Date
    Dec 2010
    Posts
    4
    Thank you for answering my question. I must admit I didn't fully understand your answer.

    What do you mean by "cups driver" instead of "Windows driver"?
    I followed your link, and downloaded Debian Linux Print Drivers version 3.2. But what do I do next? When I open the installfile I get this message:

    Could not open the file /home/oistein/.cache/.fr….20-1-i386-deb/install.sh.

  4. $spacer_open
    $spacer_close
  5. #4
    Linux Guru reed9's Avatar
    Join Date
    Feb 2009
    Location
    Boston, MA
    Posts
    4,651
    You cannot run windows programs in Linux, except with WINE. WINE mimics the Windows API, but is not a panacea. Many things do not work completely in WINE, and generally anything to do with hardware is not going to work.

    You need a linux driver for the printer. Much of the time, this is a trivial task as drivers are included in various driver packages, such as foomatic.

    Unfortunately, your printer is not included from what I could find. Fortunately, canon has released a linux driver, but it's not as straightforward to install as one might hope.

    Here's a distillation of what I found.

    First, download some necessary dependencies
    Code:
    sudo apt-get install libtiff4 libxml1 libglade0 libpng3
    You then need to download packages for the printer and scanner.

    Download as so
    Code:
    cd ~
    wget http://gdlp01.c-wss.com/gds/6/0100002366/01/cnijfilter-mp640series-3.20-1-i386-deb.tar.gz
    wget http://gdlp01.c-wss.com/gds/9/0100002379/01/scangearmp-mp640series-1.40-1-i386-deb.tar.gz
    Extract the archived files.

    Code:
    tar -zxvf cnijfilter-mp640series-3.20-1-i386-deb.tar.gz
    tar -zxvf scangearmp-mp640series-1.40-1-i386-deb.tar.gz
    Enter the extracted directory and run the install script
    Code:
    cd cnijfilter-mp640series-3.20-1-i386-deb
    sh ./install.sh
    cd ../scangearmp-mp640series-1.40-1-i386-deb
    sh ./install.sh
    And that should do it. If you're running 64 bit, this won't work. This fellow has modified the install.sh script to work with 64 bit systems. (You have to force it to install despite the conflicting architectures. Most the time a bad idea, but apparently works for this here driver.)

    Edit: That's handy site the previous poster found too. All my typing and I didn't check that someone else already posted.

  6. #5
    Just Joined!
    Join Date
    Dec 2010
    Posts
    4
    Thank you so much for your answers!
    I will try to do what you wrote, and let you know if I succeed.

  7. #6
    Just Joined!
    Join Date
    Dec 2010
    Posts
    4
    I installed and extracted all the files and i think it worked. But if I write something in OpenOffice and want to print it out it doesn't work. I have an install-CD to the printer, but when I click the setup-button I get the same message as earlier.

    I think maybe the scanner is connected to the computer, but I can't print my documents.

  8. #7
    Linux Guru reed9's Avatar
    Join Date
    Feb 2009
    Location
    Boston, MA
    Posts
    4,651
    Except in the rare case where a company provides linux drives with their hardware, your install CD is useless. Again, software for Windows doesn't run under Linux, anymore than it would run on a Mac or Mac software on Windows. They are totally different.

    Once everything is installed, you probably need to restart cups
    Code:
    sudo /etc/init.d/cups restart
    Then open your browser to
    Code:
    http://localhost:631/
    This should bring you to a web interface for printer management where you can setup the printer.

    Or, Ubuntu has some sort of printer configuration software. Should be in the menu or launch with
    Code:
    system-config-printer

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •