Find the answer to your Linux question:
Results 1 to 6 of 6
Hello. I am new to Linux and recently installed Linux Mint 10 Julia on my Dell Inspiron 2.6 Ghz desktop. I love the new system, and am getting familiar with ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jan 2011
    Posts
    3

    Mint 10 not seeing DVD


    Hello. I am new to Linux and recently installed Linux Mint 10 Julia on my Dell Inspiron 2.6 Ghz desktop.

    I love the new system, and am getting familiar with the new set up. One problem that I've encountered is that I can not see my DVD and USB drives. I've gone under the main menu>system tools>system profiler>system information and high lighted the "Storage" tab but neither the USB nor the DVD storage drive are there.

    I have been able to use Brasero to burn data onto a CD and a DVD so I know the DVD burner is functional, as it was in Windows. I've also been able to use the CD writer to import songs from CD format into MP3 format in Rhythmbox on my computer.

    It appears that Linux will recognize data when a disc is loaded into the bay, but it will not recognize a blank disc or a USB drive as being available to save data.

    If anyone may have some suggestions on what I should do to correct this problem, it would be greatly appreciated. Thanks in advance for your help.

  2. #2
    Linux Guru reed9's Avatar
    Join Date
    Feb 2009
    Location
    Boston, MA
    Posts
    4,651
    Normally, when you put in a blank CD or plug in a flash drive, an icon will appear on your desktop and in your file manager indicating their presence. You're saying this is not occurring? And aside from that, the CD burner is fully functional and working - you said you were able to burn without problems?

    Can you plug in a usb flash drive and post the output of
    Code:
    sudo fdisk -l
    dmesg | tail

  3. #3
    Just Joined!
    Join Date
    Jan 2011
    Posts
    3
    Thanks for the input, it is much appreciated.

    Yes, you are correct that neither a blank CD, nor a USB drive show on the file manager. I previously had Windows on this machine, and the CD and USB both functioned correctly. After I stripped off Windows and installed Linux, I have not been able to see the CD or USB Drive.

    I input the code you suggested, and the response back that I received follows below. Unfortunately, I do not understand the information which it has provided. Thanks again for the help, and the code response was:

    Disk /dev/sda: 500.1 GB, 500107862016 bytes
    255 heads, 63 sectors/track, 60801 cylinders
    Units = cylinders of 16065 * 512 = 8225280 bytes
    Sector size (logical/physical): 512 bytes / 512 bytes
    I/O size (minimum/optimal): 512 bytes / 512 bytes
    Disk identifier: 0x10000000

    Device Boot Start End Blocks Id System
    /dev/sda1 * 1 12158 97654784 83 Linux
    /dev/sda2 12158 60802 390728705 5 Extended
    /dev/sda5 12158 36473 195311616 83 Linux
    /dev/sda6 36474 59293 183296000 83 Linux
    /dev/sda7 59293 60802 12119040 82 Linux swap / Solaris

  4. $spacer_open
    $spacer_close
  5. #4
    Linux Guru reed9's Avatar
    Join Date
    Feb 2009
    Location
    Boston, MA
    Posts
    4,651
    The fdisk -l command is listing your drives. This is showing you have 1 500 GB harddrive, labeled /dev/sda. If the usb flash drive is plugged in, it's not showing, which is a bigger problem than it could have been, I'm afraid. Can you try a different usb port and see if it shows?

    Also, can you give the dmesg | grep tail output after plugging in the drive as well?

    This firefox add on may be helpful for running commands.
    https://addons.mozilla.org/en-US/fir...n/terminalrun/

  6. #5
    Just Joined!
    Join Date
    Jan 2011
    Posts
    3
    Thanks for explaining this to me, and now it makes sense to me.

    I confirmed that the CD and USB drive were in place, and ran the command again. The output I received was:

    Disk /dev/sda: 500.1 GB, 500107862016 bytes
    255 heads, 63 sectors/track, 60801 cylinders
    Units = cylinders of 16065 * 512 = 8225280 bytes
    Sector size (logical/physical): 512 bytes / 512 bytes
    I/O size (minimum/optimal): 512 bytes / 512 bytes
    Disk identifier: 0x10000000

    Device Boot Start End Blocks Id System
    /dev/sda1 * 1 12158 97654784 83 Linux
    /dev/sda2 12158 60802 390728705 5 Extended
    /dev/sda5 12158 36473 195311616 83 Linux
    /dev/sda6 36474 59293 183296000 83 Linux
    /dev/sda7 59293 60802 12119040 82 Linux swap / Solaris

    Disk /dev/sdb: 1028 MB, 1028653056 bytes
    16 heads, 32 sectors/track, 3924 cylinders
    Units = cylinders of 512 * 512 = 262144 bytes
    Sector size (logical/physical): 512 bytes / 512 bytes
    I/O size (minimum/optimal): 512 bytes / 512 bytes
    Disk identifier: 0x1fbe376b

    Device Boot Start End Blocks Id System
    /dev/sdb1 1 3924 1004528 e W95 FAT16 (LBA)
    allen@allen-Inspiron-531 ~ $ dmesg | tail
    [77701.024071] ata4.00: exception Emask 0x0 SAct 0x0 SErr 0x0 action 0x6 frozen
    [77701.024085] sr 3:0:0:0: CDB: Xpwrite, Read disk info: 51 00 00 00 00 00 00 00 02 00
    [77701.024116] ata4.00: cmd a0/00:00:00:02:00/00:00:00:00:00/a0 tag 0 pio 16388 in
    [77701.024119] res 40/00:02:00:08:00/00:00:00:00:00/a0 Emask 0x4 (timeout)
    [77701.024126] ata4.00: status: { DRDY }
    [77701.024138] ata4: hard resetting link
    [77701.024143] ata4: nv: skipping hardreset on occupied port
    [77701.492074] ata4: SATA link up 1.5 Gbps (SStatus 113 SControl 300)
    [77701.516200] ata4.00: configured for UDMA/100
    [77701.516599] ata4: EH complete
    allen@allen-Inspiron-531 ~ $

    If I understand correctly, you wanted me to input the command sudo fdisk -ldmesg|tail

    the response I got was:

    allen@allen-Inspiron-531 ~ $ sudo fdisk -ldmesg|tail
    fdisk: invalid option -- 'd'

    Usage:
    fdisk [options] <disk> change partition table
    fdisk [options] -l <disk> list partition table(s)
    fdisk -s <partition> give partition size(s) in blocks

    Options:
    -b <size> sector size (512, 1024, 2048 or 4096)
    -c switch off DOS-compatible mode
    -h print help
    -u <size> give sizes in sectors instead of cylinders
    -v print version
    -C <number> specify the number of cylinders
    -H <number> specify the number of heads
    -S <number> specify the number of sectors per track

  7. #6
    Linux Guru reed9's Avatar
    Join Date
    Feb 2009
    Location
    Boston, MA
    Posts
    4,651
    So that's all fine.

    This problem crops up every now and again and it's unfortunately difficult to diagnose.

    First thing I would try is to open gconf-editor
    Code:
    gconf-editor
    Then navigate to apps -> nautilus -> desktop

    And make sure volumes_visible is checked.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •