Find the answer to your Linux question:
Results 1 to 6 of 6
Hi everybody, I searched on the forums and didn't find anything related to my problem so I hope someone can help. I use LMDE and I was trying to install ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jan 2011
    Posts
    6

    [SOLVED] Can't log in


    Hi everybody, I searched on the forums and didn't find anything related to my problem so I hope someone can help.

    I use LMDE and I was trying to install japanese language support but I must have done something wrong because now I can't log in. At one point I had to restart the computer and now I get the login screen (when I used to login automatically), I type the password over and over again but I get the same login screen and can't get past that. I'm writing from my XP partition in the meantime but all my files and stuff from work are in the linux part so I can't get anything done.

    Here's what I did, step by step, hoping someone can point out what I did wrong and how to get it right again.

    Via synaptic installed anthy, scim, scim-anthy, scim-tables-ja, scim-bridge-agent and scim-bridge-client-gtk.
    Then via terminal:
    Code:
    # dpkg-reconfigure locales
    where I choose 'ja_JP.UTF-8' and hit enter. Then:
    Code:
    # gedit /etc/scim/global
    and where it says 'SupportedUnicodeLocales' I added 'ja_JP.UTF-8'. Then:
    Code:
    # gedit /etc/scim/config
    and where it says '/FrontEnd/X11/Dynamic = false' I changed false to true. Then:
    Code:
    # im-switch -s none
    but as it turned out, 'im-switch' was not installed. I checked synaptic and instead I had 'im-config' installed so at the terminal I did:
    Code:
    # im-config -s none
    This time a window showed up with options like 'use default', 'use scim', 'automatic', etc but rather than change something there I cancelled and went back to synaptic to install 'im-switch', which in turn had to uninstall 'im-config'. Then I went back to terminal and did:
    Code:
    # im-switch -s none
    and apparently nothing hapenned so I thought it was okay, then restarted and that was it, now I can't log in.

    Where did I go wrong? can someone help me correct it?

    Thanks!

  2. #2
    Linux Engineer nujinini's Avatar
    Join Date
    Apr 2009
    Posts
    1,274
    brunn!

    How's your problem?

    I'm not familiar with your issue but...

    ...in the meantime but all my files and stuff from work are in the linux part so I can't get anything done.
    You can rescue your data from linux partition by booting from a live cd and saving your files. After which you can consider making a fresh install. This is the only thing I can think of. At least you can move forward with your works.
    nujinini
    Linux User #489667

  3. #3
    Just Joined!
    Join Date
    Jan 2011
    Posts
    6
    Hi nujinini! (you know? you're the only one that pays me attention on this forum )

    I actually did that much and backed up all my files from a live CD, but before re-installing I tried undoing my footsteps per someone else's suggestion and it worked. Turns out the problem was caused by installing im-switch (which in turn uninstalled im-config). Not sure why it wouldn't work since the description for both programs is the same. But anyway, bringing back im-config fixed the problem and now I can log back in.

    On a sidenote, I'm now able to write japanese thanks to ibus. If I had known it would be so simple I could have saved myself a big headache... but I wouldn't have learned as much.

    Thanks a lot for replying, and I'll see you when I mess something up again

    Edit: somehow the original post does not show the 'edit' option to mark it solved, so maybe a moderator can help...

  4. $spacer_open
    $spacer_close
  5. #4
    Linux Engineer nujinini's Avatar
    Join Date
    Apr 2009
    Posts
    1,274
    Quote Originally Posted by brunn View Post
    ...somehow the original post does not show the 'edit' option to mark it solved, so maybe a moderator can help...
    Hi,

    Glad your problems solved. You can mark your own thread as solved by clicking on "Thread Tools" and the rest is pretty easy.

    Anyway, there can be 1001 reasons why some questions get unnoticed and your guess can be as good as mine.

    Don't hesitate to ask any linux questions in the future. People here are generally very kind and helpful.

    Cheers

    EDIT: By the way, with your experience, you just learned two things...ONE how to solve your problem ans TWO how not to do it again.
    nujinini
    Linux User #489667

  6. #5
    Just Joined!
    Join Date
    Feb 2011
    Posts
    1
    Wow thanks for posting this. I just did the same thing after install im-switch, if I didnt find your post I probably would have been pulling my hair out for a while.

  7. #6
    Just Joined!
    Join Date
    Jan 2011
    Posts
    6
    I'm glad this helped you

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •