Find the answer to your Linux question:
Results 1 to 6 of 6
New to Linux (so apologies for my "simple" questions!) ASUS PCI-G312 wireless adapter Old PC with Linux Mint 8 universal installed I want to install the drivers for the wireless ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Mar 2011
    Posts
    2

    Install Wireless ASUS PCI-G31 802.11 g/b


    New to Linux (so apologies for my "simple" questions!)

    ASUS PCI-G312 wireless adapter

    Old PC with Linux Mint 8 universal installed

    I want to install the drivers for the wireless card to allow facilitate internet connection...

    Here's some info to hopefully help you:-

    Code:
    PCI Wireless (lspci)
    
    00:00.0 Host bridge: Silicon Integrated Systems [SiS] 735 Host (rev 01)
    00:01.0 PCI bridge: Silicon Integrated Systems [SiS] Virtual PCI-to-PCI bridge (AGP)
    00:02.0 ISA bridge: Silicon Integrated Systems [SiS] SiS85C503/5513 (LPC Bridge)
    00:02.1 SMBus: Silicon Integrated Systems [SiS] SiS961/2 SMBus Controller
    00:02.2 USB Controller: Silicon Integrated Systems [SiS] USB 1.1 Controller (rev 07)
    00:02.3 USB Controller: Silicon Integrated Systems [SiS] USB 1.1 Controller (rev 07)
    00:02.5 IDE interface: Silicon Integrated Systems [SiS] 5513 [IDE] (rev d0)
    00:02.7 Multimedia audio controller: Silicon Integrated Systems [SiS] AC'97 Sound Controller (rev a0)
    00:03.0 Ethernet controller: Silicon Integrated Systems [SiS] SiS900 PCI Fast Ethernet (rev 90)
    00:0d.0 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev 62)
    00:0d.1 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev 62)
    00:0d.2 USB Controller: VIA Technologies, Inc. USB 2.0 (rev 65)
    00:11.0 Network controller: RaLink RT2561/RT61 802.11g PCI
    01:00.0 VGA compatible controller: ATI Technologies Inc Rage 128 Pro Ultra TF

    Code:
    Driver Modules (lsmod)
    
    snd_seq_midi            6432  0
    snd_rawmidi            22208  3 snd_wavefront,snd_mpu401_uart,snd_seq_midi
    snd_seq_midi_event      6940  2 snd_seq_oss,snd_seq_midi
    snd_seq                50224  6 snd_seq_dummy,snd_seq_oss,snd_seq_midi,snd_seq_midi_event
    snd_timer              22276  4 snd_wss_lib,snd_opl3_lib,snd_pcm,snd_seq
    snd_seq_device          6920  6 snd_opl3_lib,snd_seq_dummy,snd_seq_oss,snd_seq_midi,snd_rawmidi,snd_seq
    snd                    59204  21 snd_wavefront,snd_cs4236,snd_wss_lib,snd_opl3_lib,snd_intel8x0,snd_ac97_codec,snd_hwdep,snd_pcm_oss,snd_mixer_oss,snd_pcm,snd_mpu401,snd_mpu401_uart,snd_seq_oss,snd_rawmidi,snd_seq,snd_timer,snd_seq_device
    soundcore               7264  1 snd
    snd_page_alloc          9156  3 snd_wss_lib,snd_intel8x0,snd_pcm
    dm_raid45              84228  0
    xor                    15620  1 dm_raid45
    sis900                 19932  0
    mii                     5212  1 sis900
    sis_agp                 6972  1
    agpgart                34988  2 drm,sis_agp
    floppy                 54916  0
    Linux Distibution & Version (uname )

    Linux

    (( LINUX MINT UNIVERSAL VERSION ))

    I tried highlighting text , Gedit etc.. but had to resort to "cut & paste" with open office ..

    Anyway hope someone can help & assist..

    Regards,
    Last edited by MikeTbob; 04-24-2011 at 12:38 AM. Reason: Added Code Tags

  2. #2
    Just Joined!
    Join Date
    Dec 2010
    Posts
    32
    have you tried to install the driver in ndiswrapper a.k.a. windows wireless driver in the administration menu?

  3. #3
    Administrator MikeTbob's Avatar
    Join Date
    Apr 2006
    Location
    Texas
    Posts
    7,864
    Wow this post slipped right past us, sorry about that. Anyhow, Welcome to the forums. If you're still here we'd like to try and help you get this resolved.
    Do you have a working Internet connection at present? Did you try installing the drivers from the system menu? System>Administration>Additional Drivers
    Last edited by MikeTbob; 04-24-2011 at 01:10 AM. Reason: Added extra info
    I do not respond to private messages asking for Linux help, Please keep it on the forums only.
    All new users please read this.** Forum FAQS. ** Adopt an unanswered post.

    I'd rather be lost at the lake than found at home.

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined!
    Join Date
    Mar 2011
    Posts
    2

    Wireless ASUS PCI-G31 802.11 problems

    Thanks to both sicko65 & MikeTbob ..

    Answer for sicko65:

    I get error message "unable to see if hardware is present"

    NB/ when I cjeck on currently installed windows drivers I get the following:-

    netr61
    Hardware present - Yes

    rt61
    Hardware present - Yes

    (both these were installed from the ASUS drivers CDRom)????


    Answer for MickTbob

    (A) Yes- I Ihave access to windows & Mac PCs internet access...

    ...also if I move the Linux PC close to the router & by use of an ethernet cable the Linux PC connects to the internet straight away?


    (B) If I do :-
    menu
    admin
    hardware drivers
    "searching for available drivers..."

    This results in error message " No propietary drivers are in use on this system"

    Hum???


    Any ideas ?

    Best Regards,

  6. #5
    Just Joined!
    Join Date
    Dec 2010
    Posts
    32
    wow that really is strange. and yes when connected via Ethernet it should connect automatically with autoeth0

  7. #6
    Linux Engineer MASONTX's Avatar
    Join Date
    May 2010
    Location
    Mason Texas
    Posts
    934
    Mint 8 is from 2009, you might try installing the current Mint 10, Lubuntu, or some other current distro to see if that solves the problem. Try a live cd of the current Ubuntu to see if it works, if it does, then you have a software problem, but if it doesn't, you may have a hardware problem.
    Registered Linux user #526930

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •