Find the answer to your Linux question:
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 19
Hello Forum. When viewing the Desktop, I am not able to see the last 3" (or so) of the screen. This problem occurred after I swapped out my Radeon X300 ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Aug 2010
    Posts
    28

    Question [SOLVED] Display does not fill the screen


    Hello Forum.
    When viewing the Desktop, I am not able to see the last 3" (or so) of the screen.
    This problem occurred after I swapped out my Radeon X300 Graphics card with a PNY GeForce4 MX440se 64MB SDR PCI with TV-Out & RCA Video Card.

    I removed the PNY GeForce4 card and re-installed the Radeon X300 card then restarted the computer and that is when I noticed that the last 3" of the display was missing, as well as the "Screenlets" that I had on my desktop.

    I have searched the Linux Mint Forums and Posted this issue there. It was suggested that I search the xorg.conf Folder/Files and removed all that contained the entry Nvidia.
    This did not solve the issue and beyond that, I don't know what else to do.

    I am using Linux Mint 10 x86 on an AMD 64bit computer with 2 GIGs of RAM.
    If any further information is needed please let me know.

    Any help will be gratefully and enthusiastically accepted.

    [EDIT] I just thought of something else that may (or may not) be important.
    The Radeon X300 Graphics adapter that was originally installed in the computer when I installed Linux Mint 10 is a PCIE card while the PNY GeForce4 MX440se 64MB is a PCI card.
    Just thought I should add this information.
    Last edited by patriot56; 04-11-2011 at 05:57 PM. Reason: More information.....

  2. #2
    Linux Engineer MASONTX's Avatar
    Join Date
    May 2010
    Location
    Mason Texas
    Posts
    928
    Try going into system>administration>system monitor and manually adjust the setting to the proper resolution. Also try system>administration>additional drivers to make sure you have the proper driver loaded. Good luck!
    Registered Linux user #526930

  3. #3
    Penguin of trust elija's Avatar
    Join Date
    Jul 2004
    Location
    Either at home or at work or down the pub
    Posts
    3,296
    Does your monitor have an "auto-adjust" feature on it's configuration menus? This will sometimes sort out strangely sized displays
    What do we want?
    Time machines!

    When do we want 'em?
    Doesn't really matter does it!?


    Conkybots: Interactive plugins for your Conkys!

  4. #4
    Just Joined!
    Join Date
    Aug 2010
    Posts
    28
    @MASONTX
    Thank you for your responce.
    I tried to adjust the resolution manually-no joy.
    All that happens is that the resolution grows or shrinks as I change the resolution settings up or down. The bottom 3" of my screen is still black.
    Anything else that you can think of that I can try would be really appreciated.
    Thanks again mate.

  5. #5
    Just Joined!
    Join Date
    Aug 2010
    Posts
    28
    @elija
    Thank you for the post. I tried your suggestion and selected the "auto-adjust" from the monitors configuration menu but it didn't work. I even reverted to "Factory Default" settings: that didn't work either.

    I believe that the problem lies in the Kernel. I think what happened was that when I switched the ATI video card with the Nvidia card the Kernel saw that there was a new video card in the machine and installed the drivers for it.
    The problem (I believe) is that when I switched back to the ATI card it somehow hosed the Kernel module for the video drivers. If that is even possible. I don't know, it's just a hunch. I am so new to Linux that very little of this makes any since to me.
    Thanks for your help.

  6. #6
    Penguin of trust elija's Avatar
    Join Date
    Jul 2004
    Location
    Either at home or at work or down the pub
    Posts
    3,296
    So we've eliminated a possible easier fix or two which is both good and bad!

    Run the following commands on the terminal and copy / paste the output here. The first one will show what graphics card is being picked up as in use, which should be your ATi
    Code:
    lspci | grep -i vga
    and then we look at what drivers you have running with
    Code:
    lsmod
    What do we want?
    Time machines!

    When do we want 'em?
    Doesn't really matter does it!?


    Conkybots: Interactive plugins for your Conkys!

  7. #7
    Just Joined!
    Join Date
    Aug 2010
    Posts
    28
    elija.
    Here's the output from the lspci | grep -i vga command:
    Code:
    lspci | grep -i vga
    05:00.0 VGA compatible controller: ATI Technologies Inc RV370 5B60 [Radeon X300 (PCIE)]
    And this is the output from the lsmod command:
    Code:
    Module                  Size  Used by
    ufs                    73069  0 
    qnx4                    6877  0 
    hfsplus                71344  0 
    hfs                    41250  0 
    minix                  25303  0 
    ntfs                   95015  0 
    msdos                   6436  0 
    jfs                   171034  0 
    xfs                   693150  0 
    exportfs                3449  1 xfs
    reiserfs              225942  0 
    nls_iso8859_1           3261  2 
    nls_cp437               4931  2 
    vfat                    9201  2 
    fat                    48240  2 msdos,vfat
    binfmt_misc             6599  1 
    ipt_REJECT              2004  1 
    ipt_LOG                 4490  11 
    xt_limit                1394  7 
    xt_tcpudp               1927  7 
    ipt_addrtype            1611  4 
    dm_crypt               11385  0 
    xt_state                1014  6 
    snd_emu10k1_synth       5136  0 
    snd_emux_synth         29012  1 snd_emu10k1_synth
    snd_seq_virmidi         4193  1 snd_emux_synth
    snd_seq_midi_emul       5547  1 snd_emux_synth
    snd_usb_audio          86704  1 
    snd_emu10k1           131818  3 snd_emu10k1_synth
    snd_util_mem            3118  2 snd_emux_synth,snd_emu10k1
    snd_hwdep               5040  3 snd_emux_synth,snd_usb_audio,snd_emu10k1
    snd_intel8x0           25632  2 
    snd_ac97_codec         99227  2 snd_emu10k1,snd_intel8x0
    snd_usbmidi_lib        17413  1 snd_usb_audio
    ac97_bus                1014  1 snd_ac97_codec
    ip6table_filter         1275  1 
    ip6_tables             11764  1 ip6table_filter
    snd_pcm                71475  4 snd_usb_audio,snd_emu10k1,snd_intel8x0,snd_ac97_codec
    snd_seq_midi            4588  0 
    snd_seq_midi_event      6047  2 snd_seq_virmidi,snd_seq_midi
    snd_seq                47174  5 snd_emux_synth,snd_seq_virmidi,snd_seq_midi_emul,snd_seq_midi,snd_seq_midi_event
    nf_nat_irc              1168  0 
    nf_conntrack_irc        3348  1 nf_nat_irc
    snd_rawmidi            17783  4 snd_seq_virmidi,snd_emu10k1,snd_usbmidi_lib,snd_seq_midi
    snd_timer              19067  3 snd_emu10k1,snd_pcm,snd_seq
    nf_nat_ftp              1398  0 
    snd_seq_device          5744  5 snd_emu10k1_synth,snd_emu10k1,snd_seq_midi,snd_seq,snd_rawmidi
    nf_nat                 16289  2 nf_nat_irc,nf_nat_ftp
    nf_conntrack_ipv4      10783  8 nf_nat
    nf_defrag_ipv4          1117  1 nf_conntrack_ipv4
    gspca_sonixj           25836  0 
    nf_conntrack_ftp        5361  1 nf_nat_ftp
    nf_conntrack           63258  7 xt_state,nf_nat_irc,nf_conntrack_irc,nf_nat_ftp,nf_nat,nf_conntrack_ipv4,nf_conntrack_ftp
    gspca_main             23644  1 gspca_sonixj
    iptable_filter          1302  1 
    snd                    49006  23 snd_emux_synth,snd_seq_virmidi,snd_usb_audio,snd_emu10k1,snd_hwdep,snd_intel8x0,snd_ac97_codec,snd_usbmidi_lib,snd_pcm,snd_seq,snd_rawmidi,snd_timer,snd_seq_device
    psmouse                59033  0 
    ip_tables              10460  1 iptable_filter
    videodev               43098  1 gspca_main
    soundcore                880  1 snd
    x_tables               15921  10 ipt_REJECT,ipt_LOG,xt_limit,xt_tcpudp,ipt_addrtype,xt_state,ip6table_filter,ip6_tables,iptable_filter,ip_tables
    v4l1_compat            13359  1 videodev
    snd_page_alloc          7120  3 snd_emu10k1,snd_intel8x0,snd_pcm
    serio_raw               4022  0 
    emu10k1_gp              1472  0 
    i2c_nforce2             5179  0 
    gameport                9327  2 emu10k1_gp
    joydev                  8735  0 
    ppdev                   5556  0 
    lp                      7342  0 
    parport_pc             26058  1 
    k8temp                  3132  0 
    parport                31492  3 ppdev,lp,parport_pc
    dm_raid45              81721  0 
    xor                    15136  1 dm_raid45
    btrfs                 489451  0 
    zlib_deflate           19266  1 btrfs
    crc32c                  2531  1 
    libcrc32c                887  1 btrfs
    usbhid                 36882  0 
    hid                    67742  1 usbhid
    radeon                825934  2 
    ttm                    56633  1 radeon
    drm_kms_helper         30200  1 radeon
    drm                   168054  4 radeon,ttm,drm_kms_helper
    firewire_ohci          21106  0 
    firewire_core          46643  1 firewire_ohci
    sata_nv                19420  0 
    crc_itu_t               1383  1 firewire_core
    pata_amd                8746  2 
    forcedeth              49433  0 
    floppy                 54311  0 
    agpgart                32011  2 ttm,drm
    i2c_algo_bit            5168  1 radeon
    usb_storage            40172  2
    By the way elija, thank you for such a quich response.
    I am currently at work so my response may be a little slow but I will respond as I have the opportunity.
    Last edited by MikeTbob; 04-17-2011 at 02:15 PM. Reason: Added Code Tags

  8. #8
    Penguin of trust elija's Avatar
    Join Date
    Jul 2004
    Location
    Either at home or at work or down the pub
    Posts
    3,296
    I can't see anything immediately wrong there; there don't appear to be any nvidia drivers lying around. I don't have an ATi card so I'm afraid that I may be a bit fuzzy on the details but the approach I would take if this happened with Nvidia is to:

    open a terminal and run the following commands
    Code:
    cd /etc/X11
    sudo mv xorg.conf xorg.saved
    and then reboot. In the first command, that's a capital X and two ones. This will backup your display configuration and then the reboot will force Mint to use a default configuration. This won't be the proprietary drivers but will hopefully use the whole screen.

    I would then use the Nvidia control panel to configure things up again. I hope that ATi provide one of those as they do make things easy.

    This is kind of reaching the edges of my knowledge now, so hopefully a real guru will be along shortly
    Last edited by elija; 04-17-2011 at 03:04 PM.
    What do we want?
    Time machines!

    When do we want 'em?
    Doesn't really matter does it!?


    Conkybots: Interactive plugins for your Conkys!

  9. #9
    Just Joined!
    Join Date
    Aug 2010
    Posts
    28
    Thanks elija.
    I will give this a try and then post the results.
    If anything good has come from this it is that I am leaning Linux bits and pieces at a time. :o)

    I'll let you know what happens.

  10. #10
    Just Joined!
    Join Date
    Aug 2010
    Posts
    28
    I ran into a problem with the second command.
    When I executed the command, sudo my xorg.conf xorg.saved this is what I got:

    sudo: my: command not found

    Did I do something wrong? Do I need to do this as root?

Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •