Hey everyone!

Linux Mint had been running well on my Acer Aspire one netbook in the last few months. Well today, I installed BackTrack 5 along with it as a dual boot. Everything worked fine, I was able to dual boot between BT5 and LM10 with no problem. I've booted on both OS multiple times. But today, I tried booting in Linux Mint, and it gave me an error similar to this code:

Busybox v1.10.2 init not found try passing init = bootarg
Linux Mint wasn't able to boot properly but BT5 still boots fine. I wonder if I can fix the "init" file or script using BT5 (I can access the 'filesystem' of Linux Mint in BT5). I Googled the error, and most people suggested booting from the LiveCD and try fixing it from there. Unfortunately, I do not have the LiveCD because I installed Linux Mint through USB key on my netbook. I am fairly new to Linux so please bare with me.

I cannot lose Linux Mint because it's my primary OS. I installed BT5 along with the Mint for my IT/computer class.

Thanks in advanced!