Find the answer to your Linux question:
Page 2 of 4 FirstFirst 1 2 3 4 LastLast
Results 11 to 20 of 32
Like Tree1Likes
It means that your wireless device is "asleep" and we need to "wake it up". Code: sudo rfkill unblock all Post any errors or messages. Now try the new connection ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #11
    Administrator MikeTbob's Avatar
    Join Date
    Apr 2006
    Location
    Texas
    Posts
    7,864

    It means that your wireless device is "asleep" and we need to "wake it up".
    Code:
    sudo rfkill unblock all
    Post any errors or messages. Now try the new connection dialog and see if you can get online.
    I do not respond to private messages asking for Linux help, Please keep it on the forums only.
    All new users please read this.** Forum FAQS. ** Adopt an unanswered post.

    I'd rather be lost at the lake than found at home.

  2. #12
    Just Joined! dylan1031's Avatar
    Join Date
    Jun 2011
    Location
    Florida
    Posts
    16
    I typed “sudo rfkill unblock all”, and got no errors, messages, or dialog boxes. Nothing showed up in the terminal at all after I entered my password.

    When I right click the network connections icon on the task bar though, I see that “Enable Wireless” is now checked and not faded out (for the first time, so im taking that as a good sign)

    But, “Wireless Network (Ralink 802.11 n WLAN)” (which I think is my adaptor), says “device not ready (firmware missing)”. I hope thats not a bad thing

  3. #13
    Administrator MikeTbob's Avatar
    Join Date
    Apr 2006
    Location
    Texas
    Posts
    7,864
    Try this command and see if it gives any output.
    Code:
    sudo dmesg | grep -i firmware
    I do not respond to private messages asking for Linux help, Please keep it on the forums only.
    All new users please read this.** Forum FAQS. ** Adopt an unanswered post.

    I'd rather be lost at the lake than found at home.

  4. #14
    Just Joined! dylan1031's Avatar
    Join Date
    Jun 2011
    Location
    Florida
    Posts
    16
    ok, this is what i got:

    Code:
    dylan@dylan-Lenovo-V560 ~ $ sudo dmesg | grep -i firmware
    [sudo] password for dylan: 
    [    0.512155] [Firmware Bug]: ACPI: BIOS _OSI(Linux) query ignored
    [   21.145737] iwlagn 0000:04:00.0: loaded firmware version 41.28.5.1 build 33926
    [   21.359599] elantech: assuming hardware version 2, firmware version 4.0.2
    [   24.539410] i2400m_usb 2-1.4:1.0: firmware interface version 9.3.2

  5. #15
    Administrator MikeTbob's Avatar
    Join Date
    Apr 2006
    Location
    Texas
    Posts
    7,864
    I think the firmware is loaded. Try this command please.
    Code:
    sudo dmesg | grep -i iwlagn
    I do not respond to private messages asking for Linux help, Please keep it on the forums only.
    All new users please read this.** Forum FAQS. ** Adopt an unanswered post.

    I'd rather be lost at the lake than found at home.

  6. #16
    Just Joined! dylan1031's Avatar
    Join Date
    Jun 2011
    Location
    Florida
    Posts
    16
    I just realized that sense i rebooted Linux, the "Enable Wireless" option has faded out again and the message next to the adapter option says that the hardware switch is off again.
    But i entered what you said in the termianl and this is what it said:

    Code:
    dylan@dylan-Lenovo-V560 ~ $ sudo dmesg | grep -i iwlagn
    [sudo] password for dylan: 
    [   21.529893] iwlagn: Intel(R) Wireless WiFi Link AGN driver for Linux, in-tree:
    [   21.529896] iwlagn: Copyright(c) 2003-2010 Intel Corporation
    [   21.530017] iwlagn 0000:04:00.0: PCI INT A -> GSI 17 (level, low) -> IRQ 17
    [   21.530055] iwlagn 0000:04:00.0: setting latency timer to 64
    [   21.530132] iwlagn 0000:04:00.0: Detected Intel(R) Centrino(R) Advanced-N + WiMAX 6250 AGN, REV=0x84
    [   21.540150] iwlagn 0000:04:00.0: device EEPROM VER=0x554, CALIB=0x6
    [   21.540153] iwlagn 0000:04:00.0: Device SKU: 0Xb
    [   21.540185] iwlagn 0000:04:00.0: Tunable channels: 13 802.11bg, 24 802.11a channels
    [   21.540357] iwlagn 0000:04:00.0: irq 42 for MSI/MSI-X
    [   21.554094] iwlagn 0000:04:00.0: loaded firmware version 41.28.5.1 build 33926

  7. #17
    Administrator MikeTbob's Avatar
    Join Date
    Apr 2006
    Location
    Texas
    Posts
    7,864
    Everything looks perfect to me, I'm not sure what the problem is. Are you still getting the "device not ready (firmware missing)" error?
    I do not respond to private messages asking for Linux help, Please keep it on the forums only.
    All new users please read this.** Forum FAQS. ** Adopt an unanswered post.

    I'd rather be lost at the lake than found at home.

  8. #18
    Just Joined! dylan1031's Avatar
    Join Date
    Jun 2011
    Location
    Florida
    Posts
    16
    No the message changed back to "hardware switch disabled" once i rebooted. The "Enable Wireless" box on the dropdown menue from the icon on the taskbar also faded and unchecked itself again. This all happened after i rebooted, idk what it could be

  9. #19
    Just Joined! dylan1031's Avatar
    Join Date
    Jun 2011
    Location
    Florida
    Posts
    16
    I reran all the commands you gave me from the beginning to see what would happen if ran thema ll in one session, and i got the "Enable Wireless" checkbox able to be checked again, and I checked it. when i tried to connect, the message on the adaptor changed from "hardware switch disabled" to "wireless disabled". so now im thoroughly confused sense when i checked the enable wireless, the message changed to "wireless disabled".

  10. #20
    Administrator MikeTbob's Avatar
    Join Date
    Apr 2006
    Location
    Texas
    Posts
    7,864
    That is confusing as hell. Anyone else have any luck with this card or this error message? I'm stumped.
    The RFkill command will have to be run after every reboot, I didn't want to make it permanent until we got it all working correctly.
    I do not respond to private messages asking for Linux help, Please keep it on the forums only.
    All new users please read this.** Forum FAQS. ** Adopt an unanswered post.

    I'd rather be lost at the lake than found at home.

Page 2 of 4 FirstFirst 1 2 3 4 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •