Find the answer to your Linux question:
Results 1 to 5 of 5
Hello Everyone, I've installed Mint 12 Lisa on a Dell Optiplex 755 with two 250GB SATA HDDs. Both HDDs are being recognized in the BIOS. Both drives are set to ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Feb 2012
    Posts
    4

    Mint 12 not recognizing 2nd HDD.


    Hello Everyone,

    I've installed Mint 12 Lisa on a Dell Optiplex 755 with two 250GB SATA HDDs. Both HDDs are being recognized in the BIOS. Both drives are set to CS with the master at the extreme end of the cable.

    I want to utilize the second HDD only as a backup and additional storage.

    Any assistance on this will be greatly appreciated!

    Thank you.

  2. #2
    Administrator jayd512's Avatar
    Join Date
    Feb 2008
    Location
    Kentucky
    Posts
    5,023
    Hello and Welcome!

    What is the output of
    Code:
    sudo fdisk -l
    If you look at the documentation for the drives, should you have both marked for CS?
    You might need to change the primary drive to Master.
    Jay

    New users, read this first.
    New Member FAQ
    Registered Linux User #463940
    I do not respond to private messages asking for Linux help. Please keep it on the public boards.

  3. #3
    Just Joined!
    Join Date
    Feb 2012
    Posts
    4

    fdisk -l Output.

    Quote Originally Posted by jayd512 View Post
    Hello and Welcome!

    What is the output of
    Code:
    sudo fdisk -l
    If you look at the documentation for the drives, should you have both marked for CS?
    You might need to change the primary drive to Master.
    Thank you for such a prompt response!

    fdisk -l output is as follows:

    Disk /dev/sda: 250.1 GB, 250059350016 bytes
    255 heads, 63 sectors/track, 30401 cylinders, total 488397168 sectors
    Units = sectors of 1 * 512 = 512 bytes
    Sector size (logical/physical): 512 bytes / 512 bytes
    I/O size (minimum/optimal): 512 bytes / 512 bytes
    Disk identifier: 0x000f0f99

    Device Boot Start End Blocks Id System
    /dev/sda1 * 2048 480274431 240136192 83 Linux
    /dev/sda2 480276478 488396799 4060161 5 Extended
    /dev/sda5 480276480 488396799 4060160 82 Linux swap / Solaris

    Disk /dev/sdb: 250.1 GB, 250059350016 bytes
    255 heads, 63 sectors/track, 30401 cylinders, total 488397168 sectors
    Units = sectors of 1 * 512 = 512 bytes
    Sector size (logical/physical): 512 bytes / 512 bytes
    I/O size (minimum/optimal): 512 bytes / 512 bytes
    Disk identifier: 0x00000000

    Disk /dev/sdb doesn't contain a valid partition table

    [END]

    I was going to try changing the jumper to Master and leaving the secondary hdd as CS if other efforts failed.

    Thanks again.

  4. #4
    Just Joined!
    Join Date
    Feb 2012
    Posts
    4

    Addendum.

    Quote Originally Posted by jayd512 View Post
    Hello and Welcome!

    What is the output of
    Code:
    sudo fdisk -l
    If you look at the documentation for the drives, should you have both marked for CS?
    You might need to change the primary drive to Master.
    Well, after further review, I see from that output (fdisk -l) that Mint is recognizing the second hdd after all, "Disk /dev/sdb doesn't contain a valid partition table."

    I am assuming then in this case that I need to mount the drive? sdb needs to be formatted? Any assistance with commands on how to do this would be appreciated!

    Thank you.

  5. #5
    Administrator jayd512's Avatar
    Join Date
    Feb 2008
    Location
    Kentucky
    Posts
    5,023
    The second drive is being detected as /dev/sdb. So I don't think you need to play with the jumper settings.
    What seems to me to be the telling part;
    Code:
    Disk /dev/sdb doesn't contain a valid partition table
    Have you formatted the second drive?
    You can use a LiveCD like GParted or Parted Magic to do the job.
    Once formatted, you should be able to use the second drive for back-ups.

    *EDIT*

    No need to mount the drive at this point.
    Last edited by jayd512; 03-05-2012 at 10:17 PM. Reason: see EDIT
    Jay

    New users, read this first.
    New Member FAQ
    Registered Linux User #463940
    I do not respond to private messages asking for Linux help. Please keep it on the public boards.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •