Find the answer to your Linux question:
Results 1 to 10 of 10
Hey guys, Complete linux noob here! im pretty handy with ms and osx but i thought it was time to start on linux so you will probably see me rearing ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    May 2012
    Posts
    3

    Exclamation Launching a .jar file with more memory


    Hey guys, Complete linux noob here!

    im pretty handy with ms and osx but i thought it was time to start on linux so you will probably see me rearing my ugly head around here a lot for a while :P

    first question...
    Im trying to launch minecraft with more memory but all my searching just come up with is "just launch it using java -Xmx1024M -Xms512M -cp Minecraft.jar net.minecraft.LauncherFrame"

    ...this is all well and good but i have no idea how! on windows i use a similar method but there you just make a .bat file. Im assuming its something similar on linux but using the terminal. If anyone could show me this step by step i would love you forever and maybe even give you a cookie (yummy kind, not the interwebz kind).

    If it helps you to give me a more accurate answer my minecraft.jar file is in the home directory. pwd gives me /home/user . dont know if that helps but i thought i should mention anything i know lol.


    Thanks in advanced guys and girls, I eagerly await your response.

    Peace
    Dan

  2. #2
    Just Joined!
    Join Date
    Apr 2012
    Location
    Australia
    Posts
    33
    java -Xmx1024M -Xms512M -cp "Minecraft.jar net.minecraft.LauncherFrame"

    you probably want more object-stack(-Xms) and as far as i know 1GB is the limit for any.

    type "java -h" at the terminal to see the list of options
    there is also java -X to see extra options not mention in the -h set

    java -Xms786432k -Xmx1048576k -cp "Minecraft.jar net.minecraft.LauncherFrame"

    You could increase your initial object-stack size.

    note: -Xss (objects quantity) is a little interesting to understand but would be too variable in q to set so ignore that unless you get a very comprehensive explaination.

    seems you have the max effectively, they must be in multiples of 1024 k

    such as
    java -Xms768m -Xmx1024m -cp "Minecraft.jar net.minecraft.LauncherFrame"
    --edited: sorry the classpath switch and path must be together i think
    Last edited by nicephotog; 05-02-2012 at 06:17 AM.

  3. #3
    Just Joined!
    Join Date
    May 2012
    Posts
    3

    still didnt work im afraid :(

    Hey, thanks for your reply. I tyoed in this exactly into the console and just still didnt work:

    java -Xms768m -Xmx1024m -cp "Minecraft.jar net.minecraft.LauncherFrame"

    any ideas at all?

  4. #4
    Just Joined!
    Join Date
    Apr 2012
    Location
    Australia
    Posts
    33
    You could download java 7 if its available or the latest JRE and see if the docs provide for a bigger stack.

    What i compiled with recently 1.5.0_03 may have only 1gb of object-stack maximum on computers 8gb released 4 years previous. now plenty are 16gb.
    couldn't say at this time.
    You would need something like
    JRE 1.6.0_22 or newer to see if it had a change.

  5. #5
    Penguin of trust elija's Avatar
    Join Date
    Jul 2004
    Location
    Either at home or at work or down the pub
    Posts
    3,483
    Quote Originally Posted by Linuxnoobdan View Post
    Hey, thanks for your reply. I tyoed in this exactly into the console and just still didnt work:

    java -Xms768m -Xmx1024m -cp "Minecraft.jar net.minecraft.LauncherFrame"

    any ideas at all?
    When you say it didn't work...

    Did you get an error message? (If yes can you post the message please)
    Did nothing happen?
    What do we want?
    Time machines!

    When do we want 'em?
    Doesn't really matter does it!?


    Conkybots: Interactive plugins for your Conkys!

  6. #6
    Just Joined!
    Join Date
    May 2012
    Posts
    3
    Hey,
    It just comes up telling me all the java commands.

  7. #7
    Just Joined!
    Join Date
    Apr 2012
    Location
    Australia
    Posts
    33
    Hey,
    It just comes up telling me all the java commands.
    GOOD your java works in Linux!!!

    UPDATED: I decided to download the .jar files

    I tried the .jar's for linux in windows, i went to the download page because that's absurd what appears to be the problem but .jar is still a headache in UNIX platforms.

    from the download page (when the java window for 89Kb pops you will be able to "login" in the bottom right corner):
    ..."You'll be able to play the game without an Internet connection if you've been online at least once."...

    I think you start the minecraft_server.jar (621 KB)
    and then you use it with the minecraft.jar (89 KB).
    both together.
    (open a terminal for each and cd into the folder e.g. make a folder called "minecraft" for both .jar to be in)
    1. have your internet connection open (with something such as KPPP. "KDE desktop is generally the most stable")
    2. Start the server first
    3. then start the user app(p/player i think)



    You can play around with the command lines after but i took down two Linux .jar and ran them in windows
    minecraft.net/download
    one is for a server (pops a GUI but is only a logging device you need to learn the "keys" to press to control it) minecraft_server.jar (621 KB) with java -Xmx1024M -Xms1024M -jar minecraft_server.jar
    the second
    is for standalone of a user i think (this is a GUI for playing in and logging in) (89 KB)
    java -Xmx1024M -Xms512M -cp Minecraft.jar net.minecraft.LauncherFrame


    This one worked on the windows prompt (remember whether prompt or terminal the command should be issued from within the same folder as the .jar)

    java -jar Minecraft.jar -Xmx1024M -Xms512M net.minecraft.LauncherFrame


    Help wiki for MINECRAFT:
    minecraftwiki.net/wiki/Setting_up_a_server#Start_the_Minecraft_Server_.28 .jar_version.29

    ======================= other inf i did earlier


    open your .jar with the archiver "Ark" from its interface and tell us if it has a folder META-INF and show us the lines in the the file in it called MANIFEST.MF

    It should appear alike this next (just the three lines, also your minecraft docs probably tell you which version it is compiled in so swap 1.5.0_03 with whatever that is):
    =============================
    Manifest-Version: 1.0
    Created-By: 1.5.0_03 (Sun Microsystems Inc.)
    Main-Class: net.minecraft.LauncherFrame


    If it hasn't, make a file MANIFEST.MF, put that into there in META-INF (one blank line at the end)(META-INF/MANIFEST.MF) with ark as a remove the file replace the file GUI action
    then cd into its folder you start the .jar in with the terminal, and try this
    java -Xms768m -Xmx1024m -jar Minecraft.jar

    just another note from looking up the java command on the prompt next maybe possible too
    (note: there was update to the programming model of using .jar callled "packaging" in the Java language around the 1.5.x version releases)
    java -Xms768m -Xmx1024m -jar Minecraft.jar net.minecraft.LauncherFrame

    -cp maybe to notify "extensions" mechanisms or other "add-on" classes(part of the Java language framework as a whole)

    *next: Just a thought:
    I would not say the next were how the interpreter sees it but may be but is effectively an argument to the jar file(this piece net.minecraft.LauncherFrame is Java JNDI naming syntax(used in package directories syntax) and perhaps should be in quotes though quotes are generally because of spaces in directory/"resource" names)
    java -Xms768m -Xmx1024m -jar Minecraft.jar -cp net.minecraft.LauncherFrame
    Last edited by nicephotog; 05-04-2012 at 12:27 PM.

  8. #8
    Just Joined!
    Join Date
    Apr 2012
    Location
    Australia
    Posts
    33
    This reply cause an email update, i've had a real look at it for you.
    It appears to operate ok. see the previous post, i've changed it.

    Actually the download at the minecraft forum page has two folders "server" and "bin"
    that has effectively both jars with slightly different names.

    If its not the "you need premium service" with the download page it becomes
    no client starts with the one from the forum page in "bin"


    also you need to set the server.properties file to ip address 127.0.0.1

    YEAH, gotcha, that's a bit nasty by that gaming company to be so misleading!!! It hasn't properly or fairly explained anything
    nice point about the wiki forum about it but finally only something at ten years programming in java and UNIX has a chance
    Last edited by nicephotog; 05-04-2012 at 02:26 PM.

  9. #9
    Linux Enthusiast Bemk's Avatar
    Join Date
    Sep 2008
    Location
    Oosterhout-NB, Netherlands
    Posts
    525
    I honestly don't understad what that net.minecraft.LauncherFrame is doing there, since when I add it to my command it doesn't work either.

    This is the command I use to start Minecraft:
    java -Xmx1024M -Xms512M -jar minecraft.jar
    Full time computer science student, spare time OS developer.
    @bemk92 on twitter.

  10. #10
    Just Joined!
    Join Date
    Apr 2012
    Location
    Australia
    Posts
    33
    No,it does "start" (the client - there are two parts client interface and server-interface), i downloaded the .jar's for Linux from the site this person got the game from, and there were two different places could acquire download, and both types were structured(jar's and container) a different way. Then the techniques of setup included localhost, ip internet and multiplayer and single player.
    The supposed reason for the two different download systems were said to be for one being a type of freeware old-version and a new pay for play version.

    note: /bin/minecraft.jar is not operating
    the separate download
    Minecraft.jar does operate
    note the case sensitive names.
    java -jar Minecraft.jar -Xms768m -Xmx1024m net.minecraft.LauncherFrame does start and is the separated .jar "DOWNLOAD" client interface.

    What the free one is, is a little interesting, you download the "classic" version .jar BUT, you remain requiring to connect to the internet using URL encoded "get" querystring(CGI) and configure the call to the client interface page on the minecraft.net server (a jsp page with an Applet viewer embedded in the page).
    The download is "minecraft_classic_server.zip" on URL
    minecraft.net/classic/list page


    It isn't well explained, they as well may wait for a turn on the actual server for being online.

    I just think i better add it is truly misleading and not well layed out pages and information they have at minecraft, but
    what gets me the most is why they think they can have the servers so accessible to children under 16 whom don't have
    the rights and capacity of operating a lease hold telecommunication connection for servers.
    The software should be clearly explained as what they get and can have which effectively is online through the minecraft site
    only inclusive if they install a server on their own machine.

    Its a bit rude by that company.

    Its not that it bothers geek children to set it up, its they'd have thousands more chewing on rubber servers and rubber games that cannot understand what they are actually doing.
    Last edited by nicephotog; 05-06-2012 at 11:44 AM.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •