Find the answer to your Linux question:
Results 1 to 9 of 9
I just installed Mint 13 MATE on a SSD and changed the Screensaver and Power Management settings so the PC or monitor do not sleep when idle, yet after a ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jun 2007
    Location
    UK
    Posts
    18

    Question Stopping screen going blank when idle Mint 13 MATE


    I just installed Mint 13 MATE on a SSD and changed the Screensaver and Power Management settings so the PC or monitor do not sleep when idle, yet after a few minutes of not using it the screen goes blank and I have to wake the computer up by moving the mouse.
    I havn't touched any settings on the actual monitor so I know this is a OS problem.
    Have I missed a setting? How do I stop it from sleeping?

    Thanks for any help

  2. #2
    Linux User Krendoshazin's Avatar
    Join Date
    Feb 2005
    Location
    London, England
    Posts
    471
    Here is the ServerFlags section from my copy of /etc/X11/xorg.conf. I found that to reliably disable blanking you have to disable everything:
    Code:
    Section "ServerFlags"
            Option "BlankTime" "0"
            Option "StandbyTime" "0"
            Option "SuspendTime" "0"
            Option "OffTime" "0"
    EndSection

  3. #3
    Just Joined!
    Join Date
    Jun 2007
    Location
    UK
    Posts
    18
    I navigated to /etc/X11 but do not have a /xorg.conf file, only a xorg.conf.failsafe file. Should I create one and add your text?

  4. $spacer_open
    $spacer_close
  5. #4
    Linux User Krendoshazin's Avatar
    Join Date
    Feb 2005
    Location
    London, England
    Posts
    471
    I'm sure there's a way to do it without creating a xorg.cong file, but I'm not sure how; most of Xorg these days is configured automatically. You can try creating a xorg.conf file and see if the values in there will take effect.

  6. #5
    Just Joined!
    Join Date
    Sep 2012
    Posts
    1
    Quote Originally Posted by Krendoshazin View Post
    Here is the ServerFlags section from my copy of /etc/X11/xorg.conf. I found that to reliably disable blanking you have to disable everything:
    Code:
    Section "ServerFlags"
            Option "BlankTime" "0"
            Option "StandbyTime" "0"
            Option "SuspendTime" "0"
            Option "OffTime" "0"
    EndSection

    It worked for me, there was no xorg.conf file in system so I just created a blank one and pasted the option code in. Thanks for the tip

  7. #6
    Just Joined!
    Join Date
    Dec 2006
    Posts
    21
    From EdWh
    I know this is fairly old post but for those not used to Mint 13. The controls for the display values are located in the control center under screen savers. Cllick on the start up menu and go to control center and you will find "screen Savers" icon, click on it and set to never for display. Default is way to low about 15 minutes and will turn off display while new system is loading, have to move mouse to bring it back. Hope it helps, heck of a place to put controls. Nice system except there is no way to add a extra hdd to act as a extention of free space as is in windows where any new volume is given a letter and you can install programs to the drive.

  8. #7
    Just Joined!
    Join Date
    Feb 2013
    Posts
    1
    Quote Originally Posted by EdWh View Post
    From EdWh
    I know this is fairly old post but for those not used to Mint 13. The controls for the display values are located in the control center under screen savers. Cllick on the start up menu and go to control center and you will find "screen Savers" icon, click on it and set to never for display. Default is way to low about 15 minutes and will turn off display while new system is loading, have to move mouse to bring it back. Hope it helps, heck of a place to put controls. Nice system except there is no way to add a extra hdd to act as a extention of free space as is in windows where any new volume is given a letter and you can install programs to the drive.
    Thank you for taking the time to make this post. You solved my problem and I didn't have to create a file with additional commands! Again, thank you for making this post.

  9. #8
    Just Joined!
    Join Date
    Oct 2013
    Posts
    1

    Red face It worked for me too.

    Quote Originally Posted by Krendoshazin View Post
    Here is the ServerFlags section from my copy of /etc/X11/xorg.conf. I found that to reliably disable blanking you have to disable everything:
    Code:
    Section "ServerFlags"
            Option "BlankTime" "0"
            Option "StandbyTime" "0"
            Option "SuspendTime" "0"
            Option "OffTime" "0"
    EndSection
    This worked on my Linux Mint 15 Mate system. My system is connected to my TV via HDMI and I was experiencing the problem where the screen would go blank about every 5 minutes unless I moved the mouse. It didn't matter what my power settings or screen saver settings were, this would still happen. It was extremely annoying because it meant that I could not watch a movie or listen to music which was the main purpose of this system. If I had music playing it would suddenly stop when the sceen went blank because it was going via the HDMI.

    The 'xorg.conf' file did not exist on my system, so I simply created it and copied the text above into it. Then I rebooted the computer and now all is working great. Out of all the solutions to fix or to get around this issue, this solution was by far the easiest and best one.

    Thanks very much,
    Tom.

  10. #9
    Just Joined!
    Join Date
    Oct 2014
    Posts
    1
    i'm having the same issue in linux mint 17 qiana x86_64 kernel 3.13.0-24-generic. like tommyinoz it is annoying as i often hook my computer up to the tv via a HDMI cord to stream big, i also often watch documentaries posted to youtube as i fall asleep. i have no screensaver option in preferences, and i set my power management settings to never sleep when idle. all this did was bring up my desktop background and desktop clock after 10mins (no conky or docky though) instead of a blank screen. i tried the above solution but it wasn't working. tried accessing xorg.config and pasting the provided code in terminal, it did not recognize the command. i'm pretty new at this, i've only been using linux for three days so...

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •