Find the answer to your Linux question:
Results 1 to 6 of 6
Hi folks... I have an Asus laptop 64bit Win 7 machine. on which Id like to run both Win 7 AND Mint 2x 1/2Tb Hdd. Both Hdd are partitioned. C: ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Dec 2011
    Posts
    36

    Frozen install


    Hi folks...

    I have an Asus laptop 64bit Win 7 machine. on which Id like to run both Win 7 AND Mint

    2x 1/2Tb Hdd. Both Hdd are partitioned. C: for OS (win7) D: for user... on the first Hdd.

    The second Hdd is E: user and F: user and win7 Backup.

    I cleared the E: partition so I could install MINT on it.

    I booted off Mint disk and it runs fine... BUT when I tried to install it... it got ALMOST done then told me I was low on disk space. I was like WTF!?!?!?!

    To my knowledge Mint doesn't need more than 230 Gb of space to install thus I was needless to say surprised to see this message.

    I canceled the install but it became non responsive and had to force close the installer...

    I tried to install it again a slightly different way and again it got almost done (about where it gave me memory problem) but then it just stopped and did nothing. (no error this time) Eventually I canceled out and forced close AGAIN because I was done at work and needed to take my machine home.

    I shut down the machine and have yet to try it again...
    I may try again now that It's been off then on again and I'm home and have more time to fuss with it...

    Don't suppose anyone here has any suggestions on what I may be doing wrong...

    CHEERS

  2. #2
    Linux Guru
    Join Date
    Oct 2007
    Location
    Tucson AZ
    Posts
    3,113
    Boot the Mint CD to the Desktop and before you click the Install icon, click the Menu in the lower left and open a terminal and run this command: sudo fdisk -l(lower case Letter L in the command) to output drive/partition information. It would he helpful to also run: df -h, post the output here.

    Booting the Mint Live CD to the Desktop and then clicking on the Install icon should give you the Welcome screen where you select your language, then a Preparing to Install Mint screen which tells how much drive space is needed and tells whether you are connected to the Internet. The next screen is the Installation Type which should have three options. Which did you select? The best to have control and see what is happening is "Something Else" option.

    2x 1/2Tb Hdd. Both Hdd are partitioned. C: for OS (win7) D: for user... on the first Hdd.

    The second Hdd is E: user and F: user and win7 Backup
    The information above is meaningless in a Linux installation as drive/partition naming conventions are different which is why the fdisk output asked above would be helpful.

  3. #3
    Just Joined!
    Join Date
    Dec 2011
    Posts
    36
    yeah just learned about the df -h command...

    I tried the install again and it was successful but the laptop refused to boot off the second Hdd... the "E:" drive that i had cleared equated to the sdb if i recall correctly and the partition was sdb1 I put grub in that drive and even tho it installed correctly it wouldn't let me boot.

    so I tried it a 4th time... this time I put grub in sda or sda1 (cant recall) (equivalent of "C:" and it did work... when it booted it gave the option of mint or win7... tho it didn't give me long to choose... seems to be working now. should hove messed with it more before posting

    OTz Gomen Gomen

    umm is there a way to tell grub to give me a bit longer to choose what OS I want to boot to??? ALSO with this fresh install it still looks like I Have that other install of mint on that Hdd... looks to be taking up about 3 GB if that sounds right... anyone know how I might be able to clear that off... or if nothing else boot to it so I can use it as well?

    Cheers

  4. #4
    Linux Guru
    Join Date
    Oct 2007
    Location
    Tucson AZ
    Posts
    3,113
    I tried the install again and it was successful but the laptop refused to boot off the second Hdd
    Your second hard drive 'should' have been shown as sdb during the Mint installation and you should have selected '/dev/sdb' as Device for bootloader installation. If you did that, you would then select the second drive to boot from in the BIOS and it should have given you the option to boot Mint or windows.

    so I tried it a 4th time... this time I put grub in sda or sda1 (cant recall)
    That would be sda which means you installed part of Grub in the master boot record of the first (windows) hard drive. That should not be a problem but understand that if this is the case, if you decide to delete or reformat Mint, you will no longer be able to boot windows as most of the Mint Grub boot files are on its partition. If you have a windows installation CD, you can repair that later. Given the size of your drives, it would be simpler to just leave Mint until you are more familiar with bootloaders.

    To change the timeout for Grub boot menu, open this file as root in Mint: /etc/default/grub. Use sudo gedit from a terminal or sudo nautilus to open that file, need to be root (sudo) user to edit it. There is a line near the top of this file: GRUB_TIMEOUT=10, the default is usually 10 but you can change it to whatever you like.
    You can format the partition where the old install is. It might be useful to post the fdisk -l and df -h output and indicate which partition it is on.

  5. #5
    Just Joined!
    Join Date
    Dec 2011
    Posts
    36
    Quote Originally Posted by yancek View Post
    Your second hard drive 'should' have been shown as sdb during the Mint installation and you should have selected '/dev/sdb' as Device for bootloader installation. If you did that, you would then select the second drive to boot from in the BIOS and it should have given you the option to boot Mint or windows.



    That would be sda which means you installed part of Grub in the master boot record of the first (windows) hard drive. That should not be a problem but understand that if this is the case, if you decide to delete or reformat Mint, you will no longer be able to boot windows as most of the Mint Grub boot files are on its partition. If you have a windows installation CD, you can repair that later. Given the size of your drives, it would be simpler to just leave Mint until you are more familiar with bootloaders.

    To change the timeout for Grub boot menu, open this file as root in Mint: /etc/default/grub. Use sudo gedit from a terminal or sudo nautilus to open that file, need to be root (sudo) user to edit it. There is a line near the top of this file: GRUB_TIMEOUT=10, the default is usually 10 but you can change it to whatever you like.
    You can format the partition where the old install is. It might be useful to post the fdisk -l and df -h output and indicate which partition it is on.
    Odd thing but I couldn't get the bios to boot from the second Hdd... but you are right I can probably deal with that later.

    As for formating the partition where the old install is... That's a no go because it SHOULD be the same partition where the new (current) install is.. I can post fdisk -l and df -h if you would be so kind as to refresh my memory on how to post CODE in the forums... (i forgot)

    also thanks for the info on GRUB does it need to be gedit or nautilus? i'm really familiar with them... Can I use nano ???

    Thanx again

  6. #6
    Linux Guru
    Join Date
    Oct 2007
    Location
    Tucson AZ
    Posts
    3,113
    how to post CODE in the forums...
    Not sure what you mean by that, do you mean using code tags to post? Click the hash mark (#) at the top of the input box and paste code there. You can use nano to edit the file, I think gedit is the default text editor which is why I suggested it.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •