Find the answer to your Linux question:
Results 1 to 6 of 6
Like Tree2Likes
  • 1 Post By jayd512
  • 1 Post By jayd512
hi in Linux bash , when you type for example 'a' an then press tab , it show all commands that start with 'a' , how can i disable this ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jul 2012
    Posts
    13

    help me !


    hi
    in Linux bash , when you type for example 'a' an then press tab , it show all commands that start with 'a' , how can i disable this feature ?

    thank you

  2. #2
    Linux Newbie hagfish52's Avatar
    Join Date
    Dec 2011
    Location
    Asheville, NC
    Posts
    225
    Don't understand why you want to. Tab isn't good for anything else in Terminal anyway.

  3. #3
    Administrator jayd512's Avatar
    Join Date
    Feb 2008
    Location
    Kentucky
    Posts
    5,023
    I've never thought to try this, but I think you can add this:
    Code:
    set disable-completion on
    Or this:
    Code:
    bind 'set disable-completion on'
    to your /etc/inputrc file.
    ayaranad likes this.
    Jay

    New users, read this first.
    New Member FAQ
    Registered Linux User #463940
    I do not respond to private messages asking for Linux help. Please keep it on the public boards.

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined!
    Join Date
    Jul 2012
    Posts
    13
    Quote Originally Posted by jayd512 View Post
    I've never thought to try this, but I think you can add this:
    Code:
    set disable-completion on
    Or this:
    Code:
    bind 'set disable-completion on'
    to your /etc/inputrc file.
    Thank you very very much.
    it works.

  6. #5
    Just Joined!
    Join Date
    Jul 2012
    Posts
    13
    Quote Originally Posted by hagfish52 View Post
    Don't understand why you want to. Tab isn't good for anything else in Terminal anyway.
    I changed some of my command !! and for security reason i want to disable this feature .

  7. #6
    Administrator jayd512's Avatar
    Join Date
    Feb 2008
    Location
    Kentucky
    Posts
    5,023
    Quote Originally Posted by ayaranad View Post
    Thank you very very much.
    it works.
    Good deal! Glad it worked out!
    If all is working as you wanted, you can mark this thread as [SOLVED] using the Thread Tools near the top of the page.
    ayaranad likes this.
    Jay

    New users, read this first.
    New Member FAQ
    Registered Linux User #463940
    I do not respond to private messages asking for Linux help. Please keep it on the public boards.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •