Find the answer to your Linux question:
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 13
I'm always looking for the new thing with Distro's and wanted to try BTRFS. I have read that it is better for SSD's as it does not journal or record ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Aug 2012
    Location
    Lyons, CO
    Posts
    7

    LMDE install with BTRFS


    I'm always looking for the new thing with Distro's and wanted to try BTRFS. I have read that it is better for SSD's as it does not journal or record metadata. I currently use JFS for that reason.

    The other day I tried installing and LMDE on a 60GB SSD drive with BTRFS and the following partitions:

    /boot
    /root
    /home

    Upon reboot I was issued an error shown here:
    IMAG0088.jpg

    I even tried installing with just / - same outcome.
    Has anyone encountered this and if so, how can I fix it?

    Thanks in advance!

  2. #2
    Linux Newbie hagfish52's Avatar
    Join Date
    Dec 2011
    Location
    Asheville, NC
    Posts
    225
    Sorry, but your image doesn't have enough resolution to see what's going on. Could you type it out for us?

  3. #3
    Just Joined!
    Join Date
    Aug 2012
    Location
    Lyons, CO
    Posts
    7
    Where the problems start, the terminal reads:
    fsck: fsck.btrfs: not found
    fsck: error 2 while executing fsck.btrfs for /var/run/rootdev
    fsck died with exit status 8
    failed (code
    An automatic file system check (fsck) of the root filesystem failed. A manual fsck must be performed, then the system restart
    on mounted in read-only mode. ...failed!
    The root filesystem is currently mounted in read-only mode. A maintenance shell will now be started. After performing system the system. ...(warning).
    Give the root password for maintenance
    (or type control-D to continue):


    I entered password and did not know the correct commands to perform "maintenance" requested, especially if btrfs has no fsck.

    I appreciate ANY help you can offer.

  4. $spacer_open
    $spacer_close
  5. #4
    Linux Newbie hagfish52's Avatar
    Join Date
    Dec 2011
    Location
    Asheville, NC
    Posts
    225
    This sounds like your problem: Linux Mint Forums • View topic - [SOLVED] Disable fsck on btrfs It was solved by editing fstab to disable running fsck. But I'm a little worried that may not work if your filesystem is mounted "read only". Give it a try.

  6. #5
    Just Joined!
    Join Date
    Aug 2012
    Location
    Lyons, CO
    Posts
    7
    I tried that in a subsequent install and was unsuccessful as well.

  7. #6
    Linux Newbie hagfish52's Avatar
    Join Date
    Dec 2011
    Location
    Asheville, NC
    Posts
    225
    Did you follow this procedure for the installation? Linux Mint Forums • View topic - HOW-TO: Install LMDE with BTRFS and Snapshots If you didn't you might give it a try.

  8. #7
    Just Joined!
    Join Date
    Aug 2012
    Location
    Lyons, CO
    Posts
    7
    Do you know why I would have an unsuitable fstab.d file?I just installed ext4 without journaling

  9. #8
    Linux Newbie hagfish52's Avatar
    Join Date
    Dec 2011
    Location
    Asheville, NC
    Posts
    225
    fstab file. From what I read the OS insists on a file check of the filesystems (in this case the btrfs filesystems) with fsck during startup, but btrfs can't use fsck, it uses btrfsck instead, so you wind up with the fsck error. So the fsck scan has to be turned off.

  10. #9
    Just Joined!
    Join Date
    Aug 2012
    Location
    Lyons, CO
    Posts
    7
    I reinstalled using ext4 as a filesystem so I can shut off journaling and cannot edit /etc/fstab file, (noatime, run tmp in ram, etc...)

  11. #10
    Linux Newbie hagfish52's Avatar
    Join Date
    Dec 2011
    Location
    Asheville, NC
    Posts
    225
    Well, to edit anything in in /etc you have to use sudo, but I don't think what you are doing will get you where you want to go. You don't want to start with an EXT4 filesystem. Follow the procedure in the link I gave you. The first step is to load the LMDE Live DVD, and then create a partition on your HDD and format it BTRFS with gparted (you run "sudo gparted" in Terminal). Later on, in step 5, fstab is created (if it isn't there already) with the nano text editor and the file is edited. You may have to use "sudo nano /etc/fstab" instead of just "nano /etc/fstab". If there already is an fstab, and it has other entries, you should comment them out with a # at the left edge.

Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •