Find the answer to your Linux question:
Results 1 to 4 of 4
I got a big problem on my hand, I may lose everything on my harddrive if I don't fix it. It's life or death right now. So this is what ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Sep 2012
    Posts
    7

    Boot loader corrupt


    I got a big problem on my hand, I may lose everything on my harddrive if I don't fix it. It's life or death right now.

    So this is what happened, I installed Linux from a usb flash drive, it went well, when I restarted, the boot loader was there, and I booted up Linux normally. But I get a problem where when I try to install an app from software manager, it'll download half way, or almost half then suddenly stop. I always get this prob (I've installed Linux like 3-4 times on this HDD so far)
    I restarted my computer to get into windows 7, but the bootscreen is corrupted, saying the partition doesn't exist, and Im able to typ ein commands. Says Grub rescue on the left of the command lines.
    I tried using the recovery partition to use startup repair to fix the boot, but it isn't working this time.
    All I can do is boot Linux from my usb flash drive, and hope for help somewhere on a forum.

    I remembered that I installed Linus before, so now I have two partitions for Linux now. They both showed up in the boot loader. I might be able to use Gparted on Linux to fix my partitions.

    Screenshot of gparted:
    http (space<-- delete)://img849.imageshack.us/img849/4503/screenshotfrom201209090.png

    The two 58 GB partitions are my Linux partitions. The OS partition is my main one with windows 7 installed on it.


    If anyone can help me with this problem, it'll be the nicest thing anyone can do!
    Last edited by Mattkimura; 09-10-2012 at 12:50 AM.

  2. #2
    Linux Guru
    Join Date
    Oct 2007
    Location
    Tucson AZ
    Posts
    3,190
    I tried using the recovery partition to use startup repair to fix the boot, but it isn't working this time.
    For Mint? I thought you were able to boot Mint? Are you doing this to try to access windows?

    I can't even load the C drive from linux when I usually can
    Do you mean you are not able to mount the windows partition from Mint? If so, how are you doing it? What commands? Are you root user when doing it?

    I would suggest you go to the site below and read the instructions on using the bootinfoscript, download and run it from Mint if you are able to boot it, otherwise use the Mint flash drive. You should get output in the form of a results.txt file which you can post here and get help. It will give detailed information on your drives/partitions and boot files:

    Boot Info Script | Free System Administration software downloads at SourceForge.net

  3. #3
    Just Joined!
    Join Date
    Sep 2012
    Posts
    7
    Thanks for the reply. I greatly appreciate it, it's hard to get help anywhere
    I'll try to make my situation more clear.
    I currently can't boot into windows 7, or any of the two linux mint 13 partitions I isntalled. When I come to the bootscreen, it just says error: no such partition and I can't boot anything. Unless I can type in specific commands (it lets me type)
    So Only way to boot into any kind of OS is to boot my usb flash drive which has Linux Mint 13 on it.
    And about me not being able to access my hard drive, that's changed now. When I click on the C drive on Linux, it wouldnt let me into it. But I kept clicking it later, and it let me in, and Im able to see al my files on my c drive.
    About using the recovery partition, I do this by pressing F11 when I first turn on my PC.

    I used the program and here are the results:

    vvv fix the link

    http(space<--Delete)://pastebin.com/PnEzMwTf
    Last edited by Mattkimura; 09-10-2012 at 01:14 AM.

  4. #4
    Just Joined!
    Join Date
    Sep 2012
    Posts
    7
    Problem solved!! I'm finally back on Windows 7, removed the Linux partition, restored my boot to normal.
    My solution:
    Using Linux from my usb flash drive, I ran a command in the terminal:

    sudo apt-get install lilo
    sudo lilo -M /dev/sda mbr

    Then I restarted, and the boot menu was working again, but its the Linux grub menu. When I loaded up windows 7, I would get a black screen with my cursor on it. So I restarted, launched my recovery partition and did a system restore from a few days ago. Now Im able to get into windows 7 normally
    I removed the Linux partitions, got all my space back. If I do a Linux install, I'll either do Mint4win, or what someone suggested, Knopper.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •